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About this book

Use of warning, caution, information, and tip icons
This publication includes Warning, Caution, and Information where appropriate 
to point out safety related or other important information. It also includes Tip to 
point out useful hints to the reader. The corresponding symbols should be 
interpreted as follows:

Although Warning hazards are related to personal injury, and Caution hazards are 
associated with equipment or property damage, it should be understood that 
operation of damaged equipment could, under certain operational conditions, result 
in degraded process performance leading to personal injury or death. Therefore, 
comply fully with all Warning and Caution notices.

Electrical warning icon indicates the presence of a hazard which could result in 
electrical shock.

Warning icon indicates the presence of a hazard which could result in personal 
injury.

Caution icon indicates important information or warning related to the concept 
discussed in the text. It might indicate the presence of a hazard which could 
result in corruption of software or damage to equipment/property.

Information icon alerts the reader to pertinent facts and conditions.

Tip icon indicates advice on, for example, how to design your project or how to 
use a certain function
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Terminology
The Glossary contains terms and abbreviations that are unique to ABB or have a 
usage or definition that is different from standard industry usage. Please make 
yourself familiar to that.

You will find the glossary at the end of the Engineering Manual Freelance 
Operations.

Document conventions
The following conventions are used for the presentation of material:

• The words in names of screen elements (for example, the title in the title bar of 
a window, the label for a field of a dialog box) are initially capitalized.

• Capital letters are used for the name of a keyboard key if it is labeled on the 
keyboard. For example, press the ENTER key.

• Lowercase letters are used for the name of a keyboard key that is not labeled on 
the keyboard. For example, the space bar, comma key, and so on.

• Press CTRL+C indicates that you must hold down the CTRL key while 
pressing the C key (to copy a selected object in this case).

• Press ESC, E, C indicates that you press and release each key in sequence (to 
copy a selected object in this case).

• The names of push and toggle buttons are boldfaced. For example, click OK.

• The names of menus and menu items are boldfaced. For example, the File 
menu.

– The following convention is used for menu operations: MenuName > 
MenuItem > CascadedMenuItem. For example: select File > New > Type.

– The Start menu name always refers to the Start menu on the Windows 
Task Bar.
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• System prompts/messages are shown in the Courier font, and user 
responses/input are in the boldfaced Courier font. For example, if you enter a 
value out of range, the following message is displayed:

Entered value is not valid. The value must be 0 to 30. 

You may be told to enter the string TIC132 in a field. The string is shown as 
follows in the procedure:

TIC132

Variables are shown using lowercase letters.

sequence name
Operators Manual - Archive Browser 9
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1  Archive Browser

1.1 Archive Browser- General description
Freelance Archive Browser is an additional program for the Freelance system and 
requires a license.

Archive Browser permits viewing archived trend, log files and reports without the 
use of Freelance operator stations. The data can be presented in graphic form or as 
tables. The graphic presentation can be scaled as desired, to facilitate examination 
of particular past process events. In addition, it is possible to convert the data to 
ASCII format, making it readable by other programs, such as, for example, data 
base or spread sheet programs.

The transfer of archive files from the different operator stations is either automatic, 
manual or event-driven, as configured in Freelance Engineering. It is also possible 
to configure for files archived at a Operator station to be transferred to the PC on 
which the Freelance Archive Browser is installed.

1.1.1 Starting Archive Browser

1.1.2 Requirements for receiving data through FTP export

The PC which is to receive the archives must have a network communication link 
with the Freelance Operations PC. For more information on installing and 
configuring of FTP server, refer to Introduction - Getting Started FTP Export is 
configured in the parameter-setting dialog for trend displays or logs at the relevant 
operator station.

Windows 7: 
Start > All Programs > ABB > Freelance <version> > Archive Browser

Windows 10: 
Start > ABB > Archive Browser
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The Station is determined by the IP address input for the target computer, e.g. 
“172.16.1.24”. If the archive files are being copied to a directory, the full name of 
the directory must be given.When setting parameters for the trend display or log, 
you need only enter a backslash\, possibly followed by the rest of the branch of the 
path. For example, the path C:\ARCHIV\STATION1\SSL for the target computer 
may mean that it diverts all input archives to the default path C:\ARCHIV and the 
incoming archive contributes the path information \STATION1\SSL.

In the FTP Export File setting the export file is stored once, with the filename given 
in the target path, for example: STATION1\SSL\SSL_PRODUCTION. The file is 
overwritten each time an item is exported. The path and filename together may have 
length of 100 characters.

In the Directory [8.3] setting export files are transmitted in DOS format - e.g. to a 
PC with a Windows operating system and activated FTP server. The filename 
corresponds to the export date, in the format ‘YMMDDHHm.mss’, e.g. 
70528162.320.

In the Directory setting export files are stored in the directory specified in the target 
path, under their original name (from parameter mask 1). This name is followed by 
the export date - separated by a dot - in the format ‘.YYMMDDHHmmss’.

Example: SSL_PRODUCTION.970528162320.

The path and filename together may have a length of 100 characters.

The user name and password must correspond to a valid user of the target station 
(see Windows User Manager).

It should be noted that the target computer is responsible for further file 
processing in data transmission. The copied file is only temporary and is 
overwritten next time the relevant archive is exported.

The path to the archive store at the target station needs to be kept available and 
must not be write-protected.

The filename does not contain any information about the type of archive. Choose 
a path name which will ensure that it is recognized later.
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1.1.3 Menu structure of the Archive Browser

File Open Window Trend Hardcopy

Close Cascade

Export Tile horizontal

Move Tile Vertical

Copy Arrange Icons

Delete Close All

Exit Refresh File Manager F5

View Archive Manager Help Contents F1

Search

About Archive Browser

Edit Goto

Options Default view List/Trend

Switch trend-list

Trend options

Search path

Column width

Archive manager

Format Column Fade in

Fade out

Fade in all

Read defaults

Define
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1.1.4 Call-up of the archive manager

After being called up, a file manager appears listing the available archive files, i.e. 
the archive found in the configured search path. See also Search path on page 23.

di4201_us.png

The available files and their directories are shown in the left window. Only filed 
archives found by following the set search path are displayed.

In the right window, information is listed relating to the different versions of the 
selected archive which can be examined.

1.2 Archive display

1.2.1 Trend archives

Tabular presentation is preselected for the logging and trend archives. However 
trends can also be shown as curves.

Selecting this option changes the presentation of the archive currently selected. If 
another option is chosen the presentation changes again.

The current setting only applies to newly opened windows. Windows which are 
already open retain the existing presentation.

> Select archive from right-hand column > Double-click left mouse button

> Options > Switch trend - list
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Tabular presentation

di4203_us.png

In tabular presentation of a trend the following entries are shown:

• Number and status of record,

• Time stamp of the recorded variables in format DT (Date & Time),,

• Values of variables (maximum 6).

Trend presentation

The desired section of the archive can be brought into view using the scroll bars. 
With the graphical presentation, the scale factor can also be adjusted.
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di4202_us.png

Individual trends can be selected using the above name fields. The name field for a 
selected trend appears raised and the scaling appears in the color for the trend. The 
trend can then be processed as follows, using the buttons at the bottom.

ZoomX+ Shortens the time interval per raster.

ZoomX- Lengthens the time interval per raster.

ZoomY+ Reduces the scale for the Y axis.

ZoomY- Enlarges the scale for the Y axis.
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1.2.2 Trend options

di4207uk.bmp

Colors Colors in the graphics window can be controlled with the 
Foreground, Background and Windows. Reset restores colors to 
their original values.

Name_1..6 These buttons give the name of the variable recorded. Only buttons 
which apply can be seen, according to the number of channels 
recorded. When a variable is selected its scale is shown on the 
Y axis.

di4208uk.bmp

The Y axis can be scaled channel by channel in this mask. The form of presentation 
can also be controlled.

Y-scaling With band start and band end the scaling of the Y axis can be set for 
this trend. The position on the Y axis of the band start and band end 
can be set between 0% and 100% using the band start% and band 
end%.

> Options > Trend options
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Interpolation There is a choice between None, Linear and Steps.

di0559uk.bmp

Marker Can be set as None, Pixels or Rectangle.

If None is selected for both the interpolation and the marker, the 
trend is invisible!

Color The color for the display of the trend and the Y axis scaling is 
determined after marking Select. Reset is for standard color.

For further information, see also manual Freelance Operations , Trend Display.

1.2.3 Signal sequence log SSL1/SSLN

The signal sequence logs are generally found in the <FreelanceData>\sfp directory. 
Double clicking on a file opens a window in which the files contents are displayed.

The band start setting must always be less than the band end. This also applies to 
the band start% and band end%. The percentage values can be less than 0% and 
more than 100%. In this case the part of the trend not between 0% and 100% will 
be displayed as a line above 100% or below 0%.

Band start and band end must be entered as real values. The value range is 
between 0.0 and ±999999999.9.

The percentage values for band start and band end must be entered as integer 
values between 0 and ±5000%
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di4209_us.png

The following data are displayed in the table:

• Record number and status of the entry,

• Time stamp of the recorded variables in format DT (Date & Time),

• Signal content (format dependent).

The entries for the various events are found between the time markers. Which events 
are displayed in which format is specified during configuration. There are special 
formats for process messages, system messages, operator actions and logging 
events. For details, refer to manual Freelance Operations, Logs.

Graphical presentation of the log files is not possible.
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1.2.4 Operation log OPL

The operation logs are generally found in the <Freelance Data>\bpr directory. 
Double clicking on a file opens a window in which the contents of the archive are 
displayed.

di4205_us.png

The table has the following entries:

• Record number and status,

• Time stamp of the recorded variables in format DT (Date & Time),,

• Status

• Names of up to 200 variables,

• Table of the recorded values of the variables.

See also manual Freelance Operations Operators Manual, Logs

Graphical presentation of log files is not possible.
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1.3 Editing files 

di4210_us.png

1.3.1 Opening files

Choose the archive file to be opened. Default filing of archives is done in the 
Freelance data directory under 

\curv for trend files

\ucurv for user-defined trend files

\bpr for operation log files

\sap for disturbance course log files

\sfp for signal sequence log files

1.3.2 Closing files

Closes the selected window.

> File

> File > Open

> File > Close
Operators Manual - Archive Browser 21
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1.3.3 Export

The contents of the archive can be converted to ASCII format (.CSV), so that they 
can be read into a data base or spreadsheet program.

di4212uk.bmp

1.3.4 Deleting files

After confirmation, the archive file selected in the file manager will be deleted.

> File > Export

> File > Delete
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1.4 General settings

1.4.1 Search path

Paths can be entered for use by the archive manager. The archive manager will 
search all paths entered for valid archive files and will list available archive in the 
table. Path entries are separated by semicolons.

di4214us.png

1.4.2 Column width

The width of the columns for the tabular display of archive files can be changed. 
The individual values are separated by semicolons.

di4215uk.bmp

> Options > Search path

> Options > Column width
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1.5 Window settings

di4216uk.bmp

1.5.1 Trend hardcopy

Used to take the print out for the opened Trend window, printer must be configured 
or else it throws the following message

1.5.2 Cascade

All open windows are positioned in cascade.

di4217_us.png

> Window > Trend hardcopy

> Window > Cascade
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1.5.3 Tile horizontal 

All open windows are lined up horizontally.

di4218_us.png

1.5.4 Tile vertical

All open windows are lined up vertically.

1.5.5 Arrange icons 

If any windows were shrunk to icons, the corresponding icons are arranged.

> Window > Tile horizontal 

> Window > Tile vertical

> Window > Arrange icons
Operators Manual - Archive Browser 25
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1.5.6 Close all

All open windows will be closed.

1.5.7 Refresh file manager

The contents of the file manager display will be rebuilt, i.e. the files in the archive 
directories will be reread.

1.5.8 List of open windows

The names of the files displayed in the open windows are listed at the bottom of the 
options menu. When a number of windows are open, an easy way to bring one to 
the foreground is to click on the desired archive here.

di4221_us.png

> Window > Close all

> Window > Refresh file manager

> Options
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