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About this book

Use of warning, caution, information, and tip icons
This publication includes Warning, Caution, and Information where appropriate 
to point out safety related or other important information. It also includes Tip to 
point out useful hints to the reader. The corresponding symbols should be 
interpreted as follows:

Although Warning hazards are related to personal injury, and Caution hazards are 
associated with equipment or property damage, it should be understood that 
operation of damaged equipment could, under certain operational conditions, result 

Electrical warning icon indicates the presence of a hazard which could result in 
electrical shock.

Warning icon indicates the presence of a hazard which could result in personal 
injury.

Caution icon indicates important information or warning related to the concept 
discussed in the text. It might indicate the presence of a hazard which could 
result in corruption of software or damage to equipment/property.

Information icon alerts the reader to pertinent facts and conditions.

Tip icon indicates advice on, for example, how to design your project or how to 
use a certain function
Introduction - Getting Started 9
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in degraded process performance leading to personal injury or death. Therefore, 
comply fully with all Warning and Caution notices.

Terminology
The Glossary contains terms and abbreviations that are unique to ABB or have a 
usage or definition that is different from standard industry usage. Please make 
yourself familiar to that.

You will find the glossary at the end of the Engineering Manual System 
Configuration.

Document conventions
The following conventions are used for the presentation of material:

• The words in names of screen elements (for example, the title in the title bar of 
a window, the label for a field of a dialog box) are initially capitalized.

• Capital letters are used for the name of a keyboard key if it is labeled on the 
keyboard. For example, press the ENTER key.

• Lowercase letters are used for the name of a keyboard key that is not labeled on 
the keyboard. For example, the space bar, comma key, and so on.

• Press CTRL+C indicates that you must hold down the CTRL key while 
pressing the C key (to copy a selected object in this case).

• Press ESC, E, C indicates that you press and release each key in sequence (to 
copy a selected object in this case).

• The names of push and toggle buttons are boldfaced. For example, click OK.

• The names of menus and menu items are boldfaced. For example, the File 
menu.

– The following convention is used for menu operations: MenuName > 
MenuItem > CascadedMenuItem. For example: select File > New > Type.

– The Start menu name always refers to the Start menu on the Windows 
Task Bar.
10 Introduction - Getting Started
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• System prompts/messages are shown in the Courier font, and user 
responses/input are in the boldfaced Courier font. For example, if you enter a 
value out of range, the following message is displayed:

Entered value is not valid.The value must be 0to30. 

You may be told to enter the string TIC132 in a field. The string is shown as 
follows in the procedure:

TIC132

Variables are shown using lowercase letters.

sequence name

Related documentation
The following list gives an overview of the documentation relating to the Freelance 
system.

Title Number

Introduction – Getting Started 3BDD012560

Introduction – New Features History 3BDD011933

Mounting and Installation Instructions, Safety Instructions 2PAA109317

Mounting and Installation Instructions, AC 900F Controller 2PAA109295

Mounting and Installation Instructions, AC 800F Controller 3BDD012501

Mounting and Installation Instructions, AC 700F Controller 2PAA103858

Mounting and Installation Instructions, Rack System 3BDD012603

Mounting and Installation Instructions, I/O Modules for AC 700F/900F 2PAA109294

Engineering Manual, Process Stations 2PAA114393

Engineering Manual, S700 I/O Modules 2PAA105800

Engineering Manual, System Configuration 3BDD012503

Engineering Manual, IEC 61131-3 Programming 3BDD012504
Introduction - Getting Started 11
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Engineering Manual, Functions and Function Blocks 3BDD012514

Engineering Manual, Operator Station Configuration 3BDD012518

Engineering Manual, Communication and Fieldbusses 3BDD012515

Engineering Manual, IEC 60870-5 Telecontrol Library 3BDD012509

Engineering Manual, User Management 3BDD012513

Engineering Manual, Trend Server 3BDD012527

Engineering Manual, OPC Server F 3BDD012511

Reference Manual, DMS / API 3BDD012508

Engineering Manual, Bulk Data Manager 2PAA105801

Operators Manual, Freelance Operations 3BDD011932

Operators Manual, Archive Browser 3BDD012601

Engineering Manual, Process Station - Rack System 3BDD012520

Engineering Manual, I/O Modules for AC 700F / AC 900F 2PAA109292

Engineering Manual, Formulation 2PAA110024

Engineering Manual, OPC Tunnel 2PAA106899

Title Number
12 Introduction - Getting Started
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1  General notes

1.1 Freelance support
For technical assistance, please contact your local service organization.

http://www.abb.com/contacts/ 

or

https://new.abb.com/control-systems 

1.2 System requirements
It is strongly recommended to install the Freelance software on your PC and 
additionally only the third party software mentioned here. Freelance is not tested 
and released together with any other applications.

If you are using other software packages together with the Freelance software and 
should encounter any problems, we request you to uninstall these other software 
packages first.

1.2.1 Operating system

All components of Freelance 2019 can be used with the following versions of the 
Microsoft Windows operating system:

• Windows 7 Professional SP1 32 bit 
• Windows 7 Professional SP1 64 bit 
• Windows 7 Enterprise SP1 32 bit 
• Windows 7 Enterprise SP1 64 bit 

• Windows 10 Pro 32 bit
Introduction - Getting Started 13
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• Windows 10 Pro 64 bit
• Windows 10 Enterprise 32 bit
• Windows 10 Enterprise 64 bit

The Freelance OPC Server and Trend Server can also be used with the following 
versions of the Windows operating system: 

• Windows Server 2016
• Windows Server 2019

This feature is intended for integration with 800xA Operations.

Security updates

It is strongly recommended to install all Microsoft custom suggested security 
updates.

The current results for Microsoft Security update tests for the active Freelance 
versions can be found in ABB Library or in myABB/MyControlSystem in the 
document "Freelance: Microsoft Security Updates Validation Status" 
(2PAA107593).

Service packs and security updates are available free of charge from Microsoft 
Corporation (also on the Internet at http://www.microsoft.com).

System Hardening

The System Hardening function is intended to increase the Freelance system 
security. See the "Freelance Hardening Manual" (2PAA112641) for details about the 
required settings. Essentially, system hardening is achieved by removing 
unnecessary Windows components, deactivating unused Windows services and 
configuring the firewall accordingly.

You can find the Freelance Hardening Manual in the ABB Library and in 
myABB/MyControlSystem

1.2.2 Web browsers

Usage of the web display in a Freelance Operations station requires that the 
Microsoft Internet Explorer or Microsoft Edge is installed on the respective 
Freelance Operations PC. Usage of the diagnosis web pages of the Freelance 
14 Introduction - Getting Started
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process stations requires that the Microsoft Internet Explorer or the web browser 
Microsoft Edge (Windows 10) is installed on the PC used for commissioning. For 
Freelance 2019 this feature is tested and released for version 11 of Microsoft 
Internet Explorer.

1.2.3 Microsoft Office

Usage of the Bulk Data Manager and Excel Reports functionality requires that 
Microsoft Office, especially Microsoft Excel, is installed on the PC. The following 
Microsoft Office/Excel versions can be used with Freelance 2019:

• Office 2016 32 bit 
• Office 2019 32 bit 

1.2.4 Windows user access rights

Installing the Freelance software requires administrator privilege.

Users working with Freelance applications do not need administrator privileges. 
They should be members of the Windows user group "ABB Freelance Basic 
Access".

The creation of Freelance Operations users is supported through the Freelance 
Settings tool (see Modify installation settings on page 68).

1.2.5 Recommended PC equipment

The below-mentioned specifications for PC equipment are recommendations, only. 
They were selected to ensure a fluent workflow and to have good response times. 
Depending on the size of your project you might experience a fluent behavior with a 
less powerful PC as well.

It is recommended to always install and run the OPC Server and Trend Server on 
separate PCs.
Introduction - Getting Started 15
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Freelance Engineering

Freelance Operations

Hard disk for installation  1 GB free disk space

Hard disk for operation 10 GB free disk space

Operating system Microsoft Windows 7 (32/64 bit)
Microsoft Windows 10 (32/64 bit)

CPU speed > 2 GHz

RAM > 4 GB

Ethernet card with supported Interface 10/100 MBit

Hard disk for installation 500 MB free disk space

Hard disk for operation > 2 GB free disk space

Recommended for archiving > 80 GB (depending on configuration)

Operating system Microsoft Windows 7 (32/64 bit)
Microsoft Windows 10 (32/64 bit)

Speed > 3 GHz

RAM 4 GB

Ethernet card with supported Interface 10/100 MBit
16 Introduction - Getting Started
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OPC Server

1.2.6 Freelance network / Control Net

The security of industrial automation and control systems becomes increasingly 
critical as different networks are connected and systems are integrated in a 
collaborative manufacturing environment. For industrial automation and control 
systems the potential impact of an attack may be more serious than for computer 
systems in general. Users of industrial automation and control systems need to pay 
correspondingly increased attention to these issues.

For more details and background information, please refer to the document 
"Security for Industrial Automation and Control Systems" (3BSE032547) in 
the ABB Library and in myABB/MyControlSystem.

1.2.7 Control Net redundancy

Optionally, communication between AC 900F controllers and operator or gateway 
stations and lateral communication between AC 900F controllers is possible using a 
Control Net in a redundant configuration. The following Freelance stations support 
Control Net redundancy:

Hard disk for installation 500 MB free disk space

Hard disk for operation > 2 GB free disk space

Operating system Microsoft Windows 7 and Windows 10
Microsoft Windows 2016 Server
Microsoft Windows 2019 Server

Speed > 2 GHz

RAM > 4 GB

Ethernet card with supported in-
terface

10/100 MBit

It is recommended to separate the Freelance network and the global company 
network. 
Introduction - Getting Started 17
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• AC 900F

• AC 900F redundant

• AC 900F Lite

• AC 900F Lite redundant

• AC 900F Premium

• AC 900F Premium redundant

• Freelance Engineering

• Freelance Operations (operator station)

• OPC Gateway

• OPC Gateway redundant.

ControlNetRed_1_us.png

Communication between the operator stations and gateway stations (horizontal 
communication) is only possible via the configured Ethernet line. Redundancy is 
not supported in this case. Communication between AC 900F controllers (lateral 
communication) and with operator or gateway stations (vertical communication) is 
done via the active Control Net line. In the event of a failure of the active line, a 
18 Introduction - Getting Started
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redundancy toggle to the redundant line occurs within a configurable changeover 
time. 

1.2.8 Network protocol

The network protocol used by Freelance is TCP/IP. No other protocol is required. 
With other network protocols, correct network operation cannot be ensured. 

IP addresses of the address block 172.16.0.0/20 are recommended for addressing 
the stations and resources in a project. The subnet mask 255.255.240.0 is the default 
setting for Freelance. 

IP address settings 

Enter an IP address and subnet mask for the network adapter:

IP address: 172.16.x.x for example, 172.16.1.20

Subnet mask: 255.255.240.0

An address in the same subnet must be assigned to all Freelance stations on the 
same Control Net, e.g. 172.16.0.1 to 172.16.15.254. The first and last addresses of 
the subnet are reserved (broadcast addresses) and must not be used. 

All Freelance stations which no Control Net redundancy support (eg.: AC 800F) 
should only be connected to the Control Net Line A.

If Freelance is installed in a virtualized system, the configuration "Bridged" must 
be selected for the network adapter on the virtualized system.

Windows 7
Start > Control Panel > Network and Internet 
> Network and Sharing Center > Change adapter settings
> Right-click a network adapter > Properties
> Select Internet Protocol Version 4 (TCP/IPv4) > Properties

Windows 10
Windows button > Settings > Network & Internet > Change Adapter Options
> Right-click the appropriate network adapter > Properties
> Select Internet Protocol Version 4 (TCP/IPv4) > Properties
Introduction - Getting Started 19
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For a Control Net in a redundant configuration addresses of a separate subnet must 
be assigned to the network adapters of Line A and Line B, e.g.:

Line A: 172.16.0.1 to 172.16.15.254

Line B: 172.16.16.1 to 172.16.31.254.

Subnet mask for time synchronization

Besides the Windows PCs the process stations need a valid network configuration.

To permit time synchronization, all stations must be located in the same subnet. 

For setting the IP addresses, resource IDs and subnet masks of your controllers, 
refer to the respective Mounting and Installation manuals and in the Engineering 
Manual System Configuration. 

If other subnet masks than 255.255.240.0 are used, make sure that they are 
contiguous. The equivalent bit pattern must start and then continue with 1 values. 
It may change to zeros once and must then end with zeros.

Valid example:

11111111 11111111 11110000 00000000 = 255.255.240.0

Invalid example:

11111111 11111111 11111001 00000000 = 255.255.249.0

When using redundant AC 800F process stations, the subnet mask 255.255.240.0 
must be used.

The IP address of the redundancy link of a redundant controller is automatically 
assigned by the controller itself and cannot be modified. Make sure that 
redundant operation is enabled in the controller.

Stations connected via a router participate neither in the normal time 
synchronization nor in lateral communication. The function “External time 
server” (see Engineering Manual System Configuration, Project tree) can be 
used to implement time synchronization for external process stations.
20 Introduction - Getting Started
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Parameters for DNS server and WINS

No parameters must be set for DNS or WINS, if the software is run on a standalone 
system. The default network settings of the Windows installation can be used 
unchanged to operate a Freelance system. The TCP/IP protocol must be used on all 
PCs.

Usage of host names

Up to Freelance 2013 is was possible to use symbolic names for the computers and 
process stations instead of IP addresses when configuring a project. Freelance 2016 
does no longer support this feature.

When a project is imported from a previous Freelance version, the host names are 
replaced with the IP addresses specified in the host file. The host file does not 
require any further maintenance activities. 

Network configuration check

To check the network configuration between a Windows PC and a controller station 
or between two Windows PCs, use the ping command.

 Enter the ping command to check if a connection to the address can be established.

For example, enter ping 172.16.1.20 to check the connection to the station with 
the IP address 172.16.1.20.

If the connection is OK, the pinged station or computer will reply and a time value 
how long the sent package took to return is printed out. If the connection is not OK, 
a request timed out message is displayed.

If the DNS name resolution is used, this can also be tested with the ping command. 
For example, enter ping opc_gwy.

Windows 7:
Start > Enter cmd > Press [Enter]

Windows 10:
Windows button > Windows System > Command prompt

A windows console window opens (prompt).
Introduction - Getting Started 21
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Windows firewall settings to use the ping command

To check the connection to a Windows computer, the firewall rules on the Windows 
target machine must be adjusted. By default, the Windows firewall blocks incoming 
ping requests. 

1.3 Freelance add-on software packages
With the Freelance 2019 setup CD, compatible software packages such as Freelance 
Formulation, DTMs, Control Aspect (CBF Viewer) and ABB OPC Tunnel are 
provided. Depending on the functionality selected during the setup, these 
components will be installed together with the Freelance software.

When the Freelance software is installed in the Engineering Station or a Combined 
Engineering & Operating Station version, some macros and templates with a 
description file are also installed on the PC in the Freelance installation directory 
<FreelanceData >\.

1.3.1 S700 templates

GSD based templates for easy integration of S700 modules in the Freelance 
hardware configuration. 

export\S700_CI741_Template_US.hwm
export\S700_CI741_Template_DE.hwm
export\S700_DC705F_Template_US.hwm

Open the configuration of the advanced Windows firewall on the target machine 
(not the machine where the ping is entered):

Windows 7:
Start > Control Panel > System and Security > Administrative Tools 
> Windows Firewall with Advanced Security.

Windows 10:
Windows button > Settings > Update & security > Windows Security 
> Firewall & Network Protection > Advanced Settings > Inbound Rules

Enable the inbound firewall rules named File and Printer Sharing (Echo 
Request - ICMPv4-In) to allow ping requests to this computer.
22 Introduction - Getting Started
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1.3.2 User defined function blocks for field devices

User defined function blocks for easy integration of S700 modules in Freelance 
programs:

export\S700_UFBsUS

User defined function blocks for easy integration of S800 modules in Freelance 
programs:

export\S800_UFBsGR
export\S800_UFBsUS

User defined function blocks for easy integration of S900 modules in Freelance 
programs.

export\S900_UFBsUS

User defined function blocks for easy integration of ACS800 drives through 
Modbus RTU in Freelance programs.

export\ACS800_Drives_UFBsUS

1.3.3 Tag type libraries

Example of OPC function block classes for Freelance function blocks for 
connecting a Freelance project through PLC integration functionality:

export\FreelanceSampleTagTypeLib_V1.1.prt

Example of OPC function block classes for AC500 function blocks for connecting 
an AC500 project into a Freelance system through PLC integration functionality:

export\AC500 StandardTagTypeLibrary V1.0.prt

1.3.4 Graphic macros

To support the user in creating complex process displays, several graphic macros are 
prepared and provided during the installation of Freelance Engineering. These 
macro libraries are copied into the directory <FreelanceData>\macros.

• 3D_Macros.bol
The description of this library can be found in the file 3D_Macros Library.pdf 
in the folder “macros”.
Introduction - Getting Started 23
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• hb_sym01.bol
For more information on these macros, refer to Engineering Manual Operator 
Station Configuration, Graphic Display.

• Macros.bol:
This library contains graphic macros that simplify the creation of user defined 
faceplates in the new design of Freelance Operations.

• S900_UFB_macro_library.bol
This library contains graphic macros to be used with S900 device.

• ufp_sym1.bol
This library contains graphic macros that simplify the creation of user defined 
faceplates in the conventional design of Freelance Operations. For more 
information, refer to Engineering Manual IEC 61131-3 Programming, User-
defined Function Blocks.

1.3.5 Terminal emulation

For diagnosis purposes a debug terminal can be connected to a Freelance controller. 
When installing Freelance Engineering, a terminal emulation program is installed in 
the following folder: <Freelance_installation_folder>\exe\Terminal.exe.
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1.4 Compatible fieldbus software

1.4.1 PROFIBUS DTMs

The Freelance 2016 software is compatible with the following DTMs for PROFI-
BUS Remote I/Os::

Freelance 2019 is also compatible with the DTMs for HART and Profibus PA 
devices which are listed as interoperable in the data sheets "Freelance Integrated 
HART Devices" 3BDD011926 Rev January 2019 or higher and "Freelance 
Integrated PROFIBUS Devices" 3BDD011925 Rev January2019 or higher.

Updates of these data sheets will also contain compatibility statements for Freelance 
2019. The data sheets can be found in the ABB Library 
http://inside.abb.com/abblibrary/downloadcenter under:
Control Systems / Freelance / Device Management HART / HART DTM
and
Control Systems / Freelance / Device Management PROFIBUS / 
PROFIBUS DTM.

1.4.2 FOUNDATION Fieldbus Linking Device

Freelance 2019 is also compatible with the LD 800HSE Firmware Version  
1.60.0.00, 1.60.1.00 and LD 810HS Version 1.20.01.4403. Further details can be 
found in the ABB Library under:
Control Systems / Freelance / Device Management FOUNDATION Fieldbus  

ABB PROFIBUS Hart Library DTM400 2.00.36
ABB S800 I/O DTM Version 6.0.00300.5
ABB S800 I/O Firmware CI801: 1.5/1; 1.6/1

CI840: 4.2/2, 4.3/2
ABB S900 DTM Version 6.0.00300.8
ABB S900 I/O Firmware CI920: 1.5.9; CI92AS: 2.1.0
ABB Basic HART DTM /HART DTM Builder Version 6.0.00300.1
- FDT Base Container Version 14.0.00300.1
- FDT Shared Components Version 14.0.00300.3
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1.5 Third party software

1.5.1 Adobe Acrobat

The current Release Notes and newest information about the software can be 
accessed directly in Freelance Engineering. For this purpose, a PDF reader software 
such as Adobe Reader must be available on your configuration PC. 

1.5.2 Antivirus program

The Freelance software has been tested under Windows 7 and Windows 10 with the 
antivirus program McAfee, VirusScan Enterprise® (Version 8.8 Patch 12). For the 
up-to-date tested DAT files and Virus Definition Files refer to the document 
2PAA118238 “Freelance System Daily verification of McAfee & Symantec 
updates” available in the ABB Library under: 

Control Systems / Freelance / System / Freelance System Versions / Freelance 
2019

1.5.3 FTP server

Freelance Operations and Freelance Engineering have built-in FTP clients. For 
some features like automatic archiving an FTP server can be used. 

We recommend to use the Microsoft FTP Server together with the Freelance 
software. It is delivered with certain versions of Windows and can be installed 
through the Windows Control panel. It runs as a service process and uses the 
maintenance infrastructure of the internet information server.

For data security reasons, it is recommended to run the FTP server on a separate 
machine within the controller network. A typical network setup could look like this:

Antivirus programs and background tools can affect the installation procedure of 
the Freelance software. We therefore recommend to disable programs of this kind 
before executing the Freelance setup program and re-enable them after the setup 
has finished.
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FTP Scenario us.bmp

The following chapters about FTP server installation and configuration are kept as 
simple as possible. The intention is to give a working starting point that can be 
customized as required.

For security reasons use a specific FTP login user with limited rights for FTP 
server login. For example, create a Windows user called “FreelancerFTP” for that 
purpose on the machine that hosts the FTP server.

Use a unique password for FTP operations.

It is not required to create this Windows user on the FTP client machines.

The FTP user must have all access rights to the FTP server root directory and all 
subdirectories on file system level. Otherwise, it may not be possible to read or 
write files.

In the described basic configuration FTP passwords are transmitted as clear text 
over the network.

Clarify a secure FTP setup with the network and system administrators.
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FTP server installation

FTP Server Win7 Windows Features us.bmp

The FTP server is installed.

Windows 7:
Start > Control Panel > Programs > Programs and Features 
> click Turn Windows features on or off in the left navigation bar.

Windows 10:
Windows button > Settings > Apps & Features > Programs and Features
> click Turn Windows features on and off in the left navigation bar

The Windows Features are displayed > Expand Internet Information Services 

> expand FTP Server > select FTP Service
> expand Web Management Tools > select IIS Management Console > OK
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FTP server configuration

The IIS management console is displayed. It has a left tree area named 
“Connections”, a right area called “Actions” and context dependent area in the 
middle.

A wizard to configure an FTP site opens.

FTP Add FTP Site us.bmp

Windows 7:
Start > Control Panel > System and Security > Administrative Tools
> double-click Computer Management

Windows 10:
right-click the Windows button and start Computer Management

> expand Services and Applications > Internet Information Services

In the Connections tree, expand the root node
> right-click Sites > select Add FTP Site
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Enter the FTP site properties:

FTP site name Enter a free name for your site, for example, “Default FTP Site”.

Content directory
Select a root directory path for the FTP site. In this directory all 
content of the FTP site will be stored.

After pressing Next the Bindings and SSL Settings can be configured.

FTP Binding and SSL figure us.bmp

Select No SSL, all other entries can be accepted.

Click Next to continue.

The Authentication and Authorization Information page is shown.
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Enable Basic Authentication.

Under Authorization, select All users from the Allow access list.

Under Permissions, select both Read and Write.

Click Finish to complete the basic FTP server configuration..

Enable FTP firewall rules

When the FTP server is installed, the Windows firewall with advanced security will 
still block all external FTP traffic. To prepare external access, the FTP server 
installer has added 5 preconfigured firewall rules, 3 inbound and 2 outbound, which 
must be enabled.

The FTP login user - for example, “FreelancerFTP” - must have the necessary 
access rights to the FTP site directory - here “D:\FTP” - and subdirectories on file 
system level. Otherwise you cannot be able to read or write files, even if the 
server allows it.
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Open the configuration dialog of the Windows firewall with advanced security.

Enable the following inbound rules:

• FTP Server (FTP Traffic-In)

• FTP Server Passive(FTP Passive Traffic-In)

• FTP ServerSecure(FTP SSL Traffic-In)

FTP Inbound FTP Rules Windows 7 us.bmp

Enable the following outbound rules:

• FTP server (FTP Traffic-Out)

• FTP Server Secure (FTP SSL Traffic-Out)

Windows 7:
Start > Control Panel > System and Security > Administrative Tools
> Windows Firewall with Advanced Security
> select Inbound Rules

Windows 10:
Windows button > Settings > Update & Security > Windows Security
> Firewall & network protection > Advanced Settings > Inbound Rules

> select Outbound Rules
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FTP Outbound FTP Rules Windows 7 us.bmp

Restart the Windows service Microsoft FTP Service:

The FTP server is restarted and the firewall will use the exception rules now.

Testing the FTP server

Perform the following steps to test the FTP server functionality:

• Logon with an FTP client (for example, the Windows FTP command line client 
or FileZilla), from another Windows PC using the created limited user (for 
example, “FreelancerFTP”) for login.

• Upload a file.

• Download a file.

Now the FTP based functionality in Freelance Engineering and Freelance 
Operations can be configured and used.

If the FTP server is initially installed, the firewall still blocks the traffic until the 
service of the FTP server is restarted.

Windows 7:
Start > Control Panel > System and Security > Administrative Tools
> double-click Services 

Windows 10
right-click the Windows button and start Computer Management 
> expand Services and Applications > select Services

select Microsoft FTP Service > Restart the service
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1.5.4 Java installation

Java is used to display applets in a Web browser. It is necessary, if the Emulator 
View of the Controller Emulator will be used.

Installation

Java 8 Update 171 or higher is recommended.

Download the Java Runtime Environment (JRE) from the website, www.java.com 
and install it.

Testing Java

After installation of the Freelance Controller Emulator, this software can be used to 
test the Java installation. Start the Internet Explorer and open the Controller 
emulator manager by entering the address http://<IP addr.>:8888.

Start a Controller emulator station and click the Emulator View of the station to 
view the information.

On a 64-bit PC, the 64-bit version of the Microsoft Edge web browser or the 
Microsoft Internet Explorer 11 must be used to run the applet.

Depending on the Java security settings, the emulator website may need to be 
added to the exception list (http://<IP-Adr>:8888/SCGui.html).

Accessing the Controller emulator manager or the web interface of a process 
station may fail if an internet proxy is configured.

To exclude specific IP addresses from being accessed through the proxy:

Internet Explorer:
Start the Internet Explorer > Tools > Internet Options 
> Connections > LAN settings > press the Advanced button
> Enter the IP addresses or IP address patterns that shall not be accessed through 
an Internet proxy.

Edge:
start Edge > Settings and more (···) > Settings > View advanced settings
> Open proxy settings > Enter the IP addresses or IP address patterns that shall 
not be accessed through an Internet proxy.
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1.6 PC settings

1.6.1 Disable automatic Windows updates

The automatic update of the Windows operating system should be disabled.

For Windows 10 Pro and Enterprise, an automatic update can only be deferred, but 
not disabled. Therefore, it is recommended to use the Windows 10 Long Term 
Servicing Channel (LTSC).

During the mainstream support phase (5 years), the Windows Long Time Service 
Channel allows only security updates and critical bug fixes to be downloaded 
without any new features. This will allow you to postpone updates and only 
download security updates and critical bug fixes.

1.6.2 User Account Control

Freelance 2019 supports Windows User Account Control (UAC). User Account 
Control can prevent malicious software from damaging a computer. If User Account 

Automatic updates may reboot the PC automatically. It is highly recommended to 
disable them.

Windows 7:
Start > Control Panel > System and Security > Windows Update
> select Change settings > select Never check for updates from the list > OK

Windows 10:
Windows button > Settings > Update & Security > Advanced options
Option 1: Pause updates > On
Option 2: Defer installation of feature updates (up to 365 days) and / or security 
updates (up to 30 days)
Option 3: Set "Semi-Annual Channel", this delays updates until Microsoft 
considers an update as "business-suited", usually four months after publication.

For security reasons, Windows updates, especially security updates, should be 
performed on a regular basis. This must be done in consultation with the system 
administrator and according to company-specific security policies.
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Control is enabled, to improve IT security, a program will only be run with 
administrator privileges if this has been explicitly authorized. User Account Control 
suppresses the automatic installation of unauthorized software and prevents 
unwanted changes to the system settings. The following setting should be selected 
for User Account Control:

• Standard - notify me only when apps try to make changes to my computer

1.6.3 Windows firewall

The Windows operating system comes with an integrated firewall. A firewall can 
block the communication between applications.

The firewall configuration is handled by the Freelance setup. The firewall is 
configured to allow the Freelance applications to communicate properly. There is no 
specific configuration required by the user. See also Windows firewall on page 85.

1.6.4 Configure power options

The Windows power management may shut down the PC to save energy or put it to 
sleep mode. This must be avoided. It must be ensured that the energy saving 
mechanisms are configured in a way that the computer is always on.

Windows 7:
Start > Control Panel > System and Security > Power Options
If not expanded, expand Show additional plans
> Select the High Performance power plan.

Windows 10:
Windows button > Settings > System > Power & sleep 
> Screen - turn off after Never
> Sleep - PC goes to sleep after Never
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1.6.5 Disable screen saver

It is strongly recommended to disable the Windows screen saver, especially for a 
Freelance Operations PC. Perform the following steps on all Freelance PCs:

1.6.6 Windows text size

Freelance supports the default text size which should not be modified.

1.6.7 For Freelance Operations: Set screen resolution

The Freelance Operations software supports both the conventional screen formats 
4:3 / 5:4 and the widescreen formats 16:9 / 16:10. For the 5:4 screen format a 
monitor screen resolution of 1280 * 1024 pixels is recommended, for the 16:9 
widescreen format a resolution of 1920 * 1080 pixels should be used.

On screens with a low resolution, scroll bars may be displayed if required. 

Freelance Operations supports up to four monitors, even with different screen 
resolutions.

1.6.8 For Freelance Operations: Set Windows theme

The Freelance Operations software is not released for any Windows theme; 
Windows 7 Basic theme or Windows 10 - Background - Solid color must be used 

Windows 7:
Start > Control Panel > Appearance and Personalization > Personalization
> click Screen Saver in the lower right corner
> in the Screen Saver list, select (None) > OK

Windows 10:
Windows button > Settings > Personalization > Lock screen 
> Screen saver settings > select Screen saver None > OK
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for Freelance Operations. Using other Windows themes may lead to unhandsome 
effects in the Freelance Operations software 

1.6.9 For Freelance Operations: Disallow operating system access

Operator stations shall be configured to disallow operating system access. Freelance 
Operations is designed to support this.

Background information

When you start Freelance Operations in Production mode, the Windows Start button 
is disabled. There is no minimize button in Freelance Operations. This behavior has 
been implemented because of security concerns. The Freelance Operations user 
cannot switch to other applications. Only those applications that have been started 
before the start of Freelance Operations can be reached by the Freelance Operations 
user by pressing the ALT+TAB keys.

The Windows operating system can be reached from the Freelance Operations menu 
(Tools > System > Operating system) after entering a password. With this action 
the Windows Start button is enabled and is displayed with text. This is not a security 
problem, as long as the task bar is in the background of Freelance Operations. 

Configure the Windows task bar

In Freelance Operations, the task bar cannot be suppressed in all cases. If the 
property “Lock the task bar” has been enabled, the task bar is always shown in front 
of Freelance Operations. Therefore, the task bar property “Lock the task bar” must 
be disabled to make sure that the Freelance Operations user has no access to other 
applications.

Windows 7:
Start > Control Panel > Appearance and Personalization
> Personalization > select Windows 7 Basic as theme

Windows 10:
Windows button > Settings > Personalization > Background 
> Solid color
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Windows key at the keyboard

To suppress access to the Windows operating system, also the Windows key at the 
keyboard should be disabled. This can be done in the Settings tool. For details refer 
to General Freelance settings on page 68.

1.7 Licensing
Different licenses are available to configure and operate a Freelance system:

• Freelance Engineering license to program and configure your plant with 
Freelance Engineering

• One Controller license for each controller or process station to be used

• Freelance Operations licenses for the integrated Human Machine Interface 
(HMI) for observation and operation with Freelance Operations

• One Connectivity license for each OPC server to provide data for another 
system and the Trend server for data acquisition on Freelance Operations

• Batch license for connecting a batch application with the Freelance system

1.7.1 Freelance Engineering

Freelance Engineering is the central Freelance software which is used for 
programming, configuration and commissioning of the Freelance process stations as 
well as the Freelance operating stations. Also gateway stations can be configured to 
provide data of a Freelance project to other control systems.

Two license types are available for Freelance Engineering:

• Freelance Engineering Standard

• Freelance Engineering Professional

Freelance Engineering Standard

With Freelance Engineering Standard license the following functions are supported:

• Configuration and commissioning of user programs
• IEC 61131-3 programming (FBD, IL, LD, ST, SFC)
• Graphical hardware configuration
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• Integral fieldbus configuration for PROFIBUS and FOUNDATION Fieldbus
• IEC 61131-3 data types and user-defined (structured) data types
• Project-wide variables and function block lists
• Online cross-reference
• Efficient plausibility check
• Extensive online help
• 16 character tag names
• Function block TUNE
• Sequence of events
• User-defined function block classes (runtime license)
• OPC function block classes (runtime license)

Additionally, online test functions (debugging functions) and graphical 
documentation of the entire user program are supported.

Besides the programs, all hardware components are displayed in graphical form and 
are submitted to a plausibility check together with the allocated software.

Freelance Engineering Professional

Freelance Engineering Professional supports all functions of Freelance Engineering 
Standard and additionally provides the following features:

• Access protection (Security lock)
• Creation of user-defined function blocks (developer license)
• Creation of OPC function block classes (developer license)
• FDT/DTM support

Runtime license for User-defined and OPC function block classes means that 
function blocks created in another project can be imported into the own project 
and used for execution only. It is not possible to zoom in the definition and 
modify them.

This functionality is possible only for function block classes that are locked in the 
definition project.
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1.7.2 Freelance process stations

One Controller license is required for each process station. A controller license 
includes the usage of 50 I/O signals (inputs/outputs); the number of I/Os can be 
extended in steps of 50.

A control software license supports:

• IEC 61131-3, digital and analog value processing
• Controller function blocks
• Integration of PROFIBUS
• Integration of FOUNDATION Fieldbus (only supported for AC 800F)
• Communication with Freelance Operations
• 50 I/O signals
• Serial package Modbus Master, Modbus Slave
• Ethernet package Modbus Master, Modbus Slave
• Serial package Sartorius scales interface (only supported for AC 800F)
• Serial package Protronic coupling (only supported for AC 800F)
• 800xA Operation and Process Portal B Support
• Tune (Self tune PID)
• Sequence of events (only supported for Rack I/O)

Options for the control license

The control license can be extended with the following options:

• Set of 50 I/O signals
• Telecontrol library (IEC 60870-5-101 and IEC 60870-5-104)

Licensing used I/Os

The Freelance Engineering software adds up and displays all I/O components used 
in a project. The used I/Os in an open project are shown with the license bargraphs 
in the Status bar (see Engineering Manual System Configuration, License 
indicator) and can also be displayed in the hardware manager.

> Hardware structure > Show all used I/Os
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As a rule, only a project without any errors in plausibility check indicates the 
actually required number of I/O licenses. If the number of I/Os used in a project 
exceeds the number of licensed I/Os, it will not be possible for the project to pass 
the plausibility check. As a result, you cannot download the software configuration 
into the process station.

The number of I/Os relevant for licensing is determined by counting only those I/Os 
that are in use, that is:

• I/O components assigned to a IEC variable, or

• I/O components used in a program, or

• I/O components provided through a gateway (OPC server)

If the same variable is used in multiple ways, only one of them is considered as 
variable that has to be licensed, that is how often a variable is used is not relevant for 
determining the number of required I/O licenses.

The input/output variable definition depends on the respective bus/fieldbus.

I/O modules

Every channel assigned to an IEC variable or used in a program or gateway 
independent from the data type is considered as an I/O.

PROFIBUS

All I/O components agreed on the controller and used in a program or gateway are 
considered as I/Os.

FOUNDATION Fieldbus

Every I/O component that is transferred between the linking device and the process 
station and that is used in a program or gateway is considered as an I/O.

Modbus

All Boolean data (coils) or registers used by the transmit and receive function blocks 
are considered as I/Os.

The following data are not considered as I/Os:

• Send/receive function blocks
• Diagnostic data (DP, PA)
• Alarms (FF)
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• Parameters (PA, FF)
• Global variables

1.7.3 Freelance Operations

A Freelance Operations license is required for each operator station. A special 
license Combined workplace is necessary to use Freelance Engineering and 
Freelance Operations (Lite or Standard) at the same PC.

Freelance Operations Standard

A Freelance Operations license supports:

• Observation and operation of all tags through faceplates
• Graphic displays, Trends, Historian, Reports, Operator logs
• SFC displays, Time scheduler, WEB displays
• Extended diagnostic

Freelance Operations Lite

A Freelance Operations Lite license supports all Freelance Operations Standard 
functions, with the following limitations:
• max. number of user-specific graphic displays (FGR) is limited to 5

• the below-listed options are not available

Options for the Freelance Operations license

The Freelance Operations Standard license can be extended with the following 
options:

• Multi-monitor support (up to four monitors)
• Control Aspect to display Freelance Engineering function block diagrams in 

Freelance Operations with online values (read-only mode)

1.7.4 Connectivity server

One Connectivity license is required for each gateway station in a Freelance 
project. A gateway station provides process signals and variables of a Freelance 
project to other systems or Freelance Operations through a server.
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The following connectivity licenses are available for a Freelance system:

• Generic OPC server license to support the general OPC interface

• OPC for Extended Automation to support connectivity with System 800xA 
and Process Portal B

• Trend server to support data acquisition in Freelance Operations without using 
trend acquisition function blocks.

1.7.5 Batch

A Batch license is required to support batch applications with the Freelance system. 
The following batch licenses are available:

• Freelance Formulation to support an Essential Recipe Manager

• Freelance Batch to support the interface to the Workflow Manager

• Batch for Extended Automation to support the interface to an 800xA Batch 
system

1.8 Control system lifecycle management program
Automation Sentinel is the ABB control system lifecycle management program. An 
introductory trial period to the Automation Sentinel program will be included, at no 
additional cost, with each new ABB control system software delivery. Please 
contact your designated Automation Sentinel responsible for any questions or 
please refer to the Automation Sentinel product guide for detailed information on 
the program and on how to calculate and order Automation Sentinel subscriptions. 

1.9 Hardkey
Freelance products are protected by means of USB hardkey and an associated 
authorization code, which activates those products for which official orders have 
been processed. For details, refer to Licensing on page 39.

The following types of the hardkey are available:

• Freelance Engineering

• Freelance Operations
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• Combination (Freelance Engineering and Freelance Operations)

1.9.1 Hardkey during installation

If no hardkey is installed on the PC during installation, the Freelance system will 
launch in demo mode. The software will be available for 100 days and will expire 
after this time.

For usage of the software for production the hardkey is necessary during 
installation. 

In case of a hardkey failure, the software will enter an emergency mode, which – 
just like the demo mode – expires after 100 days. As long as the hardkey is replaced 
within these 100 days, the rights conferred by the license will remain in effect.

Similarly, if the hardkey is unplugged after startup, the software will go into 
emergency mode.

Changing from production mode back to demo mode is not possible.

1.9.2 License extension

In case of license extension, you will receive a new authorization code that you 
should enter as follows:

1.10 Compatible hardware versions
For all details for the released controllers and I/O components refer to the 
corresponding Release Notes, Appendix A, Compatible Hardware Versions. 

Windows 7:
Start > All Programs > ABB > Freelance 2019 > Settings

Windows 10:
Windows button > ABB > Settings

Select the tree item:
> General settings > Authorization key installation
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2  Freelance installation

2.1 Preparation to install the Freelance software
Make sure that the preparations on your PC have been executed accordingly; refer to 
Section 1, General notes. 

2.1.1 Checklist for PC preparation

Has the Windows operating system been fully installed, including 
the current updates?
See Operating system on page 13.

Is the automatic update of the Windows operating system disabled 
or delayed?
See Disable automatic Windows updates on page 35.

Is the User account control enabled? 
See User Account Control on page 35.

Have the Power options been checked? 
See Configure power options on page 36.

Is the Screen saver deactivated?
See Disable screen saver on page 37.

Freelance Operations only: Is the screen resolution set?
See For Freelance Operations: Set screen resolution on page 37.

Freelance Operations only: Is the Windows theme set?
See For Freelance Operations: Set Windows theme on page 37.

Freelance Operations only: 
Is the Windows task bar configuration appropriate?
See For Freelance Operations: Disallow operating system access on 
page 38.
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Is TCP/IP protocol installed as network protocol?
Have the IP addresses been entered?
See Freelance network / Control Net on page 17.

2.1.2 Checklist for before starting the setup

Do you have a current authorization key file available?
If not please contact your local ABB sales office.
See Authorization key installation on page 70.

Is the USB hardkey installed at the USB port?

Is an administrative user with password ready to be used as 
operator?
See Windows user access rights on page 15.

In case you are a user of an earlier Freelance version: 
Have you backed up your existing projects?
Refer to Upgrade an existing version to the new version on page 48.

2.1.3 Checklist for after installation of Freelance

Check the Freelance installation.
See Freelance Check tool on page 83

Check Windows firewall rules.
Windows firewall on page 85.

2.2 Upgrade an existing version to the new version
Upgrade means the change from an existing Freelance version to a newer version. 
This process includes the software as well as the configured data and archives. The 
following steps should be performed to upgrade all data to the new version. 

• Save the project configurations

• Upgrade the Freelance software

• Upgrade the project data for the new version
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2.2.1 Save the project configurations

Existing project configurations can be saved without any problem, if the upgrade is 
to the next higher revision level (e.g. from Freelance 2016 to Freelance 2019). To 
perform a project upgrade, you must export the project with the old version of 
Freelance Engineering to a CSV file and then import that CSV file into the new 
version of Freelance Engineering. When changing over several versions (for 
example, from Freelance V9.2 to Freelance 2019), it may be necessary to upgrade 
each intermediate version (e.g.: 9.2 -> 2013 -> 2016 -> 2019).
For more information and assistance contact your local ABB service organization.

Before installing the new software version, it is strongly recommended to save all 
your configuration data.

Checklist

Are all changed or modified parameters stored in the project files?

Are all function block parameters in the project files documented?

Have all project files been exported from the existing version of 
Freelance Engineering version.

Save all parameters in the project files

In the first step you must ensure that all parameters, which have been changed either 
from the operator station or during commissioning mode, are stored in the project 
file using the CORRECT option. Each parameter modified with a WRITE command 
is set to its original value while the process station is being loaded. With the 
function Load/Parameters you can save all modified parameters:

Document function block parameters

It is recommended that you document the parameters of the function blocks in the 
projects. In case of incompatible changes to the function block library which cannot 
be handled automatically by the system, it may be necessary to re-enter parameters.

Start Freelance Engineering > Open project > Switch to Commissioning mode
> Load > Parameters > Only different > Correct parameters
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Export the project files from older versions

Existing projects from an older version must be exported (create *.CSV file) using 
your existing Freelance Engineering version, before starting the setup of the new 
software version.

Save all configured projects in a *.CSV file. See also Engineering Manual System 
Configuration, Project manager, Exporting a project.

Repeat these steps for all your projects.

2.2.2 Upgrade of the Freelance software

If a Freelance version is already installed on the system, this version must be 
uninstalled before the new version can be installed. If the new setup is started 
without uninstalling the old version, the setup displays a warning and will abort. 
Freelance versions can be removed through the Windows Control Panel:

The additional packages such as the OPC tunnel, S800 DTM, S900 DTM, FDT 
shared components, FDT Base container, Control Aspect (CBF Viewer), etc. are 
also uninstalled if they have been installed using the Freelance setup function. If 
necessary, the additional packages must be manually uninstalled.

Start Freelance Engineering > Open project > Project > Project manager
> Export > Save the data in *.CSV format

Windows 7:
Start > Control Panel > Programs and Features

Windows 10:
Windows button > Settings > Apps & Features

> Select the program to uninstall, for example ABB Freelance 2016
> Select Uninstall
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The Freelance setup also includes a Remove option to uninstall the Freelance 
software and any additional packages. See also Remove option on page 67.

After uninstalling the old software components, the new software can be installed as 
described below; see Install Freelance software on page 51.

2.2.3 Upgrade of the project data for the new version

After the new setup is completed, the project configurations are upgraded by 
importing the *.CSV files in the new Freelance Engineering version. In general, 
necessary updates are performed automatically during the import and no special 
customer actions are required.

2.3 Install Freelance software

2.3.1 Start setup

To install the Freelance software, insert the Freelance software USB flash drive. The 
autoplay dialog starts automatically, if the Autoplay function is enabled in 
Windows. If this function is disabled, you can start the dialog manually.

When installing under Windows 7, the Freelance Setup program recognizes whether 
User Account Control (UAC) is disabled and displays the following warning:

> Start Autoplay.exe from the SetupCD of the existing Freelance version
> Select the language > Freelance software
> Select Remove in the maintenance dialog and proceed until the software is 
uninstalled

If a Freelance project was created in Windows XP and is now opened in 
Windows 7 or Windows 10, the time zone setting will be lost.

To set time zone, open the project with Freelance Engineering, 
right-click the CONF node in the Project tree > Header > Timezone.

Start the Windows Explorer 
> Select USB drive > run Installer.exe. 
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EnableUAC.png

Click Enable UAC to enable the UAC feature.

EnableUAC2.png

Make sure that you have no unsaved work and click Yes to restart the computer. 
After the reboot, the Freelance Setup program must be restarted.

First select the language for the software.

tb499_us.png

Release Notes This option opens the Release Notes document for reading, which 
lists the new features of this version.

A PDF reader software like Adobe Acrobat Reader is required to open the 
document.
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Next This option starts the Freelance software installation. 

Cancel Cancellation of the freelance installation.

Read first the Release Notes and then start the Freelance software installation. 

2.3.2 General operation in the setup procedure

These buttons are available in the dialog boxes:

Next Continue the installation with the next dialog box.

Back Returns to previous window.

Cancel Aborts the installation; can be done at any time. 

In some dialogs a description to the dialog content can be obtained by clicking on 
the Help icon provided on the top right side of the screen. 

2.3.3 Welcome screen

The Welcome screen reminds the user of important steps to do before the software is 
installed. See also Upgrade an existing version to the new version on page 48.

Ensure that the preconditions are fulfilled and continue with Next. The License 
agreement will open. To accept, select the appropriate check box and continue.

2.3.4 Selecting a setup type

In the next dialog you have to choose the required setup type.
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Demo Select Demo mode to install the software on the system for a trial. 
No license is required and all functionalities of the software are 
available to the user. 
The validity of this mode is limited to 100 days.

Production Select Production mode to install the software in the production 
environment. The Production mode will modify the setting on the 
PC besides installing the software. License keys must be provided 
for installing the selected components.

Destination folders
Changes the default path for installing the software and storing the 
data.
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2.3.5 Installation directories

The following subdirectories are created below the installation directory:

The following subdirectories are created below the data directory:

The default destination directory for the installation depends on the used 
Windows operating system:

Windows 32 bit: C:\Program Files\ABB\Freelance

Windows 64 bit: C:\Program Files(x86)\ABB\Freelance

Control Aspect Files for software packet Control Aspect (CBF Viewer)
dmsapi Application interface
exe dll and exe files for Freelance Engineering
FDT Base Con-
tainer

Files for FDT Base Container

FDT Shared Files for FDT Shared Components
OPCTunnel Installation folder for OPC Tunnel Server
S800 IO DTM Installation folder for S800 DTM
S900 IO DTM Installation folder for S900 DTM
setctrl Setup control
VisHelp Online help for Freelance Operations

The default destination directory for Freelance project data is 

C:\FreelanceData

bitmaps Bitmap files for the project documentation in Freelance Engi-
neering and bitmap files for PROFIBUS devices in Freelance 
Engineering and Freelance Operations

bpr Operation logs
curv Trend archives
doc Project documentation
export Exported project files or program sections
ff Files from FOUNDATION Fieldbus Standard
gsd PROFIBUS device master data files
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 2.3.6 Workplace type

A workplace type is used to install a typical set of the Freelance software 
components on your PC.

License License files
Logs Log files
macros Macros for the graphic editor
NameSrv Network information
OPC Server OPC server information
opcsrv OPC server (Trace files)
OPCTunnel Installation folder for OPC tunnel
proj Default folder for project files
proj\BDM Default folder for Bulk Data Manager templates and files
reports Default folder for Excel reports
sap Disturbance course logs
sfp Signal sequence logs
ucurv User-defined trend archives
wave Wave files for alarm messages in Freelance Operations
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Depending on the selection in this dialog, a typical set of Freelance software 
components will be installed on your PC:

Engineering Station
Freelance engineering software with all subcomponents for field 
bus configuration

Operator Station
Freelance Operations software for visualization

Combined Eng. & Oper. Station
Combination of all components for configuration and visualization

Extended Maintenance Station
Freelance software for visualization and PROFIBUS FDT and 
FOUNDATION fieldbus configuration software to operate field bus 
devices on an operator station.
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Connectivity Station
Freelance OPC Server software

Custom This option is recommended for advanced users of the Freelance 
software. All software components can be selected or deselected 
individually.

Depending on the selected workplace type, these additional components can be 
selected or deselected for installation:

Control Aspect
View real-time data in Freelance Operations for the application 
programs from Freelance Engineering.

Freelance Trend Server
Special OPC server that supports user defined trend displays in 
Freelance Operations.

ABB OPC Tunnel
Link Trend and OPC servers with the Freelance system.

Details The selected software components are shown in a tree structure. 
Click on a component name in the feature tree to display a brief 
description of that component and information about the required 
space on the PC

A similar feature tree is shown after selecting Custom and button Next. In the 
custom mode all software components can be selected or deselected individually for 
installation.
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2.3.7 Freelance software packages

tb500_9_us.png

The following software packages can be installed with this setup:

Engineering Station

• Freelance Engineering
Software package for configuring and commissioning process, gateway and 
operator stations for Freelance projects.

• Freelance Engineering Help
Online help for Freelance Engineering.

• PROFIBUS FDT Library
Software for configuring PROFIBUS installations using FDT/DTM interfaces, 
version FDT 1.2 in Freelance Engineering projects

– FDT1.2
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– FDT1.2 Components
To configure the field devices in Freelance Engineering using DTMs, you 
have to install these software components in addition to the PROFIBUS 
FDT libraries.

- FDT Shared Components

- FDT Base Container 

– DTM for S800

– DTM for S900

• Foundation Fieldbus
Software for configuring FOUNDATION Fieldbus devices

• Bonus Pack

– Controller Emulator
This software package can be used to emulate process stations. A project 
configuration can be tested in the absence of any existing hardware.

– Bulk Data Manager
Freelance Bulk Data Manager is a tool that allows manipulation of large 
data sets during engineering with Freelance Engineering with the help of 
Microsoft Excel. The functionality provided comprises the import/export 
of tag and variable lists, multiplying of typical application solutions and 
parameter changes for complete sets of function blocks.

Operator Station

• Freelance Operations
Software for an operator station for operating and observing the processes 
configured using Freelance Engineering.

• Freelance Operations Help
Online help for the Freelance Operations operator station.

• Archive Browser
Software package for viewing archived trends and logs.
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Servers and Gateways

• Freelance OPC Server
Gateway for interfacing Freelance projects with other application programs, 
should be installed on a Connectivity station only.

• Freelance Trend Server
The Trend Server is a special OPC server that supports user defined trend 
displays. Only one Trend server is allowed in a Freelance system and should be 
installed on an operator station or a dedicated Connectivity station.

• Application Programming Interface (API)
Programming interface for direct communication with a process station.

• OPC Tunnel
Used to link Trend and OPC servers with the Freelance system (Freelance 
Engineering and Freelance Operations). Install this on all machines running 
Freelance OPC servers, Freelance Trend server and any OPC server from other 
vendors which should be connected to the Freelance project.

Control Aspect
Used to view real-time data in Freelance Operations for the application programs 
(FBD, SFC and so on) from Freelance Engineering.

Batch Station

• Formulation Client
This option installs the complete Formulation functionality without a local 
database. The client installation uses the shared database from the server.

• Formulation Server
This option installs the complete Formulation functionality including a local 
database that will be shared with the client installations.

2.3.8 Ready to install dialog

If the feature selection is completed, click Next to start the installation.
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Clicking on the Install button will install the selected components.

2.3.9 Import data from previous versions

After installation of the software packages it is possible to import Freelance data 
from a previous version. This dialog must be used only if the new Freelance system 
version has been installed in another directory than the previous version. 

Use this dialog to copy all project and archive data into the new Freelance 
installation directory.
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If the project data are to be copied into the new directory, activate the checkbox 
Import subdirectories of a previous Freelance version and Browse to the 
directory name of the previously used Freelance version.

Clicking the Next button copies the data from the previous version.

2.3.10 Modify initial installation settings

In the next installation step, the Settings dialog can be used to customize the 
installation to your computer and requirements. The settings can be modified 
retroactively after the installation has been completed without having to carry out 
the installation again.

For a detailed description of the configuration dialog, refer to chapter Modify 
installation settings on page 68.

2.3.11 Finishing the installation

With a click on OK in the Settings dialog the installation will be finished. A screen 
indicating the completion of the installation is displayed as follows.
Introduction - Getting Started 63



Import data from previous versions 2  Freelance installation

E
n

g
lis

h
D

eu
ts

ch
 
tb500_31_us.png

Choose the required boot action:

Yes Restart the computer now.

No Install the additional Freelance products, then restart the computer 
once after completing all installation procedures.

The Finish button is used to complete the installation.

In case you have installed the Control Aspect (CBF Viewer ), you must open it 
once in order to start the Control Aspect configuration wizard. For details refer to 
the installation guide of the Control Aspect which has been installed together 
with the software.
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2.4 Installation maintenance mode
If the setup program is started on a PC where one or more Freelance components of 
the same version have already been installed, the setup program automatically 
changes over to Maintenance mode.

tb500_12_us.png

Modify Add or remove components of the Freelance installation.
For details refer to Modify option on page 66.

Repair Reinstall components that have already been installed to repair files 
or settings that may have been overwritten.
For details refer to Repair option on page 67.

Remove Remove all Freelance components from your system. 
For details refer to Remove option on page 67.
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2.4.1 Modify option

This option can be used to add or remove components of the Freelance software. 
Choosing this option and clicking Next will open the “feature-tree” dialog.

tb500_16_us.png

The components that are already installed on the system will appear with a check 
mark, whereas all other components will be unchecked.

If you want to uninstall a component that is already installed on the system, then 
uncheck that component from the list.

Check the components that are to be installed and click the Next button.

The setup program makes the required modifications and displays the “Maintenance 
complete” screen. Click the Finish button to complete the installation.
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2.4.2 Repair option

This option is used to reinstall components that have already been installed on the 
system, in order to repair files or settings that may have been overwritten. In 
addition, you can use the Repair option to install another language selected in the 
language selection dialog.

If any file, registry key or content of any installed component is corrupted in the 
system, choosing this option will repair or put back the contents of the components. 
Th setup program replaces or repairs and verifies files and registry keys contained in 
the Freelance software components.

Select the Repair option and click - Next; the setup program will make the 
necessary repairs.

The configuration screen is displayed when the repair process is completed. Modify 
the settings if required. For details refer to Modify installation settings on page 68.

To complete the repair, the system must be restarted. Select whether this should be 
done now or later and click the Finish button to terminate the setup program.

2.4.3 Remove option

This will remove all Freelance components from your system. The setup program 
asks you to confirm the removal of the components. After accepting this message all 
installed Freelance components will be removed from the system.

Application data like logs, archives, projects and export files will not be removed. 
These can be deleted manually if they are no longer required. In case a user account 
was created by the setup program this user account will also remain.

To complete the uninstall, the system must be restarted. Select whether this should 
be done now or later and click the Finish button to terminate the setup program.

The repair option will overwrite the content of temporary corrections, roll-ups 
and all manual changes to the setup files. 
All temporary correction and roll-ups have to be reinstalled manually.
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2.5 Modify installation settings
The Settings program is provided to accomplish basic configuration and 
maintenance tasks for the Freelance software. It is automatically started at the end 
of the software installation, but can also be started manually using the Windows 
Start menu at any time.

If the Settings tool is started after an installation, all entries in the tree structure 
should be selected one by one to check and configure the settings. After the 
configuration is completed, press OK to apply the changes and close the dialog.

2.5.1 General Freelance settings

tb500_20_us.png

Mode The installation mode can be changed from Demo to Production or 
vice versa in this dialog without having to reinstall the software.

> Start > All Programs > ABB > Freelance 2016 > Settings
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Demo Mode To install the software for demo-purpose or for a try out.

Production Mode
To install the software in the production environment.

Auto login (User account details)
The Freelance Operations user for the Production mode in the 
Autostart mode is defined in this dialog. The default user is 
“Freelancer” and the default password is “welcome123#”. This can 
be changed as required.

Disable the keyboard Windows key
Select this option and reboot the system to disable the Windows key 
operation in Production mode.

Disable auto login
If this option is selected, the Auto login feature will be disabled 
after a restart.

Selecting Production mode will enable the Freelance Operations Autostart 
function. After a reboot Windows will start Freelance Operations automatically. 
This will prevent access to the operating system.

If the installation is made using the "Production Mode" option, the user 
"Freelancer" is created during the installation process and assigned to the "ABB 
Freelance Basic Access" user group.

If another user is specified, make sure that the user is also a member of the ABB 
Freelance Basic Access group.

This parameter is not accessible in Demo mode.
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Time synchronization
This allows you to synchronize the Windows computer time with 
the time of the process stations.

IP Address The IP address uniquely identifies devices in the Control Net.
Entry of IP address for Line A e.g.: 172.16.1.1. If no Control Net 
redundancy is needed, the input fields for Line B must be left 
empty. For a Control Net in a redundant configuration, you have to 
assign addresses of a separate subnet for Line A and Line B.
For more information, see IP address settings on page 19.

Subnet Mask Defines whether the addressed device is located in the same 
network or has to be addressed through routers.
Entry: 255.255.240.0

Authorization key installation

You should have received an Authorization key file from ABB. Enter the drive name 
and/or directory path or select the directory where the Authorization key file is 
located, using the Browse button.

When the Install button is clicked, the Authorization code is transferred to the 
installation directory.

This parameter must be set consistently for all computers in a Freelance system. 
After the Time synchronization settings have been changed, all Freelance 
applications (Freelance Operations, OPC Server, Trend Server, etc.) must be 
restarted to ensure that the changes become effective.

Time synchronization must be activated if the Freelance Operations software and 
trend displays are used in the Freelance system.

If you operate your Freelance system in a network with other network 
components, you must contact your network administrator before allocating the 
IP addresses.
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Default language

If you have installed the Freelance software in more than one language, the 
language for the Freelance user interface can be selected as follows:

In case you select a language in Windows, but Freelance software is not installed in 
this language, you can use the Settings dialog option "Default language" to 
determine the language to be used for the Freelance user interface.

Example:

You have installed the Freelance software in English and in German, but have set the 
Windows format to French. With the Settings dialog option, "Default language" you 
can specify that the Freelance software must use the English (or French) language 
for the user interface.

The language setting can be applied to the following packages by selection: 

• Freelance Engineering
• Freelance Operations
• Archive Browser
• Security lock
• OPC Server / Freelance Trend Server

A locale can only be applied if the relevant package has been installed on the 
corresponding computer.

Windows 7
Start > Control Panel > Clock, Language and Region > Region and 
Language > Format > select language, e.g. English (United States)

Windows 10
Windows button > Windows System > Control Panel > Clock and Region 
> Region > Format > select language, e.g. English (United States)
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User Management

Usermanagement_en.png

This setting enables the Freelance user management. Details are described in the 
Engineering Manual User Management.

2.5.2 Settings for Freelance Engineering

tb500_21_us.png

Resource ID Several software packages can be run at the same time on a PC. To 
enable these software packages to be addressed unambiguously, 
each one must be assigned a unique number, the resource 
identification number.
All the resources within a Freelance project must also have a unique 
resource ID.
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Controller firmware update

This dialog is used to update the firmware of the process stations.

This requires that the TCP/IP protocol is loaded and that a connection is established 
through the system bus to the process and gateway stations.

IP address
Enter the IP address of the station for download.
If you are using a redundant station you must specify both addresses 
(IP address 1 and IP address 2).

After pressing the Download button, the current version of the firmware update is 
loaded to the addressed CPU module or the controller.

If you have more than one process station and/or gateway station, you must carry 
out this procedure for each station.

For details refer to the Engineering Manual Process Stations.

PROFIBUS module firmware update

The firmware update in the PROFIBUS modules of the connected controllers can be 
loaded with the current version.

Once the IP address of a controller has been entered, the current firmware update 
version is loaded to all the PROFIBUS modules of the controller concerned.

If you are using a redundant station you must specify both addresses (IP address 1 
and IP address 2).

HSE module firmware update

The firmware update in the HSE modules of the connected controllers can be loaded 
with the current version.

Once the IP address of a controller has been entered, the current firmware update 
version is loaded to all the HSE modules of the controller concerned.

The process station cold-starts after loading the firmware update.
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If you are using a redundant station you must specify both addresses (IP address 1 
and IP address 2).

I/O firmware import

Current versions of the firmware for the I/O modules can be imported into the PC 
from a file directory. 

Enter the drive name and/or directory path or select the directory where the I/O 
firmware files are located using the Browse button.

When the Import button is clicked, all I/O firmware files are imported from the 
specified directory into the system.

To load the I/O firmware into the appropriate modules, you must select the I/O 
modules and start the load instance in the Commissioning mode of Freelance 
Engineering.
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Page layout

tb500_34_us.png

In this dialog you can specify the page layout for the printable project 
documentation.

Dimension/Message text

Language

The selection list contains the language abbreviations of the files with the 
dimensioning and message texts which have already been installed on your PC. 
During the installation a file “digit<language>.str”, for example, digitus.str, is 
copied into the installation directory. Selecting a language code in this dialog will 
copy the corresponding file to "digitool.str" in your 
<Freelance_installation_folder>\exe. 
The texts of this file are used when creating the user program in Freelance 
Engineering and when loading the program to the operator station.
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Select the language that will be used in the operator station.

Import

The Load button loads all files with the name “digit<language>.str” from the 
specified directory into the installation directory; these files can then be made 
available to Freelance Engineering through the Language setting dialog.

The default files can be modified using a text editor. The file structure cannot be 
altered.

The texts are defined as follows under the section [PARA]:

DIMENSION_0 = dim_text1
DIMENSION_1 = dim_text2
DIMENSION_2 = dim_text3
...

NOTIFICATION_0 = messagetext1
NOTIFICATION_1 = messagetext2
NOTIFICATION_2 = messagetext3
...

Use this dialog if you have adapted the standard file to your project requirements 
using a text editor.

Selection is only possible if more than one language is installed.
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2.5.3 Settings for Freelance Operations

tb500_23_us.png

Resource ID Several software packages can be run at the same time on a PC. To 
enable these software packages to be addressed unambiguously, 
each one must be assigned a unique number, the resource 
identification number.
All the resources within a Freelance project must also have a unique 
resource ID.

Font size Setting the font size for the message list, message line, hint list, 
trend and logs.

Freelance Operations autostart

Freelance Operations can be installed such that it is launched automatically after 
Windows starts.

Yes, start Freelance Operations automatically (Recommended)
PC is restarted, Windows logs in automatically with Auto Logon 
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user and Freelance Operations is launched.
Only those applications that have been started before the start of 
Freelance Operations can be reached by the Freelance Operations 
user by means of ALT+TAB keys.

No, start Freelance Operations manually
Freelance Operations will not be started automatically. Freelance 
Operations can be started using the Start menu.

Printer settings

Two printers are supported per operator station. One printer must be used for the 
continuous output of the Signal sequence log. The other printer is then available for 
printing the Operation logs or Disturbance course logs. One of the two printers is 
also used for hardcopies.

Printer 1 Choose a printer installed under Windows, for example, for 
continuous stationary.

Printer 2 Choose a printer installed under Windows, for example, a color 
printer.

Hardcopy Printer 1/2
Choose one of the installed printers to print a hardcopy from the 
operator station.

Margins of Printer 1/2 in cm
The page layout for the two installed printers is defined.

For hardcopies, do not choose a printer which is used for producing Signal 
sequence logs.
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Auto logoff

Autologoff_en.png

If Auto logoff is enabled, the Freelance Operations user will be logged off 
automatically if no operations is performed within a configured time period.

2.5.4 Settings for Archive Browser

The dialog is used to specify whether or not the user can delete archive files within 
Archive Browser.
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2.5.5 Settings for OPC server

tb500_26_us.png

New resource ID
During the installation, the OPC server software is installed on the 
PC, but no instance is created. Enter the Resource ID under which 
the OPC server shall be executed.
Several software packages can be run on a PC at the same time. To 
enable these software packages to be addressed unambiguously, 
each one must be assigned a unique number, the resource 
identification number.
All resources within a Freelance project must also have a unique 
resource ID.

Add After entering a Resource ID, this button is used to create an 
instance of the OPC server. In this way you can create several OPC 
server instances on one PC.
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Configure separate Alias ID
In addition to the Resource ID which is used for communication 
within a Freelance projects, a second Resource ID can be 
configured to establish a redundant OPC connection for an 800xA 
system. This checkbox must not be selected for standard 
applications.

Existing resources
The list shows the Resource IDs of the OPC server instances 
created on this PC.

Configure Allows to run the OPC server selected in the list with another user 
account.

Remove The instance of the selected OPC server will be deleted.

If the OPC server is configured to be connected to System 800xA Version 6.0 
(UAC enabled), the user entered here must have the rights to change the system 
time (SeSystemtimePrivilege).

Deleting all OPC server instances on a computer does not automatically delete 
the OPC server software.
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2.5.6 Settings for Trend server

tb500_28_us.png

Trend-Server Resource ID
During the installation, the Trend server software is installed on the 
PC, but no instance is created. Enter the Resource ID under which 
the Trend server shall be executed.
Several software packages can be run at the same time on a PC. To 
enable these software packages to be addressed unambiguously, 
each one must be assigned a unique number, the resource 
identification number.
All resources within a Freelance project must also have a unique 
resource ID.

Change ID An instance of the Trend server is created after entering a Resource 
ID. If you want to use the Trend server under a different Resource 
ID, edit the displayed number before pressing the Change ID 
button.
If you want to delete the Trend server from the local PC, delete the 
displayed number before pressing Change ID.
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Configure Allows to run the Trend server with another user account.

2.5.7 Confirm changes

Once all the settings have been made, click OK to accept all changes and to finish 
the Settings tool.

2.6 Installation complete
We wish you every success using Freelance to perform your automation tasks. 
Freelance Engineering will greatly reduce the effort required. Not least because of 
standards such as Windows and IEC 61131-3, this is an innovative product which is 
setting standards in this field through its use of a common database for configuring 
the user programs and for display.

If you have unexpected problems during installation, please contact your local 
Freelance provider or your local ABB office.

2.7 Check the Freelance installation

2.7.1 Freelance Check tool

The test program Check can be used to check the installation.

If Freelance Operations, OPC Server and Freelance Trend Server are run on the 
same PC, they must be executed using the same user account.

Windows 7:
Start > All Programs > ABB > Freelance 2019 > Tools > Check

Windows 10:
Windows button > ABB > Check
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tb005_us.png

Check > All Components initiates a full test of all the installed Freelance 
components. All the files that have been installed are checked. The test log can be 
output, allowing you to compare the nominal status and the actual status.

The Check program can also be started from the Freelance Engineering help menu.

Help > About > List all information.
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2.7.2 Windows firewall

During the installation process the setup will add several Freelance programs to the 
firewall exclusion list. To verify the entries made, you can open the Windows 
advance firewall configuration:

2.8 ABB OPC Tunnel
Depending on the selection during Freelance installation, the software component 
ABB OPC Tunnel will be installed. This component must be installed on all PCs 
with an OPC server to be connected to the Freelance system. The OPC Tunnel 
replaces the Windows DCOM configuration and makes its complicated settings 
unnecessary.

The OPC tunnel software has three major components: OPC tunnel client, OPC 
tunnel server and OPC tunnel configurator.

Tunnel Architecture us.bmp 

The OPC tunnel client side is integrated into the Freelance Engineering and 
Freelance Operations and will start automatically.

Windows 7:
Start > Control Panel > System and Security > Windows Firewall

Select Advanced settings.

Windows 10:
Windows button > Windows Administrative Tools > Windows Defender 
Firewall

The Windows firewall with Advanced security configuration is shown.

Select Inbound Rules.

When the setup has finished there are several entries that start with “Freelance”.
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The OPC tunnel server has a separate configuration tool which is not part of 
Freelance Engineering or Freelance Operations.

The OPC tunnel configurator is used to set up the communication parameters of 
the tunnel.

Configuration of the OPC tunnel is described in the Engineering Manual OPC 
Tunnel Configuration. 
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3  First steps

3.1 Introduction
Once you have carried out the installation of Freelance Engineering as described in 
the preceding section, you can immediately begin to set up a project.

Use the Start menu to launch Freelance Engineering.

If your hardkey is not attached, or if you have not installed a license file, a message 
will be displayed to that effect. Correct the cause of the problem and relaunch the 
program.

The version details of the installed software are displayed in the “About Freelance 
Engineering” window. Confirm this dialog using the OK button.

3.2 Creating a project file
Choose New from the Project menu and specify a file name for saving your project 
on the hard disk. The default directory used is <FreelanceData>\proj, 
but you may choose a different directory if you wish.

Once you have specified a unique file name, a further dialog appears, allowing you 
to enter general project data such as project number, person in charge, customer and 
so on. This data can also be entered or modified at any time in the future. When this 
dialog is confirmed with the OK button, an empty project file is created.

The first step of the configuration process involves setting up the software view for 
the project. This means that tags, variables and the functions to be calculated are 
defined.

In a second step, this configuration is assigned to the existing hardware, that is the 
process stations and I/O units.
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3.3 Step 1: Configuring the software view of the project
Once you have defined the general project data, you will enter the software view of 
the configuration, the Project tree.

The project tree displays the functions of a project in a clear format. The individual 
elements or objects, generally known as project elements, are structured in 
accordance with IEC 61131-3. To develop a project tree, select a node in the tree 
and choose Insert next level/Insert below or Insert above from the menu, or use 
the insertion options directly from the context menu. Depending on the node 
selected in the project tree, a selection list with the objects that can be inserted in 
that position in the tree opens. 

The topmost element in a project is the Configuration CONF, which is the sum 
total of all the project elements in a Freelance system. 

The first structural level below the configuration is Software SW or Hardware HW 
elements. The Software element is formed by the resources, which represent the 
various different stations in a project. For the processing of the process itself there 
are the D-PS (process station) resources, for operation and observation of the 
process there are the D-OS (operator station) resources, for interfacing to external 
systems there are the D-GS (gateway station) resources, and for integrating data 
from external systems there is the OPC-S (OPC server) resource.

Insert a process station below the software node.You can add either a redundant (D-
PS/RED) or a non-redundant (D-PS) process station. Further specification which 
type of process station - AC 900F, AC 800F, AC 700F or rack based station - is used, 
will be performed later in the hardware structure.

Insert a D-PS process station now and name it “PS”.

Once a name has been assigned to the resource, its basic structure is added to the 
project tree. Below the resource node, system functions and user-defined functions 
are organized in two task lists <res_name>.SYSTask and <res_name>.USRTask.

Configuration of the system task provides an opportunity to define the response of 
the process station to specific situations such as cold start, warm start and 
redundancy transfer.

Below the node USRTask the user-defined functions are specified which are to be 
executed in the process station. These functions can be executed in different tasks. A 
task is represented as a separate node in the project tree.
88 Introduction - Getting Started



3  First steps Step 1: Configuring the software view of the project

E
n

g
lis

h
D

eu
ts

ch
 

One Default task can be set up for each process station. This task is always 
executed when none of the other tasks is being calculated. Besides the default task 
other tasks can be created. Typically, each task is processed repeatedly in Interval 
mode with a configured time interval, the task Cycle time.

Now create a Task below the USRTask node.

PL programs (program lists) and SFC programs (sequential function chart 
programs) are specified below each task. The actual functions in programs are 
configured below a program list.

Create a program list PL with an IL (instruction list) program below it. Double-click 
the IL node to enter the instructions. For example, enter the following program 
(creation of a saw-tooth curve):

first01us.bmp
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While you are entering data you will prompted to define the variables being used. 
You should define the variables Init and UP with data type BOOL, and Counter 
with data type INT.

To check the program choose Editor > Check from the menu. Any errors that may 
be detected are shown in a list. Double-clicking on an error message will take you 
automatically to the place where the error has been detected. Correct the error(s) 
and run the plausibility check again.

Save the IL program and select again the IL node in the project tree. Another 
program should now be used to monitor the current count and generate an alarm 
message if required.

Add an FBD (function block diagram) program beneath the IL program. Double-
click on the program or click Edit > Program to open the FBD editor.

Select an analog monitoring function block M_ANA from menu Blocks > 
Monitoring. Alternatively you can switch the view in the left window from project 
tree to libraries explorer and select there the M_ANA function block from the  
Monitoring library. Position the block in the editor area and double-click it. Define 
the Parameters by specifying a name, setting the scaling from -100.0 to 100.0 (in 
accordance with the Counter in the IL program), and define up to four limit values. 

Example of a completed parameter definition dialog:

ParaM_ANA.png

Place a variable in the FBD editor. To do so, choose Variable read from the context 
menu (the variable Counter should be read and linked with the input IN of the 
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monitoring block). You can enter the variable name directly in the parameter dialog, 
or use the F2 key to choose it from a list. Before linking the variable Counter with 
the function block’s input pin IN, its data type must first be converted from integer 
to REAL. This is done by choosing the converter block TO_RE (to REAL) from the 
Libraries explorer or the context menu, Data type to REAL.

Draw a line from the variable to the converter’s input and from the converter’s 
output to the function block’s input IN: click a pin and move the mouse cursor to the 
pin of the other block.

The processing sequence is shown in the lower right corner of the function blocks. It 
is not correct and needs to be adjusted. Open the parameter definition dialog for the 
analog monitoring block (Right click > Parameters) and change the sequence from 
1 to 2. The processing sequence for the converter block will be automatically 
adjusted to 1.

Your program could then look similar to this image:

first03us.bmp

Choose the Check tool bar from the editor tool bar line to validate the program. 

Now check the plausibility of the project tree. Select the top most node and click 
Project > Check all.

Any errors that may be detected are shown in a list. Double-clicking on an error 
message will take you automatically to the place where the error has been detected. 
Correct the errors and check the project for plausibility again.
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3.4 Step 2: Configuring the hardware assignment
To configure the hardware in the project, choose Hardware structure from the 
System menu or click the relevant button on the tool bar. 

The hardware editor shows two representations of the hardware in the project. In the 
left-hand section of the screen all the hardware is represented in a tree view, while 
the right-hand section contains a graphical view of the currently-selected object.

A project with no hardware configuration is displayed as follows:

first10_us.png

The computer displayed represents the configuration PC (Freelance Engineering) 
and cannot be modified. The yellow lines represent the Control Net. Shown below 
the system bus are the process stations, while above the bus - adjacent to the 
configuration PC - are the configured operator and gateway stations.

The project hardware will be configured as follows:

• Select the object in the tree structure and choose Insert from the Edit menu

or
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• Select the object in the tree structure and choose Insert from the context menu

or

• Click on an unoccupied position in the graphic view (your selection will be 
indicated by a dashed red border) and double-click.

The following dialog presents a list of objects which can be inserted at the selected 
position.

Now insert a process station in accordance with the available hardware.

The hardware and software components of the project are integrated by selecting the 
hardware and then choose Resource allocation from the Edit menu to assign a 
resource.

Now select the process station and assign the “PS” resource from the project tree.

First11_en.png

The network configuration dialog (Menu: Hardware structure > Network) allows 
the stations’ resource ID and IP address to be defined. Select the process station and 
click Edit. Enter a unique resource ID for your station and its IP addresses. If no 
Control Net redundancy is configured or stations are used which do not support 
Control Net redundancy, you only have to enter an IP address for Line A. Close the 
network configuration with OK.

Usually no changes to the default boot parameters of the process station are 
necessary. If you need to edit them nevertheless, select the process station in the 
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hardware manager. Then select Edit > Parameters. The Boot Parameters of a 
process station can now be modified. Close the hardware parameters dialog.

To validate the hardware configuration select Hardware structure > Check all. No 
errors should be shown in the Plausibility check error list.

Now save the changes with Hardware structure > Save and exit the hardware 
manager with Hardware structure > Exit.

Select the uppermost node in the project tree and check the plausibility of all project 
data. When the Project > Check all menu item is chosen, all objects below the 
selected node are checked. The menu item Project > Check leads to only those 
objects being checked which are displayed with a pink node.

3.5 Step 3: Commissioning
Once any errors that the plausibility check reported have been rectified, the project 
can be commissioned. Choose Project > Commissioning or the appropriate tool 
bar button to switch from configuration to commissioning mode.

When switching to commissioning mode, Freelance Engineering attempts to 
establish a communication link with all the configured stations. As well as the 
resource nodes, the current states of the connections are indicated in the project tree.

In a newly-installed system the firmware update will have been loaded into the 
process station in the course of the installation process. If the IP addresses and 
subnet masks have been configured correctly, then the project tree node for the 
process station will be labeled “No operating system”. Other states include:

• “Running”: Operating system or configuration has been loaded.

• “Version error”: The configuration in the process station belongs to another 
project or is outdated.

• “Wrong DMS version”: The version of communication software in the 
process station is different from the Freelance Engineering version. With the 
configuration tool “Settings”, the current firmware must be loaded into the 
process station first.

An arrow before the node indicates that the data for the node is not yet available on 
the associated hardware and still needs to be loaded.
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Select the resource node of the process station and open the context menu. If 
commissioning for the first time, choose Load > Whole station. Changes and 
enhancements to the configuration can be loaded into the process station later with 
Load > Changed objects.

If the load operation has been completed successfully, the nodes in the project tree 
will appear green and the load arrows will be removed.

3.6 Step 4: Testing the configuration
In commissioning mode there are various different options in Freelance Engineering 
for testing and checking the current project configuration. Select an object and 
double-click to open it. As in the configuration phase, the relevant editor is then 
opened. It is not possible to modify the configuration here, but the current values 
can be checked, and influenced to a certain extent.

IL program

If an IL program has been loaded into a process station and executed there, then the 
IL editor can be opened in Freelance Engineering commissioning mode. For each 
step in the calculation, the current values for variables are displayed before the 
comment column. Boolean variables are displayed as F for FALSE and T for TRUE.

FBD program

If an FBD program has been loaded into a process station and executed there, then 
the FBD editor can be opened in Freelance Engineering commissioning mode. The 
current value can be read from the connecting lines.

Different colors are used for different data types. Lines for data of type BOOL are 
solid for the value TRUE and dashed for the value FALSE.

It may occur very rarely that the status indicated in the project tree or hardware 
structure is not updated directly after a load operation. For example, the status 
“stopped” may be indicated for a process station although the load operation has 
been completed successfully and the resource has assumed the “running” state. 
To solve this problem, execute in Freelance Engineering any action which will 
refresh the screen content. For example, you can navigate from the hardware 
structure to the project tree and back again.
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The cursor can be moved to all other lines. The current value is shown in the form of 
a data tip. The current values for a function block pin are shown when the cursor is 
moved to it.

Value window

The value window can be used to provide a lasting display of a value. Another 
window is displayed. Choose Windows > Show value window to open the value 
window.

Once a variable, a data flow line or a function block pin has been selected in an 
editor or a list, Enter variable can be chosen from the context menu or the 
Windows menu. The format for displaying the value is chosen in another dialog. 
After this dialog has been confirmed, the variable will appear in the value window. 
The value displayed is updated once per second.

3.7 Step 5: Saving the project data
The Freelance Engineering project data can be saved in binary format (Freelance 
Engineering project file, PRO) or as a text file (comma separated values, CSV). The 
standard format is binary. For data exchange purposes projects can be exported as a 
csv-text file after switching to the Project manager (Project > Project manager).

To save a project:

• In the project tree: Project > Save project

• In the project manager: Select Save project in section Manage project or from 
Project menu

To export a project:

• In the project manager: Project > Export...
A file name for the csv file must be entered then.

Archived and exported projects provide additional data safety and recovery options. 
Export files are required for the product upgrade procedure.
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3.8 Step 6: Configuring an operator station
The Freelance Operations software must be installed on a computer connected to the 
Freelance Engineering through a network. The Freelance Operations software can 
also be installed along with the Freelance Engineering software on the same PC.

To create an operator station in Freelance Engineering, switch back to configuration 
mode and to the project structure view. Select the process station node. Choose Edit 
> Insert below to display the list of possible resource types. Choose Operator 
station D-OS and specify a name.

Move to the hardware structure and select the uppermost node in the tree. Choose 
Edit > Insert to display the list of possible resource types. Choose VIS Operator 
station and click OK. Specify a name and the mounting position for the new 
hardware. The predefined values can be accepted with the OK button.

Select the new resource in the tree or in the graphic view, then choose Edit > 
Resource allocation.... Select the software resource that you defined previously and 
assign it to the hardware.

As with the process station, the IP address and the resource ID must be configured 
for the operator station. In the Hardware structure > Network dialog enter the IP 
address or host name and the resource ID you defined when installing the Freelance 
Operations software. Click OK to apply you changes.

Check the hardware by selecting the topmost hardware node and then Hardware 
structure > Check.

Save your changes and exit the hardware manager. Back in the project tree view 
select the uppermost node in the project tree and validate the project data with 
Project > Check.

3.9 Step 7: Commissioning the operator station
Once any errors that the check reported have been rectified, the project can be 
commissioned. Choose Project > Commissioning to switch from configuration to 
commissioning mode.

Besides the resource nodes, the current states of the connections are indicated in the 
project tree. If not already done, start Freelance Operations now on the operator 
station PC.
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The process station should be flagged with the connection status running, and the 
operator station with Version error. If the Freelance Operations software is not 
running or not reachable through the network, then No connection will be reported 
for the operator station.

Select the node for the process station and choose Load > Changed objects; then 
select the node for the operator station and choose Load > Whole station.

Change over to the operator station with Freelance Operations running. In the icon 
bar, click the Tag list icon .

The tag list is displayed. The name of the M_ANA function block is displayed in 
this list. Select the name of the function block to display its faceplate.

In the M_ANA faceplate the increasing and decreasing value (saw tooth) is 
visualized with a green bar. Alarms are listed in the Message list! along with their 
current time stamps, when the value reaches the defined limits.

You have mastered the first steps with Freelance. You have learned how to write a 
simple program, run it on a process station, visualize its state and display alarms. 
Congratulations.

3.10 Step 8: Integration of a PLC system
A PLC system can be integrated in a comfortable way into a Freelance system 
through Freelance Engineering. If a connection is established between Freelance 
Engineering and the OPC server of another system, the configuration of the OPC 
server can be read through the browser interface. The read OPC items are displayed 
in a list view. OPC items can be used to define a new function block type (OPC 
function block class). A faceplate can be configured for each function block class.

In a second step tag instances based on the classes can be created from the OPC item 
list. With the defined faceplates a quick and easy visualization on a Freelance 
Operations station is available.

A single OPC item can be instantiated as a variable in the Freelance project.

Library for OPC function block classes OPC_FB-LIB

Below the project tree Software node any nodes of type OPC_FB-LIB (Library for 
OPC function block classes) can be configured. The OPC_FB-LIB nodes are used to 
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structure OPC function block classes in a logical way – for example all classes 
which are used by an external OPC server.

OPC function block class OPC_FB-CLASS

Each OPC_FB-CLASS is defined by its interface and a faceplate. The OPC FB 
classes do not have any functional code. 

The interface is created through the class definition in the OPC item list. Also, it can 
be manually defined directly with the editor “OPC_FB class components”. The 
instances are available only through the OPC server (only the storage types VAR, 
VAR_VIS and MESSAGE are available).

For the definition of the faceplate for an OPC_FB class the functions of the 
Graphics editor are available.

OPC server in the project tree

To configure an external OPC server in the project tree, the IP address of the PC and 
a port number is required.

For easy and comfortable connection of external OPC servers naming conventions 
and alarm mapping can be defined in the Configure name pattern dialog.

The Configure name pattern dialog defines naming conventions for the items found 
through the browser interface of the OPC server. For connection to another 
Freelance system or an AC500 OPC server, predefined templates for the naming 
conventions can be used. For connecting OPC servers from other systems, the 
naming for DataAccess and Alarms&Events items can be specified by using the 
“Prefix”, “Tag”, “Selector” and “Postfix” fields in the dialog.

The Alarm mapping dialog maps the alarms generated by the OPC server or PLC 
to corresponding Freelance messages. In the upper part of the dialog the OPC 
severity is mapped to the message priorities of the Freelance system. In the other 
part the mapping of the attributes is specified; for example, it is configured whether 
“Condition” or “Sub-Condition” must be used as message type in Freelance.
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3.10.1 Configuration of an OPC server

Specify the IP address of the PC on which the OPC server and the OPC tunnel is 
installed. The port number is the same as the one used in the OPC tunnel 
configuration (9950). 

OPC_config_us.png

> In the project tree, right-click Software (SW) > Insert > next level 
> select OPC server OPC-S > OK 

Configuration dialog is displayed.

Enter any Name (for example, OPC1) and the Location, where OPC server is 
running.
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3.10.2 OPC function block library

An OPC function block class library OPC_FB-LIB is used to structure OPC 
function block classes. For each OPC_FB_LIB the assignment to OPC servers in the 
Freelance project are configured.

Double click an OPC_FB-LIB node to configure the assignment of the OPC 
libraries to the OPC servers in the project.

For using predefined OPC function block classes, a library provided with the setup 
can be imported:

The import result will the added in the Pool node, drag and drop it below the 
OPC_FB-LIB node. The library may now be used in the project.

3.10.3 Browse and add items of an external OPC server

The configuration of an OPC server can be read directly in the project through the 
browsing interface:

Click Synchronize and select the required OPC server from the list. All items of 
this OPC server which can be reached through the browser interface are listed in the 
OPC item list dialog. After selecting one or more of these items from the list, a new 
function block class OPC_FB-CLASS or a new instance for an already existing 
OPC_FB-CLASS can be created.

3.10.4 Instantiate tags

Instantiate tags using the Instantiate all button in the OPC item list. This will match 
the OPC items (the “selector” part of the OPC item name after the separator) in the 

> In the project tree, right-click Software (SW) > Insert > next level 
> OPC function block library (OPC_FB-LIB)

> Edit > Import Block

Browse a library file, for example ...\export\FreelanceSampleTagTypeLib.prt

> Project tree > System > OPC item list
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item list with that in the tag type library and lists the matching tags. The list of tags 
with proposed tag names are listed in a Rename dialog as shown below.

OPC_Server_Rename.bmp

Specify the new names for new tags in the New name column and click OK. The 
tags linked to the corresponding OPC items are created in the tag list.

3.10.5 Assign variables

A single item can be instantiated as a variable in the Freelance project. Select the 
OPC items from the OPC item list that are to be used in free graphics or trend 
displays and assign them to variables. A new dialog, similar to the tag name dialog, 
shows the OPC items and suggested new variable names. 

Specify the required “variable name” in the New name column and click OK. All 
the OPC items with the new names will be assigned as a variable in the variable 
list.

You can configure free graphics and trends from the tags and variables created 
above. For more information, refer to Engineering Manual System Configuration 
and Engineering Manual IEC-61131-3 Programming.
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