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About this book

Electrical warning icon indicates the presence of a hazard which could result in 
electrical shock.

Warning icon indicates the presence of a hazard which could result in personal 
injury.

Caution icon indicates important information or warning related to the concept 
discussed in the text. It might indicate the presence of a hazard which could 
result in corruption of software or damage to equipment/property.

Information icon alerts the reader to pertinent facts and conditions.

Tip icon indicates advice on, for example, how to design your project or how to 
use a certain function

Use of warning, caution, information, and tip icons
This publication includes Warning, Caution, and Information where appropriate 
to point out safety related or other important information. It also includes Tip to 
point out useful hints to the reader. The corresponding symbols should be 
interpreted as follows:

Although Warning hazards are related to personal injury, and Caution hazards are 
associated with equipment or property damage, it should be understood that 
operation of damaged equipment could, under certain operational conditions, result 
in degraded process performance leading to personal injury or death. Therefore, 
comply fully with all Warning and Caution notices.
 Engineering - Operator Station Configuration 11
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Terminology
The Glossary contains terms and abbreviations that are unique to ABB or have a 
usage or definition that is different from standard industry usage. Please make 
yourself familiar to that.

You will find the glossary at the end of the Engineering Manual System 
Configuration.

Document conventions
The following conventions are used for the presentation of material:

• The words in names of screen elements (for example, the title in the title bar of 
a window, the label for a field of a dialog box) are initially capitalized.

• Capital letters are used for the name of a keyboard key if it is labeled on the 
keyboard. For example, press the ENTER key.

• Lowercase letters are used for the name of a keyboard key that is not labeled on 
the keyboard. For example, the space bar, comma key, and so on.

• Press CTRL+C indicates that you must hold down the CTRL key while 
pressing the C key (to copy a selected object in this case).

• Press ESC, E, C indicates that you press and release each key in sequence (to 
copy a selected object in this case).

• The names of push and toggle buttons are boldfaced. For example, click OK.

• The names of menus and menu items are boldfaced. For example, the File 
menu.

– The following convention is used for menu operations: MenuName > 
MenuItem > CascadedMenuItem. For example: select File > New > Type.

– The Start menu name always refers to the Start menu on the Windows 
Task Bar.
12  Engineering - Operator Station Configuration
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• System prompts/messages are shown in the Courier font, and user 
responses/input are in the boldfaced Courier font. For example, if you enter a 
value out of range, the following message is displayed:

Entered value is not valid. The value must be 0 to 30. 

You may be told to enter the string TIC132 in a field. The string is shown as 
follows in the procedure:

TIC132

Variables are shown using lowercase letters.

sequence name
 Engineering - Operator Station Configuration 13
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1  Messages and hints

1.1 General description - Messages and hints
The task of message processing in Freelance Engineering is to configure the method 
of processing and displaying messages in Freelance Operations on the Operator 
Station.

Messages are used by the process stations in the Freelance system to notify the 
operator stations of changes in the process operation. Such changes may be faults or 
states in the process or also error functions of the Freelance system itself.

The Freelance system makes available the message types system message, fault 
message, switch message, hint and hint message. These types of message can be 
classified into different priority levels, one system level (divided into three groups, 
S1 - S3) and five user levels (1 - 5). The individual priority levels are displayed in 
different colors.

Different acknowledgment strategies can be allocated to these priority levels. 
Acknowledgment strategy here means how the operator at the control stations is to 
acknowledge the messages which arrive. The acknowledgment strategy to be used 
for each priority can also be configured.

Configuration is divided into global and local message processing.

Global message processing comprises configuration of the acknowledgment 
strategies of messages in the Freelance system as a whole.

Local message processing comprises configuration of the station-specific settings 
for message list, message line, hint list, and horn activation. It has to be done for 
each Operator station separately.
 Engineering - Operator Station Configuration 15
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1.1.1 Display of the message line during operation

The message line is always visible in Freelance Operations. Thus the operator at the 
Operator station can immediately ascertain incorrect behavior in the process and 
take appropriate action. 

The message line contains fields for the display of messages and buttons for 
selecting items on the hint list and for acknowledging the control room horn.

It can be displayed in three different views:

Standard view of the message line

Standard View.png

Several message points with tag names and message point information.

Area view of the message line

Area view.png

Each plant area has its own place in the message line. For each plant area the 
number of the associated messages present is displayed; the plant area is displayed 
in the priority color of the most important message; the most important message is 
shown in the tooltip. When you select a specific plant area button a message list 
specific to the plant area will be opened.

List view of the message line

List View.png

The 4 most important messages are displayed in the same format as the on the 
message page. When you double-click on the message, the faceplate that belongs to 
the message will be opened.

Depending on the selected view the message list may contain a button for point 
acknowledging or visually acknowledging messages in the message line, a field for 
displaying an overflow of the message line and the number of all messages 
contained in the message list.
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1  Messages and hints Display of the message line during operation
Depending on the configuration of the type of acknowledgment, the display of 
the message line changes:

For visual acknowledgment  is indicated. For point acknowledgment 
 is indicated.

 

 

This button is active and marked with an i if messages arrive for which hints 
have been configured. This also applies to the arrival of special hint messages. 
The hint list can then be displayed.

If there are no hints the i is not displayed.

On these fields the arriving messages are displayed. The display in the message 
field contains two lines.

This field is designated the overflow field. The area has a yellow background if 
there are more messages than can be displayed in the message line.

The number below this indicates the total number of messages.

The displayed messages are acknowledged. This is a visual acknowledgment 
only; The number of messages is not affected by this.

The displayed messages are point acknowledged. The number of messages is 
updated if necessary.

This field is used to acknowledge the control room horn. It turns colored as soon 
as the control room horn has been activated. 

 

When a message is selected in the message line, the appropriate faceplate is 
called up for operation.

Message fields
 Engineering - Operator Station Configuration 17
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1.1.2 Components of the message list

MessageList.png

The message list consists of a header, the list with the current messages, and the 
operating element area with four buttons and three checkboxes.

In the header, the total number of messages is indicated. On the right hand side, 
colored boxes indicate if any messages exist outside the currently displayed page. If 
a box is highlighted with its priority color, messages of that priority are not visible 
on the screen. Various checkboxes are available to filter the messages. If you select a 
checkbox, the associated messages will be shown.

In the Message List the fault and switch messages can be displayed in different 
formats. The formats differ in the type of information presented to the operator. For 
system messages only a fixed display format is available.

In the operating element area messages can be acknowledged, the sound file 
configured for a message can be played back and the display format can be selected. 

1.1.3 Components of the hint list

HintList.png

The components of the hint list are identical to those of the message list. The 
messages displayed are hints and/or hint messages only.
18  Engineering - Operator Station Configuration
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The operation of the hint list also corresponds to the operation of the message list. 
The only differences relate to the filtering of messages and hint list is only visual 
acknowledge is possible.

1.2 Message types
In the Freelance system, messages are divided into the following message types 
according to their importance to the process:

Message type Description

System messages System messages have the highest priority level and are 
subdivided into three message groups S1 to S3. Messages of 
this priority level cannot be configured or changed by the us-
er.The priority level of a system message coming from the 
OPC server can be changed. They are used to signal fault 
states of the system. For a list of the system messages see 
Operators Manual Operator Station, System Messages.

Fault messages Fault messages have priority levels 1 to 3. Messages of this 
type are used to indicate e.g. alarm limit settings being violat-
ed.

Switch messages Switch messages have priority level 4. Messages of this type 
are used to indicate switch events, e.g. valve open/closed.

Hints The option exists of configuring a hint for each fault message 
and switch message. The configuration of such hints should 
give the operator the cause of the message, options for elimi-
nating the process anomaly and if necessary further hints for 
operation. Hints appear only in the hint list.

Hint messages Hint messages have priority level 5. They are contained only 
in the hint list and are solely for the operator’s information.
 Engineering - Operator Station Configuration 19
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1.2.1 Priority levels

Freelance messages which arrive from the process stations can be of varying 
importance for the problem-free running of the process. The Freelance system offers 
six different priority levels for messages. Four display colors are allocated to these.

Priority level Message type Display color

S1 - S3 System message blue

1 Fault message red

2 Fault message orange

3 Fault message yellow

4 Switch message yellow

5 Hint message yellow

The same color is used in the message line, message list and faceplates to indicate 
the priority level of a message. 
20  Engineering - Operator Station Configuration
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1.3 Acknowledgment of messages

Types of acknowledgment

Two types of message acknowledgment are possible, visual acknowledgment and 
point acknowledgment.

Visual acknowledgment does not replace point acknowledgment, it is an 
additional function. 

Type of 
acknowledgment

Description

Visual 

acknowledgment

In case of visual acknowledgment the messages are marked 
as “viewed”. This type of acknowledgment has no effect on 
the current state of the message in the process station and 
OPC Server. This is available in the message line and the hint 
list. 

By visual acknowledgment in the message line all listed en-
tries are deleted. However, they are still present in the mes-
sage list. 

Through the acknowledgment in the hint list the hint or hint 
message is marked as acknowledged. Acknowledging a hint 
does not affect the acknowledgement status of the associated 
message.

Point 

acknowledgment

This type of acknowledgment is available in the message list, 
faceplates and the graphic displays, in case of appropriate 
configuration also in the message line. It performs an ac-
knowledgment of the message in the process station. This 
changes the status of the message. 
 Engineering - Operator Station Configuration 21
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Acknowledgment levels of messages

The acknowledgment strategy comprises three different acknowledgment levels.

Acknowledgment in the message line and message list

Depending on configuration, acknowledgment in the message line is by means of 
visual acknowledgment or normal acknowledgment. The acknowledgement type 
being active can be recognized by the mode of display of the button: 

Visual acknowledgment: Point acknowledgment: 

Only point acknowledgment is available in the message list. The appropriate buttons 
can be found in the operating element area.

Acknowledgment 
level

Description

1 Highest acknowledgment level. Messages with this ac-
knowledgement level must be acknowledged for incom-
ing(1) and outgoing(2) messages

(1) A message is designated incoming when the situation giving rise to it has just occurred. It is 
thus entered for the first time in the message line and message list.
Example: A message generated when a process value exceeds its limit will be considered as 
incoming until the value returns to the “normal zone” 

(2) A message is designated outgoing when the situation that caused it is no longer active. In 
some cases, acknowledgment must be used to remove these messages from the message line 
and the message list. 
Example: A message generated when a process value exceeds its limit will be considered as 
outgoing when the associated value is again in the “normal zone”.

2 Messages must only be acknowledged when incoming.

3 Messages do not have to be acknowledged.
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Acknowledgment influences the message status and the following combinations can 
be configured:

An incoming message is active in the process station.

An outgoing message is no longer active in the process station.

The full symbol is displayed at the left in the message list. It is displayed as white or 
black text on a colored background. The background color depends on the priority.

The empty symbol is also displayed at the left in the message list. It is displayed as 
colored text on a gray background. The text color (number and sign) depends on the 
priority.

Acknowledgment in the hint list

Only visual acknowledgment is possible in the hint list. Visual acknowledgment 
has no influence on the display of messages nor on their acknowledgment level in 
the message list. The display of hints depends on visual acknowledgment and the 
state of the corresponding message.

Acknowledg-
ment level

Message
incoming not 

acknowl.

Message 
incoming
acknowl.

once

Message 
outgoing

not acknowl.

Message 
outgoing
acknowl.

once

Message out-
going

acknowl. 
twice

1 Full symbol 
flashing

Full symbol 
static

Empty sym-
bol flashing

Empty sym-
bol static

Not visible

2 Full symbol 
flashing

Full symbol 
static

Empty sym-
bol flashing

Not visible Not visible

3 Full symbol 
flashing

Not visible Not visible Not visible Not visible

Message incom-
ing and not

acknowledged

Message incom-
ing and

acknowledged

Message
out-going and not 

acknowledged

Message
out-going and 
acknowledged

Black text on yellow 
background

White text on a 
black background

Black text on a 
white background

 Not visible
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1.3.1 Filtering messages

The operation dialogs of the message and hint lists offer options for filtering 
messages. These are filters for plant areas, priority levels and system message 
groups. The filter settings assumed on selection of the relevant list can be 
configured. This filter setting can only be made more restrictive if modified in 
operation.

1.4 Acoustic messages, field horn and control room horn
For local alarming, field horns can be connected to a binary output of the process 
stations. For central alarming in the control room one control room horn can be 
connected to each Operator station. 

The horns can be activated by:

• preprocessed field signals

• messages from the function blocks. 

• system messages

• messages from the OPC Server

Horn function blocks must also be configured in the process stations. 
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1.4.1 Activating horns by field signals

After preprocessing the field signals, a resulting binary signal must be connected to 
the input of the horn function block. 

To activate the control room horn, an event message is generated by the horn 
function block. Freelance Operations activates the control room horn after 
evaluating this message.

To address the field horn, the output of the horn function block is connected to the 
field horn via a binary output.

di0380uk.bmp

An event message is an internal message of the Freelance system. It is not visible 
to the operator. Event messages are used at points where a Freelance process 
station is able to control a function in the Operator station directly. Examples of 
this are the horn function and logs.
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1.4.2 Activating horns by messages

Freelance Operations evaluates the incoming messages from the process stations. If 
an incoming message passes the set horn filter, the control room horn is activated by 
Freelance Operations directly.

If an incoming message passes the set horn filter and a field horn must be activated, 
Freelance Operations writes a logic-1 signal to an internal input of the respective 
horn function block. The field horn is switched on. As feedback, an event message 
is generated and sent to Freelance Operations.

di0381uk.bmp 
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1.4.3 Acknowledgment in the field

After pressing the field acknowledge button, which must be connected to the input 
LR of the horn function block, an active field horn is switched off directly.

An activated control room horn can also be acknowledged from the field. In this 
case the horn function block generates an event message. After receiving this 
message Freelance Operations switches the control room horn off.

di0382uk.bmp
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1.4.4 Acknowledgment in the control room

On selection of the Horn off button, Freelance Operations switches off an active 
control room horn. In the case of an active field horn, a logic-0 signal is written to 
the internal input of the respective horn function block by Freelance Operations. 
The field horn is switched off. As feedback, the horn function block sends an event 
message back to Freelance Operations.

di0383uk.bmp
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1.5 Global message processing
Using global message processing you can determine the message and 
acknowledgment behavior of messages on priority levels 1 to 4. These settings 
apply to the whole Freelance system.

Global message list.png

These settings cannot be changed in Freelance Operations.

The acknowledgment strategies used can be set for fault messages (priority levels 1 
to 3) and for switch messages (priority level 4). It is possible to choose from three 
possible acknowledgment strategies for each priority.

In the Project tree > System > Global message processing

System messages and hint messages cannot be configured with a type of 
acknowledgment but have a fixed setting. System messages have 
acknowledgment levels 2 and 3, hint messages always have acknowledgment 
level 3.
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1.6 Local message processing
The local settings apply to individual operator stations. These include the settings 
for the message line, message list, message list, hint list and horn activation. 

local message processing.png

General data 
Name Name of Operator station

Message buffer length 
This number defines the number of possible entries in the message 
list at the Operator station. A minimum of 10 entries must be 
configured and a maximum of 4000 can be configured. 

Level of the message buffer for reacquisition after overflow  
This number defines the nominal level of the message list after an 
overflow. After an overflow has occurred, entries in the message list 
are deleted in accordance with a displacement algorithm. This is 

Select Operator station in the Project tree > System > Local message 
processing

Or

Double-click on Operator station in the Project tree
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repeated until the level within the message list corresponds to the 
value stated here. The positive-displacement algorithm is composed 
of the following steps:

1.6.1 Display tab

Message list 
Display of Selecting Value, Long text or Long text/Message type specifies 

the output format of the messages in the message list at the control 
station.

Formats A choice of different information items is available for the process 
messages, depending on the selected output format:

Value Sound Priority Time Plant area Tag 
name

S-Text ST-Text M-value, 
Dim.

Type Date

Long Sound Priority Time Plant area Tag 
name

S-Text L-Text ST-Text Date

 Message 
type

Sound Priority Time Plant area Tag 
name

S-Text L-Text Type Date

System messages have a fixed display format.

System

message

Sound Group Time Plant area Tag name Fault text Date

1) Deletion of hint messages.
2) Deletion of active, acknowledged messages. First the oldest 

message is deleted and then more recent messages are 
deleted consecutively. Deletion begins with priority level 4 
and continues consecutively to priority level 0.

3) Deletion of the oldest inactive, unacknowledged message. 
Otherwise the same as 2).

4) Deletion of the oldest active, unacknowledged message. 
Otherwise the same as 2).
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Description:

Sound Label identifying messages connected with a configured sound file. 
Only messages for which an audio file has been configured during 
the function block configuration are marked. General sound 
configurations for all the messages of one priority in the local 
message processing (see “Tone type” under Control room horn tab 
on page 37) are not visualized here.

Priority Priority of the message with indication of whether incoming or 
outgoing.

Group System message group; specified by system.

Time Time of occurrence of the message. The resolution is 1/1000s.

Plant area Plant area to which the tag name is allocated.

Tag name Name of the tag which generated the message.

S-Text Short text for the tag. 

L-Text Long text for the tag. 

ST-Text Status text of the message.

Measured value 
Measured value registered when the message was generated, e.g. 
limit value.

Dim Dimension of the measured value.

Type Every message has a message type. For limit values, the message 
type is the limit value type (e.g. HH for the second high limit value). 

Date Only shown with the first message and after a date change. A date 
change is indicated by a horizontal red line.

Fault text Explains the fault which has occurred in the case of a system 
message.

Message order 
Defines which of the messages (the latest or the oldest one) is to 
appear at the topmost position of the message page. 
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Message line 
Supported types 

Defines which of the three views of the message line (plant area, 
list, standard) are to be selectable in Freelance Operations and 
which one of the three is to be the default setting.

Message order 
Defines whether the latest or the oldest message is to appear in the 
message line in standard view at the top on the left or in list view at 
the top.

Acknowledge type 
With Acknowledgment type it is possible to choose between 
visual acknowledge and point acknowledge.  
In case of visual acknowledgment  will appear in the message 
line. Messages in the message line are only visually acknowledged 
and must be acknowledged in the message list. 
In case of point acknowledgment  will appear in the message 
line. Messages in the message line are acknowledged normally.

Priority filter preset  
Here you can choose whether a preset priority filter is to be used for 
the next message list to open.

Use last If a (area related) message page is opened, the messages will be 
filtered according to the priority filters set last.

Select all When a message page is called up, the messages of all priorities are 
displayed.
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1.6.2 Filter tab

Filter.png

The filters set here determine the way in which the message line, message list and 
hint list are displayed.

Message filter Determines which messages appear in the message list. Settings can 
be configured for the system message groups, priority levels and 
plant areas.

Station filter Only messages from the selected process stations will be displayed.

All stations All configured resources will be shown in the adjacent list.

Connected only 
Only those resources to which a connection has been configured 
will be displayed in the adjacent list.

Area filter Determines from which areas messages will be displayed.

The message filter settings are default settings which are taken over loading the 
control station. They can be modified by the user for message and hint list but 
only to make them more restrictive. This means that further filter settings can be 
added but ones which have already been configured cannot be turned off.
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1.6.3 Hint list tab

In the hint list both hints which are configured in relation to messages of the priority 
levels 1 to 4 and independent hint messages (messages of priority level 5) are 
displayed. 

Hint.png

Show current hints 
Defines the position of the latest hint in the hint list. 

Hint filter This determines whether only the hints for priority levels 1 to 4 are 
to be shown in the hint list, or whether the (priority 5) hint messages 
are also to be included.
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1.6.4 Field horn tab

Binary signals control the field horn. Therefore, a function block HORN must be 
configured. See Engineering Manual Functions and Function Blocks, 
Monitoring function blocks.

Field horn.png

Tag name Name of the assigned HORN function block on the process station. 
When you press the function key F2, a list of the available horn 
function blocks will be displayed for selection.

Messages For system message groups S1 to S3 and priority levels 1 to 4 it is 
possible to indicate whether the field horn is to sound when 
messages are Coming or Going or for both.

Area filter Determines, from which areas messages should control the field 
horn.

Ackn. field horn with control room horn 
If the field horn is acknowledged together with the control room 
horn (the control box is activated), the field horn is reset as soon as 
the control room horn at the Operator station has been 
acknowledged. If this field is not activated, it cannot be reset by the 
Operator station!

Quit local sound with field horn 
   The local sound system on the operator station PC is 
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deactivated by acknowledging the field horn. Which of the operator 
stations has acknowledged the field horn is of no significance in this 
case.

1.6.5 Control room horn tab

The notification that an event has occurred can also, in addition to the field horn, be 
made by a sound board in the operator station PC (control room horn).

Control room horn.png

Messages For system message groups S1 to S3 and priority levels 1 to 4 it is 
possible to indicate whether the control room horn is to sound when 
messages are Coming or Going or for both.

Tone type For each priority, several sound files (WAVE files) may be entered 
with or without extensions. These files will be played back in 
succession and with no interval. 
The system loads the files from the Freelance standard directory 
<FreelanceData>\wave. It is also possible to indicate the whole path 
with directory and file names, such as c:\winnt\media\..... The entry 
may have a maximum number of 100 characters. In accordance 
with the Play sound files in setting, the sound system of the 
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operator station will play the selected files for coming and going 
messages.

The sound files configured here, are not marked by the sound symbol at the 
beginning of a line in the message list.

Play sound files in 
In addition to the sound files configured here for the various 
priorities, audio files can also be configured for individual process 
messages. The following three alternatives can be used to control 
their processing under Freelance Operations.

Priority order, oldest mesg/Priority order, newest mesg 
The audio files of the most important message are repeated until the 
message is acknowledged or superseded by a more important 
message.

Time order The audio files of all incoming messages are played back once, each 
in the order in which the messages arise. See also Operators 
Manual Operator Station, Messages and Hints, Messages with 
sound files.

Sound board    The sound system of the operator station PC is active.

   The sound system of the operator station PC is inactive. 
Configured sound files will not be played.

Pause between two messages 
The minimal interval interposed between audio files for different 
messages or between repetitions of the same sound file for a 
particular message.

Area filter Determines, from which areas messages control the control room 
horn.
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2.1 Display access

2.1.1General description - Display access

The display access is a convenient means of quickly calling up the displays assigned 
to the selected tag during process operation, thus obtaining selective information on 
the plant status.‘

After having selected the required tag in Freelance Operations you can select the 
directly callable displays through the Context menu:

• The overview display “<Name> (Over.)”

• The system overview “System display (Sys.)”

• The message list “Messages (Mess.)” 

• The faceplate “<Tag name>”.

Configuring the display access you can assign additionally to each tag the control 
aspect (see below), a selected display of each display and log type, as well as an 
“External aspect” to open any document or application.

One display of the following display and log types can be assigned to each tag: 

• Graphic display (FGR), 

• Group display (GRP), 

• Trend display (TR_D-OS), 

• Signal sequence log (SSL), 

• Operation log (OPL), 

• Disturbance course log (DCL_D-OS), 
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• Time scheduler display (TS_D-OS), 

• SFC display (SFCP), 

• WEB display (WEB).

• Excel report (REPORT)

If one of these displays is configured as default display, the associated entry will 
appear as the topmost one in the context menu; therefore the display can be selected 
extremely fast.

Control Aspect

If the program Control Aspect has been installed additionally on the Freelance 
Operations PC, the context menu of a tag contains the entry Control aspect. After 
having selected this entry, the program which this tag has been configured in will be 
displayed together with the current process variables.

tt0001_us.png

See Operators Manual Operator Station, Operating Philosophy.
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2.1.2 Automatic display allocation

With the default setting display allocations can be specified automatically by the 
system. This serves to reduce the effort for configuration.

When display allocation is called up, and when a plausibility check is carried out on 
an Operator station, the tags, displays and logs contained in the configuration 
database are checked. For each tag, usage is established in the instances of all 
display types and log types.

When usage of a tag is discovered, the display or log is indicated as an entry for the 
display allocation. If no usage nor cross reference is found, this is indicated by the 
entry “<auto>”. 

If the corresponding tag is used in such a type of display at a later point in time, the 
display will automatically be assigned to the tag.

2.1.3 Open display access

After selecting an Operator station resource in the Project tree, the displays and logs 
stored there can be assigned to a tag. 

If the Common display pool (P-CD) is selected, the chosen Display access 
applies for all Operator stations of the project. However, if the Display access is 
chosen later for an Operator station resource, the settings previously defined in 
the Common display pool are overwritten for this resource. 

> Select in the Project tree an Operator station resource or Common display pool 
> System > Display access
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2.1.4 Structure of the parameter definition dialog – Display access

Display Access.png

2.1.5 Display access editor

The tag which the displays and logs are assigned to is selected through the windows 
Tag type and Tag name. The type is selected in the window Tag type. A list of all 
the tags of this type that are present in the system appears in the window Tag name. 
Having selected one of the tag names from the window Tag name, for each 
display/log type you can enter one of the displays and logs provided by selecting it.

Select tag
Tag type List of all tag types

Tag name List of all tags of one type with their names
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Pictures One display or log of each type can be assigned to each tag. The 
currently selected assignment is indicated in the field; when you 
press the edit field, a list of the available displays is displayed for 
selection.

<auto> Automatic display access of this display or log type for the selected 
tag. If the entry <auto> is selected, the data base will be checked 
automatically and the display name of the first reference found will 
be entered in the field. 

<empty> No display allocation of this display or log type for the selected tag. 
If <empty> is selected, no reference will be entered for the 
corresponding display or log type.

<name> All available displays or logs of the corresponding type are listed 
and can be selected for display allocation.

External aspect

Description Entry of any text. This text will be displayed as the bottom entry in 
the context menu of the tag in Freelance Operations.

Command Entry of any command line, for example, Notepad ReadMe.txt. 
With it documentations or Excel files can be linked to tags.

If this possibility is used, the free access to the operating system from Freelance 
Operations cannot be avoided any more.

Auto configure 
The display allocation is changed to <auto> for all tags. As a result, 
allocations that might have been configured before will be deleted.

Cross reference 
The list of cross references is displayed for the selected tag.
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Default display

> Click on display type  
or  
> Select Default display from the context menu for the display name 

Display type is designated with (V)

If several display types have been entered for one tag name, it is possible to 
designate a certain display type. The latter is then in the first place of the context 
menu under Freelance Operations. In all cases, only one of the entered displays can 
be designated as a default display. To change the default designation, simply click 
another display type.

2.2 Multi Monitor
Multi Monitor means Freelance Operations supports up to four monitors for better 
operation and visibility. With this option, user shall be able to customize the display 
types according to user’s request. User can decide to allow or forbid the display 
types on each monitor via the settings in Freelance Engineering.

2.2.1 Multi Monitor configuration on Freelance Engineering

Launch Freelance Engineering.

> Select in the project tree an Operator station resource D-OS, right-click and 
select Header... > Configure monitor. 
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Conf_Monitor_us.png

Select the monitor numbers from the drop-down list. 

Tick the checkbox to select the display type for each monitor and click OK to save 
the settings.

Carry on plausibility check to count the total number of graphic objects.

Increasing the amount of values which are displayed will lead to a higher amount of 
data which have to be transferred from the active automation to the Freelance 
Operator stations. This may lead to overload situations on the Freelance Controller 
or Operation stations which have to be avoided.

If the total number of graphic objects exceeds the limit, an error message pops up 
after the plausibility check. 
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If a dynamic object does not receive a value, it is represented by a red cross. In this 
case, the error message in the Windows event log can be used for further error 
analysis and the configuration should be adjusted.

2.2.2 Multi Monitor display on Freelance Operations

After completing the configuration on Freelance Engineering, user shall carry out 
the plausibility check and load the whole station to Freelance Operations. Some 
interfaces on Freelance Operations such as Overview display, tool bar or menu bar 
will change according to the monitor configuration as documented below:

Overview display

On the Overview panel, the selected types in Freelance Engineering displayed as 
normal, and the unselected types are presented with an eye icon. User cannot 
operate the disabled display types.

Overview
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Toolbar

On the toolbar, the selected display types are displayed as normal. If the display 
types are configured not to display on the monitor, the icon of the display type in 
Toolbar is grayed out for operation.

Toolbar

Menu entry

In Menu entry, the selected display types are displayed as normal. If the display 
types are configured disabled on the monitor, the icons of the display type in Menu 
entry are grayed out for operation.

Menu Entry

Display explorer

In Display explorer, the display types configured as selected in Freelance 
Engineering are displayed as normal. And the ones configured as do not display on 
the monitor are grayed out for configuration.
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Display explorer

Favorites

In Favorites panel, the display types configured as selected in Freelance Engineering 
are displayed as normal. And the ones configured as do not display on the monitor 
are marked with an eye icon on the right lower conner.

Display in Favorites

Group display

In Group display panel, if the display type of faceplates is configured as do not 
display on the monitor, then it will be displayed with an eye icon.
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Display in Group Display

Control Aspect

when there are display types configured as not display on the monitor, in the Control 
Aspect panel, those display types are grayed out for configuration.

Control Aspect

Action for graphic objects

For some graphic objects contain other objects, if the objects type is set to not 
display on this monitor, user is unable to access with a prompt saying the display 
type cannot be shown.
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FGR contains objects.png

2.2.3 Multi Monitor license

Freelance supports up to four monitors, and accordingly it requires the correct 
license key. After loading the monitor configuration from Freelance Engineering to 
Freelance Operations, Freelance Operations detects the configured monitors and the 
license number for monitors. If the configured monitors in Freelance Engineering 
are more than the available licensed, Freelance Operations goes to emergency mode. 
User has to re-configure the monitor numbers from OS header in Freelance 
Engineering, or upgrade the Freelance license. 

2.3 Overview display

2.3.1General description – Overview display

During a Freelance project, one Overview display can be configured for every 
Operation station. It consists of 16 lines with 6 columns each. A maximum of 96 
displays can be represented and selected as symbols.

Existing displays, reports and logs can be listed in a plant-specific manner, using a 
selector list. A freely assignable plant text and the line headers are used to enhance 
clarity.
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 ovewview.png

2.3.2 Create an overview display

An Overview display is created and edited in the Project tree below an Operator 
station resource or in the Common display pool (P-CD). See Engineering Manual 
System Configuration, Project tree. 

> Select an Operator station resource or Common display pool in the Project tree

> Edit > Insert next level > Overview display 
or 
Right-click > Insert > next level > Overview display

If an overview display is configured in the Common display pool, this Overview 
display will be available in all Operator stations.
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2.3.3 Configure an overview display

> Double-click on the name of the overview display in the Project tree

Displays and logs, which had been entered into the overview display but were 
later deleted, are displayed in red in the configuration dialog and are reported as 
non-existent in the error list during a plausibility check.

Overview display

Caption text Maximum 48 characters

Tabs Page 1 to Page 4 
The overview display is configured on 4 pages with 4 lines each.

<1...4> Line header. Maximum 77 characters per line

The numbers specified here depend on the particular page and/or tab.

Segment Name of the display or log entered (six per line)
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Enter display names

> Select an Overview display segment > right-click > Select > Select display 
type and display name from the Select display dialog > OK

Or

> Select an Overview display segment > Enter display name

The display list may also be called up pressing the function key F2. In the window 
that appears, all the displays and logs available at this Operator station are displayed 
classified by display types.

If the display name is entered directly, the system will check whether or not the 
corresponding display exists. The name of an existing display will appear in black, 
the one of a non-existent display in red.

Abbreviations in the Select display dialog

Plausibility check

The Overview display is checked for syntactical and contextual errors. If errors are 
found, they are displayed in a list. Implausible display and log names are shown in 
red in the configuration dialog, plausible ones are shown in black.

DCL_D-OS Disturbance course log
FGR Graphic display
GRP Group display
OPL Operation log
REPORT Excel report
SFCP Sequential function chart display
SSL1 Signal sequence log 1 (direct output to the printer)
SSLN Signal sequence log N (manual output to the printer)
TR_D-OS Trend display
TS_D-OS Time scheduler display
WEB WEB display
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2.4 Group display

2.4.1General description – Group display

For each Group display you may enter a short and a long text which are displayed in 
Freelance Operations in the title line next to the display name. This way a Group 
display can be assigned to a process segment. Existing tags can be entered using the 
tag selection dialog. Accordingly, the standardized representations of tags 
(faceplates) become an integral part of the Group display. 

Group display.png

When configuring a Group display, a distinction has to be made between standard 
screen monitors and wide screen monitors. On a standard screen, up to five tags can 
be shown next to each other, whereas a maximum of six tags is possible with a wide 
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screen monitor. Two standard or four small faceplates can be arranged one on top of 
the other.

If not all the displays can be shown completely in the display area, a horizontal 
scroll bar will appear in Freelance Operations below the Group display.

2.4.2 Create a group display

A Group display is created and edited in the Project tree below an Operator station 
resource or in the Common display pool (P-CD). See Engineering Manual System 
Configuration, Project tree. 

2.4.3 Group display configuration

> Double-click the name of the Group display in the Project tree 
or 
> Select the Group display using the arrow keys > ENTER

Tags that had been entered but were later deleted, are displayed in red in the 
configuration dialog and are reported as non-existent in the error list during a 
plausibility check.

In a Group display either 5 x 2 or 6 x 2 standard faceplates can be combined. As 
faceplates may also have other formats, such as small standard faceplates or custom 
faceplates of user-defined function blocks, the Group display allows you to arrange 
faceplates in a 30 x 4 or 36 x 4 units raster. Faceplates must not overlap.

> Select an Operator station resource or Common display pool in the Project tree

> Edit > Insert next level > Group display 
Or 
Right-click > Insert > next level > Group display

If a Group display is configured in the Common display pool (P-CD), this Group 
display will be available in all Operator stations.
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Group display configuration.png

Short text Maximum 12 characters

Long text Maximum 30 characters

In Freelance Operations, short text and long text are displayed, additionally to the 
display and/or log name, in the title line

Wide screen 
   Six columns are available for the display of the faceplates. 
   The right-most column of the configuration area is “blacked” 

and it is not possible to insert a faceplate in this area. 

Due to the different formats of the faceplates, however, the right-most area may be 
occupied after the import of a project of previous Freelance versions. If you do not 
use a wide screen, you should look for another place for the faceplates placed in the 
black area and to be precise it should be either within the Group display or in a new 
Group display to be created. The latter will occur especially in case of a group 
display with 24 binary faceplates imported from a previous Freelance version. In the 
current Group display, there is space for maximally 20 binary faceplates if the wide 
screen format is not supported.
56  Engineering - Operator Station Configuration



2  Standard displays Group display configuration
 

Enter a tag

> Select Group display segment by left-clicking with the mouse or by using the 
TAB key and the arrow keys > double-click or press F2 > select tag 

In the Select Tag dialog, all the tags configured so far are listed according to 
function types.

See Engineering Manual, Functions and Function Blocks, Abbreviations.

Plausibility check

The group display is checked for syntactical and contextual errors. If errors are 
found, they are displayed in a list. Implausible entries for tags are displayed in red in 
the configuration dialog, the plausible ones are displayed in black.

> Select function type and name from the tag selection dialog > OK
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2.5 Trend display

2.5.1General description – Trend display

The Trend display makes it possible to graphically display the development of 
process variables for a period of time. Up to six process variables can be depicted in 
each Trend display. The number of Trend displays per Operator station is unlimited.

A Trend display can be used to visualize either the data acquired by a Trend data 
acquisition block or any process variables.

If a Trend data acquisition block is used, up to six values are acquired with their 
respective time stamps and placed in a buffer memory with 200 values per signal 
and, if required, transferred to the Operator station for Long term archival. See 
Engineering Manual, Functions and Function Blocks, Trend data acquisition 
blocks.

Any six variables from the Freelance system may be specified for configuring a free 
trend display. An additional variable with the data type DATE&TIME can also be 
configured for each process variable. The value of this variable is used as a time 
stamp for the process value.

If no separate time-stamp variable is specified, then for variables from a Freelance 
process station the associated system variable <resource_name>.DateTime is 
used. In the case of variables read from an OPC server into the Freelance system, 
the OPC-server time stamp that was supplied with them is used.

In order to use a free Trend display a Gateway station of type ‘TRN gateway’ must 
be configured in the Project tree. See Engineering Manual System Configuration, 
Project tree.

An operator on a Freelance Operator station may also configure a free Trend display 
acquiring any process variables from a Freelance system if a Gateway station of 
type ‘TRN gateway’ has been configured in the project.
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 Trend display.png

2.5.2 Create a trend display

A Trend display is created and edited in the Project tree below an Operator station 
resource or in the Common display pool (P-CD). See Engineering Manual System 
Configuration, Project tree.

2.5.3 Configure a trend display

> Double-click on the name of the Trend display in the Project tree 
Or 
> Select Trend display from the project tree > Edit > Program

The Trend display configuration comprises one parameter definition dialog with 
five tabs.

> Select an Operator station resource or Common display pool in the Project tree

> Edit > Insert next level > Trend display 
Or 
Right-click > Insert > next level > Trend display
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Trend Acquisition.png

General data

Name Trend display name, editable in the Project tree.

Short text Maximum 12 characters

Long text Maximum 30 characters

The short and long texts are also printed along with the project documentation.

Acquisition tab

Use acquisition function block/Use variable acquisition 
Parameter specifying whether the Trend display is based on data 
from a Trend data acquisition block or on independent process 
variables.

In the Common display pool (P-CD), only Trend displays with variable 
acquisition can be used.

Tag name Name of the Trend data acquisition block in the process station. 
Pressing the function key F2 you can select a Trend data acquisition 
block.
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Sample time In the time interval configured, the process variables are read and 
stored as trend data.

Variables 1 ... 6 
Variable Name of the free trend variable. The function key F2 is used to open 

the list of known variables in the system.

Time stamp variable 
Name of the process variable whose value is used as the time stamp 
for the variables entered under value. The function key F2 is used 
to open the list of known variables of data type DT in the system. If 
no separate time-stamp variable is specified, then for variables from 
a Freelance process station, the associated system variable 
<resource_name>.DateTime is used; in the case of variables read 
from an OPC server into the Freelance system, on the other hand, 
the OPC-server time stamp that was supplied with them is used.

Display tab

Trend display.png

Colors Selection of colors for foreground, background and window of the 
Trend display (3 colors).

Variable description 
For display in the Trend display a name, short text, dimension and 
a tag are assigned to each trend. The number of trends is equal to 
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the number of connected inputs on the trend acquisition module or 
the number of entered trend variables.

Name The Name assigned to the trend. 

Short text The Short text assigned to the trend.

Dimension Dimension assigned to the trend. The Dimension can be entered 
directly or can be selected from an existing list, using the arrow 
keys or mouse.

Allocated tag Tag name whose faceplate can be opened in Freelance Operations 
by double-click.

Color Color selection for each trend curve. All colors available for graphic 
displays are available. Default settings for color:

The text entries or text selection for Name, Short text and Dimension are depicted 
in Freelance Operations with the trend. These entries are not mandatory.

Trend 1 signal red
Trend 2 signal yellow
Trend 3 signal blue
Trend 4 signal green
Trend 5 signal cyanide
Trend 6 medium magenta
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Area options tab

Trend Area.png

Area options The parameter definition of position comprises the time range for 
depiction on the X-axis, the definition of scaling on the Y-axis and 
band start/band end for up to six trends. 

Time gaps Maximum time interval between two successive time stamps of a 
value. The values in this internal are interpolated (see Operators 
Manual Operator Station, Trend Display, Interpolation). Entry is 
made according to IEC 1131-3 time format. 
If no time gap detection is configured Freelance Operations will 
display three times the cycle time as gap. Example: With a cycle 
time of 10s a data gap of 30s will be displayed as a gap in the trend 
even if no gap detection is configured.

Time axis The time axis specifies the scale on the X-axis for the trend 
depiction in Freelance Operations. Entry is made according to 
IEC1131-3 time format. The maximum value is around 
T#24d20h31m23s. Example: T#2147s or T#24d20h31m23s

Band start The Band start specifies the value for the scale start of the Y-axis 
for depicting an individual trend. See display “Example of the trend 
depiction” on the following page.  
Values are entered as real numbers. The value range is between 0.0 
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and ±9999999999.9. The value for the band start must be less than 
the value for the band end.

% The percentage value specifies the position of the scale start for 
Band start % on the Y-axis. See figure below. 
The percentage values must be entered as integers. The value range 
is between 0 and +5000%.

Band end The Band end specifies the value for the scale end of the Y-axis for 
depicting and for the individual trend. See figure below. 
Values are entered as real numbers. The value range is between 0.0 
and ±9999999999.9. The value for the band end must be greater 
than the value for the band start. 

% The percentage value specifies the position of the scale end for 
Band end % on the Y-axis. See figure below. 
The percentage values must be entered as integers. The value range 
is between -5000 and +5000%.

Example of a trend display:

di1311.bmp

The following settings have been chosen for the parameter definition of the position:

Band end: -10.0 Band end: 110.0
Band start %:  20 Band end %: 80
64  Engineering - Operator Station Configuration



2  Standard displays Configure a trend display
 

Archive tab

Trend Archive.png

Archive A decision is made whether the trend data archiving is to be enabled 
on the Operator station. If Enable archiving is selected, specify the 
following: Archive duration, Start up mode and if you want to 
Delete the old archive. On the Operator station only one trend 
display with a fixed size configured for an archive file (as ring 
memory). 

Enable archiving 
   The trend data are archived as a function of the Start up mode.

Delete old archive 
   The old archive will be deleted on restarting the Operator 

station (new start of Freelance Operations). 
   Archiving is resumed with a chronological gap after a restart.

If archives do not match after a restart, e.g. the number of trends have changed in 
the meantime, the old archive is saved as a file. The old archive files are assigned 
a serial extension from 001 to 999. 

Archive duration 
The Archive duration is entered according to the IEC 1131-3 time 
format. The entry can be made in days, hours, minutes and seconds. 
Inputs less than 1 s lead to error. 
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Maximum 24855d = 68 years  
Example: T#24855d or T#24d20h31m23s 
Apart from the input field for the archive duration, the maximum 
hard disk requirements for archiving on the Operator station are 
given in kilobytes.

The size of the trend file is determined by the archive duration. This size can 
never be exceeded by the Trend file since data are stored in a ring memory. This 
means that on reaching the archive duration, the oldest data are always 
overwritten again by the current data.

The archive files should not be greater than 1 Gbyte, in order to limit the load 
time in Freelance Operations.

Start up (only for displays that get data from a Trend acquisition block) The 
Start up defines whether trend data recording and archiving should 
start immediately after starting Freelance Operations.

Ready     Acquisition and archiving are ready but not yet started after 
starting the Operator station. Start is triggered by changing a flank 
at one input of the trend acquisition module. See Engineering 
Manual, Functions and Function Blocks, Trend acquisition 
blocks.

On     Acquisition and archiving are switched on after starting the 
Operator station.

Archive name The file name for the trend archive file on the Operator station hard 
disk can be specified.
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File transfer tab

Trend FT.png

File transfer Here it is decided whether - and in what way - a copy of the trend 
file should be transferred from the Freelance Operations PC to 
another PC in the Freelance net. The PC that is to receive the 
archives must be a communications subscriber in the net (network 
card and installed FTP server, see Getting Started Manual). It is 
also possible to export the Archive file to a Windows drive of the 
Freelance Operations-PC.  
To visualize the trend archive data and to convert them into the CSV 
format, the Freelance supplementary program Archive Browser can 
be used for this PC. 

File transfer (FT) 

Start export at Cyclical transfer enabled as soon as the configured time is reached. 
Make entry in the DT format. 

   Start time for the cyclical data transfer 
   No cyclical data transfer.

Reexport every Here it is determined at which time periods data transfer is effected. 
Make entry in the TIME format.

incremental    Only the data acquired since the last data transfer are 
transmitted.
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complete    All archived data are transmitted.

Export on event 
   Data transfer takes place as a function of the state of the 

entered event module. It is compulsory to input an event module. 
The function key F2 is used to open a selection list showing the 
available event modules.  

   No event-controlled data transfer.

incremental    Only the data acquired since the last data transfer are 
transmitted.

complete    All archived data are transmitted.

Reexport 
on every event    Data transfer will occur only in case an event flank increases.

cyclic every    Data transfer will occur only when an event flank increases. 
From this period on, the data transfer will be effected cyclically as 
long as the event is current. 
Which time periods the data transfer should follow are determined 
here. Make entry in the TIME format.

Access manually export (once, complete) 
   The operator at the Operator station can enable file transfer. 
   File transfer cannot be enabled manually.

Target Here the target of the file transfer must be defined. As a target a PC 
connected to the Freelance network is used. Ideally, the 
supplementary package Archive Browser should be installed on this 
PC to permit visualization of archive files of the trend and of logs.

Station Specification of the IP Address of the target computer. If you 
operate your Freelance system in a network, you should obtain the 
IP addresses from your network manager, as this address must be 
chosen unambiguously throughout the world. If you want to use the 
Freelance Operations PC as file transfer target, its IP address must 
be given here.

Path If the archive files are to be copied into a specified directory, the 
complete directory name must be given here. It is important to enter 
a backslash \ as last character. If e.g. only C:\temp is given as 
68  Engineering - Operator Station Configuration



2  Standard displays Configure a trend display
 

directory, the file c:\tempXXXX.001 is generated on the target 
computer, with the Xs denoting the first four characters of the 
configured archive name.

It must be noted that the target station is responsible for further processing of the 
files during export. The copied file is only temporary and is overwritten again 
with the next export of the corresponding archive.

File    The export files are saved in the file name given under target 
path.

Directory (8.3)    The export files are saved in the directory given under the 
target path with names generated by the system using the current 
date and time. The file name has a length of 8 characters with a 3 
characters extension.

Directory    The export files are saved in the directory given under the 
target path with a name generated by the system using the given 
name and the current date and time.

Suffix for incremental/complete 
   In order to distinguish between files containing complete or 

incremental data sets, either ‘_INC’ or ‘_FULL’ is appended to the 
basic file name. This suffix prevents a situation from occurring 
where complete and incremental files are allowed to overwrite one 
another.

FTP timeout FTP services are synchronous services. To prevent blocking the 
system, a maximum time, in which an FTP service must have been 
executed, must be specified.

User name This user name must be entered. If necessary, this name is checked 
by the FTP server.

Password This password can be defined when setting up the receiving PC. 
This ensures that only the subscriber who knows this password can 
store files in the PC. In this manner abuse or manipulation by non-
authorized subscribers can be prevented in open nets.
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2.6 Sequential function chart display

2.6.1General description - SFC display

The Sequential function chart (SFC) is a user-defined net of steps and transitions. 
The action block is defined as a step and the step-enabling condition as a transition. 
Steps and transitions are represented by graphic symbols. The representation, 
symbol type and color of the symbols depend on the status of the steps and 
transitions. Each SFC program begins with an Initial Step and ends with an End 
Transition. All steps are inactive during initialization of the SFC program. The 
initial step is activated at the start of the SFC program, all other steps are inactive. 
The start of the SFC program begins with its Enable, that is, New Start or Repeat 
Time have been reached or have expired. The end transition terminates one 
sequence function chart run. After this all steps are once again in the inactive state.

For the configuration of the Sequential function chart (SFC) and the corresponding 
terms, see Engineering Manual IEC 61131-3 Programming, Sequential function 
chart (SFC).

SFC.png
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2.6.2 Create an SFC display

A SFC display is created and edited in the Project tree below an Operator station 
resource or in the Common display pool (P-CD). See Engineering Manual System 
Configuration, Project tree. 

2.6.3 Configure an SFC display 

> Double-click on the name of the SFC display in the Project tree

SFCP.png

General data  
Name SFC display name, editable in the Project tree

Short text Maximum 12 characters

Long text Maximum 30 characters

Assigned SFC program 
Here, the name of the sequential function chart program of the 
process station to be operated with the help of the SFC display has 

> Select an Operator station resource or the Common display pool (P-CD) in the 
Project tree

> Edit > Insert next level > SFC display 
Or 
Right-click > Insert > next level > SFC display

If a SFC display is configured in the Common display pool (P-CD), this SFC 
display will be available in all Operator stations.
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to be entered. You may either enter the name directly through 
keyboard or press F2 to open the list of the available sequential 
function chart programs and select the required program.

2.7 Time scheduler display

2.7.1General description – Time scheduler display

With a time scheduler, time-dependent analog values are output and can be sent to 
other functions, for example, to a controller as a set point input. In addition to the 
Time scheduler faceplate, there is an entire-page Time scheduler display. 

This offers a comfortable means of displaying the set-point trend or the actual trend 
and of operating the time scheduler. If required, a tag can be allocated to the display 
whose faceplate should always be shown together with the Time scheduler display 
(generally the faceplate of the post-connected function block). 

The Time scheduler display has been standardized and parameters must only be 
defined for the short and long text, the name of the allocated time scheduler and if 
necessary the name of an additional tag.
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 Time Schedule display.png

2.7.2Create a time scheduler display

A Time scheduler display is created and edited in the Project tree below an Operator 
station resource or in the Common display pool (P-CD). See Engineering Manual 
System Configuration, Project tree. 

> Select an Operator station resource or the Common display pool (P-CD) in the 
Project tree

> Edit > Insert next level > Time scheduler display 
Or 
Right-click > Insert > next level > Time scheduler display

If a Time scheduler display is configured in the Common display pool (P-CD), 
this Time scheduler display will be available in all Operator stations.
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2.7.3 Configure a time scheduler display 

> Double-click on the Time scheduler display name in the Project tree

Time Schedule display.png

General data  
Name Time scheduler display name, editable in the Project tree

Short text Maximum 12 characters

Long text Maximum 30 characters

Allocation
Tag name of TS 

Name of the allocated time scheduler function block. You may 
either enter the name directly or press F2 to open a list of the 
available function blocks and select the required function block.

Tag name for display access 
Name of the module whose faceplate is displayed in the time 
scheduler window. This entry is optional. 
The function key F2 is used to open a list of the tags that can be 
entered.
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2.8 WEB display

2.8.1General description – WEB display

Calling up a WEB display in Freelance Operations you can load the local WEB 
browser and activate the link to the configured WEB site.

2.8.2Create a WEB display

A WEB display is created and edited in the Project tree below an Operator station 
resource or in the Common display pool (P-CD). See Engineering Manual System 
Configuration, Project tree. 

The WEB display will start the local web browser. That way the Freelance 
Operations user could get access to files on the local machine or on other 
machines within the company’s network or in the global Internet. Please take into 
consideration the risks and dangers associated with that!

> Select an Operator station resource or the Common display pool (P-CD) in the 
Project tree

> Edit > Insert next level > WEB display 
Or 
Right-click > Insert > next level > WEB display

If a WEB display is configured in the Common display pool (P-CD), this WEB 
display will be available in all Operator stations.
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2.8.3 Configure a WEB display 

> Double-click on the name of the WEB display in the Project tree

Web.png

General data
Name WEB display name, editable in the Project tree

Short text Maximum 12 characters

Long text Maximum 30 characters

URL Link to the required WEB site.
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3.1 General description – Graphic display
In addition to the standard displays, custom graphic displays for observation and 
operating the process can be used on an Operator station. These graphic displays 
can be created with the Freelance Engineering graphic editor. The state of a process 
can be depicted in numerous respects with such graphic displays. The static and 
dynamic graphic objects available make possible a varied graphic representation of 
the running process. Use of the various animation options makes it possible for the 
plant operators to observe process events in context at all times.

Each graphic display consists of static and dynamic elements. The static elements 
are made up of basic objects, such as lines, circles, texts and bitmaps. Available as 
dynamic elements are special graphic objects (such as alphanumeric displays and 
bar graphs) with which current process values can be displayed, either as numeric 
values or graphically. Operable elements form another category; they can be used to 
trigger a display switch, open a tag allocation faceplate, acknowledge a message or 
write values to process variables. The state of the dynamic display elements in 
Freelance Operations is determined by the assigned variables and messages from 
the common Freelance database.

Graphic symbols can be created from several single graphic objects. These new 
objects can then be processed further, just like any single graphic object. Graphic 
objects may also be defined as macros and stored in macro libraries. These libraries 
can be used as often as required, even in other projects.

The aspect ratio of a graphic display can be set to match the physical resolution of 
the monitor used:

• Widescreen format, logical resolution 14440 x 6728, suitable for 16:9 / 16:10 
monitors.

• Conventional screen format, logical resolution 10240 x 6728, suitable for 5:4 / 
4:3 monitors.
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The aspect ratio of new graphic displays can be predefined in the header data of the 
operator station (D-OS). This default setting can be modified in the menu bar of the 
draw area: 

Ratio_us.png

When a graphic display that has been created for another aspect ratio is indicated in 
Freelance Operations, it is scaled as required while maintaining the aspect ratio. In 
this case, either the full height or the full width of the available screen area is used 
(see Operators Manual Freelance Operations). 

The zoom level, as well as the current position of the cursor in the drawing area, are 
displayed in a toolbox.

Further functions include the editing of two displays simultaneously. The first 
display is a named program in the Project tree. The second display, called the 
graphic pool, possesses the same graphic characteristics as the other display and is 
always loaded simultaneously with the project. In the graphic pool display, 
complete displays, partial displays or graphic symbols can be temporarily saved for 
later use. The contents of the graphic pool are retained when another display is 
selected.

To support the user in creating complex process displays, several graphic macros are 
prepared and provided during the installation of Freelance Engineering. Five macro 
libraries are copied into the directory <FreelanceData>\macros.

• 3D_Macros.bol: The description of this library can be found in the file 
3D_Macros Library.pdf in the <FreelanceData>\macros folder.

• hb_sym01.bol: For more information on hb_sym01.bol library, refer to 
Appendix - Graphic macro library on page 193.

• Macros.bol: This library contains graphic macros that simplify the creation of 
user defined faceplates.

• S900_UFB_macro_library.bol: This library contains graphic macros to be used 
with S900 device.

• ufp_sym1.bol: This library contains graphic macros that simplify the creation 
of user defined faceplates in the conventional design of Freelance Operations. 
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3.2 Graphic editor interface
The graphic area consists of the Menu bar, Toolbar, Graphic editor tab, Graphic 
editor toolbar, the draw area with the editor-specific toolbox and the Status bar.

FGR edit.png

3.2.1 Additional features of the graphic editor

Graphic editor behavior is based on that of standard Windows programs. In 
addition, the graphic editor offers a number of special functions to simplify the 
preparation of a graphic display and its incorporation into the project database.

Cursor keys The cursor arrow keys can be used for precise positioning of the 
cursor in the draw area. With each key actuation the cursor is moved 
in the corresponding direction by exactly one screen pixel. When 
the grid is switched on, the cursor is moved by one grid unit. See 
Snap/Grid on page 85.

F2 key Opens a selection list. 
If a selected configuration mask field is to be filled in with a 
reference to some project element, the name of that element can, in 
general, either be typed in directly or chosen from a list of all 
possible entries. This list can be called up by pressing the F2 key. 
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Example 1: When during configuration, the name of a process 
variable is expected, the list called up by pressing F2 contains all 
process variables that have been configured in the current project. 
 
Example 2: When configuring a dynamic graphic object, the name 
of an associated static object is expected. Pressing F2 brings up a 
list of all static graphic objects that are available in the graphic 
display.

F5 key Display cross references. 
If the F5 key is pressed in an edit field containing a variable name, 
the list of cross references for that variable will be displayed. It is 
then possible to branch directly to any of the programs shown in the 
list.

Tool tip If the cursor is moved over a graphic object which has had a name 
assigned to it, the name and type of the object is displayed in the 
form of a tool tip.

ESC key As long as an object has not yet been defined completely, the 
configuration can be abandoned by means of the ESC key. The 
unfinished object is deleted and the graphic editor is set in standard 
mode.
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3.2.2 Menu bar

menu bar.png

Project General actions related to the whole project.

Editor Performs plausibility check, indicates error list, exports and imports 
of the graphic display and exits the graphic editor.

Elements Draws static graphic objects such as lines, rectangles, text and so 
on, inserts bitmaps and creates message type symbol.

Edit Undoes or repeats last action, groups graphic objects to form new 
objects, or ungroups them again, cuts, pastes, deletes, copies and 
doubles graphic elements, mirrors, rotates, arranges or aligns 
graphic objects, places graphic objects in the foreground or 
background, switches to the graphic pool display.

Change Changes attributes of lines, areas, texts and text contents, shifts or 
deletes points of polygons and polylines, assigns names to graphic 
objects, selects the background color for the display.

Macro Loads or saves a macro library, used for creating, editing and 
inserting macros. 

Animate Reedits dynamic objects, creates dynamic objects, such as bar 
graphs, fill areas, etc.

View Shows the complete display without editor help markings, redraws 
graphic, simulates self-animated objects, selects setting of zoom 
and visible region.

Options Print, set grid setting, determine toolbox position, limit and resize 
display, activate threaded cursor and auto accept.

Help Calls up the on-line help system.
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3.2.3 Draw area

The draw area is the user’s actual working area for creating and editing displays. It 
is located between the menu line or tool bar and the status line and fills the entire 
screen widthwise. With the toolbox switched on, the visible draw area may be 
restricted as a result of overlapping. Using the zoom function it is possible to zoom 
in or out on a section of the display being edited. The Overview function shows an 
area corresponding to 9 x the drawing size. The actual draw area is shown in the 
center, marked with a border.

The coordinates on the draw area run from left to right and from top to bottom. The 
coordinate origin is at the top left-hand corner. The coordinates of the moving 
graphics cursor are shown in the toolbox. In addition, the coordinates are used to 
indicate the position of display objects in the parameter dialogs and are shown there.

3.2.4 Toolbox

Information about the current graphic display is shown in the toolbox. This window 
can be positioned with the Options > Toolbox menu item. It can be placed at the 
right, left, top or bottom of the screen and it can be hidden with the off setting. 
Wherever it is originally positioned, it can be moved about freely on the screen.

The display of graphic editor, faceplate editor and macro editor is differentiated by 
toolbox. For example, Graphic editor toolbox, Faceplate editor toolbox and Macro 
editor toolbox. All editors toolbox have the same functionality. For description we 
are explaining only one toolbox.

Toolbox.png

Names A graphic name or the term “Pool” (for graphics pool) shown in red 
indicates that the corresponding display is the visible one. It is 
possible to toggle between the two displays with the Page  or 
Page  keys or with the help of the menu.

Display size Selected resolution of the X- or Y- coordinates.
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Display Displays the currently selected Zoom setting and x/y coordinates of 
the cursor position.

Line Changes the global line attributes (line thickness, color and style). 
All subsequent lines receive these attributes. When selecting or 
drawing a line, the text Line disappears and a line with the pre-
selected attributes is displayed on this button.

Area Changes the global Area attributes (foreground/background color, 
fill pattern). All subsequent graphic items receive these attributes. 
When selecting or drawing one of these items, the text Area 
disappears and a rectangle with the selected color and fill is 
displayed on this button.

Text Changes the global text attributes, such as foreground/background 
color and type size. All subsequent texts receive these attributes. 
When selecting or entering text, the text type and color selected is 
displayed on this button.

Changes of individual graphic objects are carried out in the Change menu. The 
selection windows are described in detail in the corresponding section of this 
document.

The second section of the toolbox contains one button for selecting and one button 
for each type of graphic object. After an object type has been selected, any number 
of objects of the same type can be drawn one after another. This drawing mode ends 
when a different object type is selected or the selection button is clicked.
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3.3 Basic settings for the draw area
The settings for the draw area are made through the Options menu.

toolbox config.png

3.3.1 Print

> Options > Print > Display only  
> Windows print options dialog  
> OK

The draw area is output to the printer.

The current visible content of the Freelance Engineering window is output to the 
printer.

> Options > Print > Whole screen 
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3.3.2 Snap/Grid

> Options > Snap/Grid

snap.png

Grid size from 1 to 20  
   Snap active, or grid visible, respectively.

In order to achieve more uniform positioning, it is possible to display a 
Background grid. There is an option of 5 fixed grid sizes. The grid setting applies 
both to the graphic and to the graphic pool displays. While a display is being 
constructed the grid can be altered and switched on and off.

When Snap is activated, only the grid points are available for positioning, i.e. the 
user does not have to click on the required grid point exactly, but only sufficiently 
near it. The grid point nearest to the cursor is then selected. The grid and snap 
settings are independent of each other, i.e. a grid may be defined without snap being 
activated, or snap may be activated without a visible grid.

When using the snap/grid function for configuring a graphic display it is strongly 
recommended to use the same monitor resolution when making later changes of 
that graphic display. 

When the snap grid is calculated by the system, the internal drawing area is 
scaled to the current monitor resolution. If you should use another resolution or 
different system settings such as smaller or larger Windows symbols for later 
changes, this may affect or complicate the alignment of the graphic elements.
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3.3.3 Toolbox

> Options > Toolbox > Off, Right, Left, Top or Bottom.

If Off is selected the toolbox is not visible. Right, Left, Top and Bottom cause the 
toolbox to be positioned along the respective edge of the screen.

For a description of the toolbox, see Toolbox on page 82.

3.3.4 Update display size

> Options > Resize display

This menu choice is used for adapting graphic displays from earlier versions of the 
software to the current standard display size which is 14440x6728.

3.3.5 Threaded cursor

> Options > Threaded cursor

Crosshairs with their intersection point at the cursor arrow are switched on. They 
extend over the entire draw area in the graphic display.

3.3.6 Auto Accept

> Options > Auto Accept

This option is used to suppress the Saving tab dialog box in future. For more 
information on Auto accept, refer to Engineering Manual System Configuration.
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3.3.7 Background color

> Change > Background color

Each graphic display and the graphic pool display may be assigned its own draw 
area background color. The background color can be set in the menu Change.

After selecting Background color, a window appears showing the available colors. 
To enable these colors to be accessed more quickly they are subdivided into a 
number of color groups. For background color, the following color groups are 
allowed Static colors, Media colors and Free colors.

3.3.8 Color selection

During the process of creating a graphic display, colors are specified for the 
background, the static graphic objects and the states of the dynamic graphic objects. 
All such color settings are made in the same color selection dialog box. This dialog 
box is opened from within the different alteration dialogs.

All the available colors are subdivided into various different color groups. The 
groups can be shown and hidden separately, and a direct jump to a particular color is 
also possible.

Each group can be used in any application, except display background.

The special colors group is an exception. The Transparent option can only be 
selected for line attributes, as a text background and for animation; it has the effect 
that the lines or graphic objects are displayed as transparent.

The Original colors setting can only be used in animation. Here, the original colors 
of the graphic object remain intact and are not altered by any animation color 
settings.
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Color Selection.png

Special colors
Transparent    No color, but invisible, that is, transparent.

Original colors 
   The colors of the static graphic object are used.

Groups Selection of the various color groups displayed in the color 
selection window.

Static colors    General colors.

Message colors 
   Colors to display alarms.

Signal colors    Colors to display signals.

Media colors    Colors that are displayed flashing off and on.

Free colors    Colors for display of color graphs.

Go to After entering the color groups ( ) the buttons Static, Message, 
Signal, Media, Free are activated and can be selected. Following 
selection, the selection is positioned at the start of the selected color 
group in the color selection dialog box.
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3.4 Drawing static graphic objects
The following static graphic objects are available: Line, rectangle, polyline, 
polygon, ellipse, arc, circle segment, text, bitmap and message type symbol. All 
static graphic objects are under the Elements menu.

Graphic objects are displayed with their various attributes such as color, width, 
style. Attributes can be altered through the toolbox or the Change menu. After 
drawing one graphic object you must select the type of the object to be drawn next 
from the Elements menu. Pressing the F8 key you can select another object of the 
type just completed.

Elements.png

The appearance of the objects is determined by their attributes. 

Graphics editor attributes Settings

Line color 237 colors and invisible

Line style continuous, dashed, dotted, dash-dotted

Linewidth 6 widths

Arrow left/right/arrows on both sides

Rounded Corners the corners can be rounded off in four stages

Foreground and Background 237 colors each

Fillpattern 15 patterns and invisible
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3.4.1 Line

> Elements > Line  
> Mark starting point with mouse click, a construction line appears, and its end 
point follows the cursor arrow  
> Mark end point by mouse click.

A line here means the shortest connection between two points.

Text attributes Settings

Size Text size in pixels

Text_direction Horizontal or vertical

Character attributes Bold and/or italic and/or underlined

Fix point Start, middle, end, top and bottom

Character font At present Arial, Courier New, Lucida Console 
and MS Sans Serif

Foreground color 237 character colors

Background color 237 colors and invisible

di0506.bmp

Lines are specified with the attributes line color, line style, line 
width and line arrow.
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3.4.2 Rectangle

> Elements > Rectangle  
> Mark starting corner point by clicking mouse, a frame appears, and its end 
corner point follows the cursor arrow  
> Mark end point by clicking mouse.

A rectangle is a graphic item having four sides and four right angles. A square is a 
particular form of rectangle.

di0507.bmp

Rectangles are specified with the attributes line color, line 
style, line width, rounded corners, foreground color and 
background color and fill pattern.
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3.4.3 Polyline

> Elements > Polyline  
> Mark starting point by clicking mouse, a construction line appears, and its end 
point follows the cursor arrow  
> Mark end point of the section by clicking mouse; this point now becomes the 
starting point of the next section  
> Mark end point of the next section by clicking mouse  
> Mark end point of the polyline by double-clicking.

 

di0508.bmp  

A polyline consists of any number of construction points. In 
each case the points are connected by lines. By activating the 
right-hand mouse button, the last end point is deleted and a new 
point can be defined.

It is possible to subsequently alter the construction points of 
existing polylines (see Change > Points).

Polylines are specified with the attributes line color, line style, 
line width, arrow and rounded corners.
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3.4.4 Polygon

> Elements > Polygon  
> Mark start by clicking mouse, a construction line appears, and its end point 
follows the cursor arrow  
> Mark end point of the section by clicking mouse; this point now becomes the 
starting point of the next section  
> Mark end point of the next section by clicking mouse, an area is formed  
> Mark end point of the polygon by double-clicking.

 

di0509.bmp  

3.4.5 Ellipse

> Elements > Ellipse  
> Mark starting point by clicking mouse, a frame appears, and its end point 
follows the cursor arrow  
> Mark end point by clicking mouse.

The starting point lies outside the ellipse and is the corner of an invisible 
rectangle which bounds the ellipse. The size, position and form of the ellipse or 
circle is determined by moving the cursor away from the starting point.

 

A polygon is a closed frame which, like the polyline, can con-
sist of any number of construction points. The first and the last 
point of the polygon are always connected.

By activating the right-hand mouse button, the last point can be 
deleted and a new point can be defined.

It is possible to subsequently alter the construction points of 
existing polygons (see Change > Points).

Polygons are specified with the attributes line color, line style, 
line width, rounded corners, foreground color and back-
ground color and fill pattern.
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di0510.bmp  

 
3.4.6 Text

> Elements > Text  
> Mark starting point by clicking mouse, a text input window appears. The 
starting point is one of the frame’s corners or center points, depending upon the 
settings in the text attributes dialog box.

 

di0513.bmp  

The ellipse is a closed graphic item. A special form of the 
ellipse is the circle.

Ellipses are specified with the attributes line color, line style, 
line width, foreground color and background color and fill 
pattern.

Words, fixed numeric values or special characters can be dis-
played as single line.

Texts are specified with the attributes size, alignment, attri-
butes, fix point, character font, foreground and background 
color.
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3.4.7 Arc

> Elements > Arc 
> Mark starting point by clicking mouse, draw circle or ellipse  
> Finish it by clicking mouse 
> Mark starting point of the arc by clicking mouse, move the cursor clockwise: 
arc gets larger, move the cursor anti-clockwise: arc gets smaller, 
> Mark end point of the arc by clicking mouse,

 

Subsequent changing of the arc size is not possible.

The arc is part of the circumference of an ellipse or a circle. The start and end points 
are connected by a curve.

Construction of an arc:

di0547uk.bmp

di0512.bmp  

Arcs are specified with the attributes line color, line style, line 
width and arrow.
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3.4.8 Circle segment

> Elements > Circle Segment  
> Mark starting point by clicking mouse, draw circle or ellipse,  
> Finish it by clicking mouse,  
> Mark starting point of the circle segment by clicking mouse, 
Moving the cursor clockwise: Circle segment gets larger, 
Moving the cursor anti-clockwise: Circle segment gets smaller,  
> Mark end point of circle segment by clicking mouse.

Subsequent changing of the segment size is not possible.

The circle segment represents a certain part of a circle or ellipse diagram. It is a 
closed graphic item.

Construction of a circle segment:

di0546uk.bmp

di0511.bmp  

Circle segments are specified with the attributes line color, line 
style, line width, foreground color and background color 
and fill pattern.
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3.4.9 Bitmap

> Elements > Bitmap  
> Mark the upper left-hand corner of the insertion position with a mouse-click, 
whereupon the bitmap dialog will appear.

Bitmap.png

Stretch X (%) Bitmap scaling on x-axis (%)

Stretch Y (%) Bitmap scaling on y-axis (%) (with the standard stretch values of 
100% on each axis, the bitmap is imported with its original size, i.e. 
with no distortion)

Transparent    Throughout the whole bitmap, all instances of the upper-left-
pixel color are replaced with ‘invisible’; i.e. the bitmap is imported 
with a transparent background color.

Preview Displays the selected bitmap

Import Opens the dialog for selecting a bitmap file.

Export Opens the dialog for writing the selected bitmap to a file.

Bitmap files can be imported in BMP format. No other formats are supported at 
present. Imported bitmaps can be moved, scaled, mirrored and named. The contents 
of a bitmap cannot be altered in the graphic editor.
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3.4.10 Message type symbol

> Elements > Message type symbol

Different static graphic objects can be displayed in Freelance Operations as a 
function of a message type.

This graphic object can only be used in conjunction with a graphic symbol that has 
been animated on message points. See Graphic symbol on page 140 and Bit 
allocation tab on page 106.

Elements-message type.png

Symbol name List of static graphic object names that have been assigned to a 
message type.

Message type List of message types used in function blocks having a faceplate. 
For list of message types and their meanings, see Engineering 
Manual, Functions and Functions Blocks, Abbreviations, 
Message types/Limit types.

<no message type> 
The graphic object assigned here will be displayed when the 
associated message does not have a message type, or when the 
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associated conditions for displaying a message have an empty 
intersection.

Message point Displays the alarm points which have been configured for the 
graphic object.

Show all symbols  
Upon switching to the graphic display, all objects assigned to this 
message type symbol are displayed.

Display Switch to graphic display in order to assign a static graphic object to 
the previously selected message type.

> Select a line in the dialog > Button Display  
> Switch to the graphic display  
> Choose an existing static graphic object or create a new one  
> Return to the Message type symbol dialog with > Edit > Return to object...  
> The name of the graphic object will be shown in the Symbol name column in 
front of the previously selected message type.

Or

> Select a line in the dialog window > Press F2  
> A list of the static graphic objects in the graphic display is shown. 
> Select an object from the list  
> The name of the graphic object will be shown in the Symbol name column in 
front of the previously selected message type.

A static graphic object can be used as many times as required within a message type 
symbol. As many message types as required can be assigned graphic objects; the 
entire list need not be filled out.

Example 1: 

The newest (most recent) message from the plant area is always to be depicted in 
Freelance Operations.

Procedure:

• Create a new message type symbol (Draw > Message type symbol).

• Draw and assign static graphic objects to the message types which are to be 
displayed in Freelance Operations.
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• Create graphic symbols and assign all message points of the plant area.

• With the help of the animation functions, configure the system to always 
display the newest of the pending messages.

• Assign this graphic symbol to the previously created message type symbol.

In Freelance Operations the message type of the most recent message will be 
determined from the set of all assigned messages. The graphic object assigned to 
this message type will be displayed. If no message can be determined with the 
configured conditions the graphic display will be displayed for which <no message 
type> was configured.

Example 2:

The message type configured to a particular message point is to be depicted in 
Freelance Operations.

Procedure:

• Create a message type symbol (Draw > Message type symbol)

• Draw and assign a static graphic object to the message types which can be 
configured for the message point.

• Create a graphic symbol and assign a message point (e.g. the first message 
point threshold of a controller).

• Assign this graphic symbol to the previously created message type symbol.

In Freelance Operations the message type of the message point will be read and the 
associated graphic object will be displayed. If no message has been configured for this 
message point, the graphic object configured for the <no message type> entry will be 
displayed.

3.5 Animate, dynamic graphic objects
The class of dynamic objects includes objects used in Freelance Operations both for 
depicting/observing process dynamics and for operating the plant, that is, for 
operating on process variables. These objects will be called observation objects 

The graphic display will not be updated automatically if a new tag is assigned to 
a plant area which is configured in the display.
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and operation objects respectively. All these objects are located under the Animate 
menu. The variables used here for animation of the graphic display can be newly 
generated from within the graphic editor or, if already configured, can be selected 
from the variable list with the F2 key.

Animate.png

For depicting changing process states, the most commonly used dynamic graphic 
objects are the following: Bar graphs, Fill areas, Alphanumeric displays, 
Graphic symbols, Self-animated objects and Trend windows.

The following techniques are available to animate observation objects:

• Display the current value of a variable numerically in any required format.

• Display the contents of a string variable as text.

• Display a configured message text.

• Display different static graphic objects as a function of the configured message 
type.

• Depict analog values with bar graphs or arbitrarily shaped fill areas, 
representing, for example, levels in containers.

• Have graphic objects move in the graphic display as a function of an analog 
value.

• Have the graphic attributes of an object (colors, line width) change as a 
function of binary process values.

• Have the graphic attributes (colors, line width) of an object change as a 
function of messages.
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The dynamic graphic objects most commonly used for plant operation actions in 
graphic displays are the following: Selection areas, Buttons, Button fields, Radio 
buttons and Tab controls.

These operation objects can be configured to trigger the following actions in 
Freelance Operations:

• Open a faceplate

• Switch to any other display

• Write a fixed value to a variable

• Write an operation value to a variable

• Acknowledge a message

These operation actions can also be initiated by a display object.

In Freelance Operations, when a graphic display is updated, all dynamic objects are 
placed in front (on top) of any static display elements. This can be altered by 
making the static elements part of a dynamic object and designating them as 
foreground or background components within that object. Such grouping makes it 
possible, for example, to display scale markings on a bar graph.

3.5.1 Create a dynamic graphic object

> Animate > Select type of dynamic graphic object  
> For a new Bar graph, alphanumeric display, Selection field, Button, Button 
field, Radio button or Trend window click mouse to indicate the required 
object position. 
> Parameter definition dialog is displayed

The editing functions under the Edit menu are only partly usable on dynamic 
graphic objects.

The system automatically assigns a name for each new dynamic object, and the 
name is shown in the general section of the parameter definition dialog. It can be 
changed by the user at any time. Object names must be unique within a graphic 
display.
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3.5.2 Delete dynamic graphic objects

> Select dynamic graphic object > Edit > Delete. 
Or 
> Select dynamic graphic object > Press DEL key

3.5.3 Moving and sizing of dynamic objects

On selecting a dynamic graphic object, a frame appears surrounding it. Just as in the 
case of static graphic objects, the dynamic object can be changed in size or moved 
about.

All objects used inside this object will be moved and sized accordingly.

3.5.4 General parameters for dynamic graphic objects

Six tabs are provided in the parameter dialog for the dynamic graphic objects Bar 
graph, Fill area, Alphanumeric display, Selection field, Graphic symbol and 
Self-animated object; they are described here for all objects.

The parameter definition dialogs of the dynam. graphic objects Button, Button 
field, Radio button, Trend window and Tab control are each described separately.

The general section of the dialog shows both the object name and the object type.

Dynamic graphic.png

Object name Shows the name of the dynamic graphic object.

Object type Shows the type of graphic object

BG = Bar Graph SEL = Selection Field,
FA = Fill Area BUT = Button
AD = Alphanumeric Display BTF = Button Field,
SA = Self-Animated Object BTR = Radio Button
GS = Graphic Symbol TC = Tab Control
CUO = Trend Window
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Process value tab

Details of the process variables that are to be displayed with this graphic object. 
Definition of the display of this object in the graphic editor.

Scale tab

The area to be displayed is defined for an animation with an analog value. The limits 
are specified either by constants or by other process variables.

For bar graphs and fill areas, the fill direction and position of the reference line are 
defined.

Bit allocation tab

A dynamic object may have up to 3 dynamic process states assigned to it. These 
binary values are linked in Freelance Operations bit-wise, so that the object can be 
displayed in up to 8 states.

There are two options for defining a binary process state:

• Any process value whose data type is BOOL

• Existing messages

Display tab

Up to 8 object display states are defined for Freelance Operations, corresponding to 
the binary process values.

General tab

Static objects can be configured specifically as foreground or background objects 
for the dynamic object.

When a dynamic object in Freelance Operations is clicked on, this can also be used 
to trigger an action, for example, a change of display or the writing of a process 
variable.

Positions tab (only for graphic symbol)

A graphic symbol can be either moved continuously across an area in the graphic 
display or displayed at up to 8 chosen positions in the graphic display. This area or 
these positions are defined on this tab.
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Tooltip tab

With this tab tool tips can be configured for the dynamic objects. Depending on the 
respective object, there are various tooltip possibilities which are available.

3.5.5 Process value tab

Process value.png

Display variable 
Enter the name of a process variable or select it from the list 
through F2 key.

Message text    In place of a process value, the specified text of a message will 
be displayed. 
Checking this box will make the Message button available. The 
input field will be colored gray and the text <Message text> 
displayed (only available with alphanumeric display graphic 
objects).

Message Choice of the message point, the text of which is to be displayed in 
the alphanumeric display (only available with alphanumeric 
display graphic objects).

Display value (GED) 
On quitting the parameters dialog, the graphic object is displayed 
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on the screen as it is to appear with the value specified. An arrow in 
the graphic object indicates that the scaling has been violated.

3.5.6 Scale tab

The scaling of the display, the fill direction and the position of the reference line are 
specified in this parameter dialog.

Scale.png

Scaling 
Start/End The display range (0 – 100%) can either be specified by giving a 

constant or as a variable name (selection list available with F2).

Filling 
Horizontal/Vertical 

Direction in which the dynamic graphic object is to be filled.

Reference line (%) 
The reference line of the bar graph is given in percent; it defines the 
value 0 in the bar graph drawing area or the fill area.

3.5.7 Bit allocation tab

Dynamic objects of type bar graph, alphanumeric display, fill area and graphic 
symbol may have up to 3 dynamic process states assigned to them. These binary 
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values are linked in Freelance Operations bit-wise, so that the object can be 
displayed in up to 8 states.

There are two options for defining a binary process state:

• Any process value whose data type is BOOL

• Existing messages

Bit allocation.png

Variables/functions
Bit1, Bit2, Bit3 

Either a process variable or a set of message points with a select 
function can be assigned to each of three bit variables. The number 
of bit variables configured will determine the number of graphic 
object states that need to be specified. 
1 Bit-Variable = 2 states of the dynamic object have to be specified. 
2 Bit-Variables = 4 states of the dynamic object have to be 
specified. 
3 Bit-Variables = 8 states of the dynamic object have to be 
specified.

Data input field 
Depends on the state of the Messages check box: 
The binary process state is defined by a variable of type BOOL. 
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Enter the name of a process variable or select it from the list 
through F2 key.

or The binary process state is defined by a set of message points. The 
F2 key opens a dialog for selecting a message function.

Messages    A set of message points is used to define a binary process state. 
If the check box is selected, the Set button becomes available, and 
the text <all messages> is displayed.

Set Choose a set of message points from among all existing message 
points in the project.

After pressing the F2 key in an input field for a bit variable with messages, an 
additional dialog box appears. The choice made there determines which message 
status will be used for evaluation.

Message.png

<active messages> 
From the set of configured messages, those whose message state is 
‘active’ are evaluated.

<all messages> 
From the set of configured messages, those whose message state is 
not ‘inactive, acknowledged’ are not evaluated, that is, all active 
messages and all the inactive, unacknowledged messages.

<not acknowledged messages> 
From the set of configured messages, those whose message state is 
‘unacknowledged’ are evaluated.
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3.5.8 Display tab

Animation of a graphic object with binary process states means that the graphic 
object will be displayed with changing graphic attributes. In addition to specifying 
pre-set colors, it is possible to configure an object to take on the color of a message. 
The message color is determined by the message priority.

It is first determined which of a set of messages are active or pending. Then with the 
function most important message, latest message, oldest message or highest 
priority message exactly one message is singled out. Both the foreground and 
background color of this message, each with or without acknowledgment 
information, can be used for displaying the object. In Freelance Operations, the 
process of singling out a message and updating the graphic object with the current 
colors of that message is repeated once per update cycle.

Display.png

Variable/Function
Bit1, Bit2, Bit3 

Display the configured bit variables and functions.

Table
Bits Displays the possible bit combinations of the binary variables.

State Numbering of the states available for the graphic object.
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Display    On quitting the parameters dialog, the dynamic object is 
displayed with the attributes of the selected line in the graphic 
display.

Msg. This button is available when the state of the graphic object is 
determined by messages. When it is selected, a dialog appears in 
which a message can be singled out.

Border/Fill  
Click mouse on the required color field or press Tab key repeatedly 
until focus is on the required color field, then press Spacebar. 
It is possible to change the border and fill color settings for the 
dynamic graphic object. The setting of the required color is made 
out with the color selection parameter window Color selection (see 
Color selection on page 87). With the setting invisible, the border or 
area is displayed transparent, with Original colors, the colors of the 
static graphic object are used. 
If the state of the graphic object is influenced by messages, then, in 
the second color dialog (Message colors) the object can be 
configured to take on colors from the messages it depends on (see 
below).

Display Switch to the graphic display (operative only with certain dynamic 
graphic objects).

Object name > Click field > Press F2, 
> Names of the static graphic objects that are not yet in use are 
output, 
> Select and OK, 
> Name of selected graphic object is shown in this field.

or

> Click the required field under Object name  
> Use the Display button to change to the graphic display,  
> Select existing or newly created static graphic object which is not yet in use  
> Return to parameter definition through > Edit > Return to object  
> Name of the graphic object is entered in the field (If a static graphic object 
without a specified name has been selected, this object is automatically assigned 
a system-generated name).
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Assignment of a message color to a dynamic graphic object

tu0506us.bmp

Foreground color of message
Background color of message 

The color, determined by the priority of the selected message, is 
used in displaying the graphic object.

with acknowledge information 
without acknowledge information 

The graphic object will be displayed with blinking or static message 
color.

Singling out a message from among the set(s) of configured messages:

After pressing a Msg button in the color table, the following dialog comes up. At 
run-time, exactly one message must be singled out in order, for example, to 
determine the color of a dynamic graphic object.
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tu0507.bmp

In the upper portion of the dialog it is determined, which sets of the specified 
message points are to be used.

In the lower portion of the dialog are the specifications as to which of these 
messages is to determine the current object color.

most important message 
The most important message is determined using the following 
algorithm:

Criterion A: Message status

Step 1 Active, not acknowledged

Step 2 Not active, not acknowledged

Step 3 Active, acknowledged
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All messages being equally important according to Criterion A are 
sorted according to:

Criterion B: priority

Step 1 System messages S1..S3

Step 2 Messages with priority 1

Step 3 Messages with priority 2

Step 4 Messages with priority 3

Step 5 Messages with priority 4

Step 6 Messages with priority 5

All messages being equally important according to Criteria A and B 
are sorted according to: 

Criterion C: Acknowledgment strategy

Step 1 Acknowledgment strategy 1

Step 2 Acknowledgment strategy 2

Step 3 Acknowledgment strategy 3

From all messages being equally important according to Criteria A, 
B, and C the oldest message will be determined.

highest priority message 
The message with the highest priority. If more than one message 
with the same priority exists, the ‘most important’ will be 
determined.

newest message The message with the most recent time stamp. If more than one 
message with the same priority exists, the ‘most important’ will be 
determined.

oldest message The message with the time stamp furthest in the past. If more than 
one message with the same priority exists, the ‘most important’ will 
be determined.
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3.5.9 General tab

General.png

Objects in foreground / background 
Overlapping of static and dynamic graphic objects. Static graphic 
objects can be placed in front of or behind dynamic objects. After 
pressing one of these two buttons, the corresponding graphic level 
is activated. Static graphic objects can be selected or created at that 
level. Return to the parameters dialog through > Edit > Return to 
object. After completion of parameter definition, the edited graphic 
objects are grouped, connected with each other (share a common 
frame).

Grouped graphic objects can be ungrouped as follows:

> Select dynamic object, > Animate > Reedit 
> Select Objects in foreground or Objects on background, graphic level is 
activated, 
> Click on an unoccupied area (no item should be selected), 
> Return to object.

The connection between the dynamic and static objects is removed.
114  Engineering - Operator Station Configuration



3  Graphic display Configuring an action
 

Action When a dynamic graphic object is selected in Freelance Operations, 
an action such as a display change, calling up a tag allocation 
faceplate, operation of a variable or acknowledgment of a message 
can be made to occur. It is also possible to operate a variable or 
acknowledge messages. See following chapter for details on how 
such an action is configured.

Comment Free-form text can be entered to describe the graphic object 
(maximum 33 characters).

3.5.10 Configuring an action

An action can be specified for all dynamic graphic object types except trend 
window. In Freelance Operations, this action will be triggered by a click on the 
object. An exception is to open a tag allocation faceplate: the tag is selected with a 
click and the associated faceplate is opened with a double-click.

One of the following actions can be configured for any dynamic graphic object:

• No action: No action will be performed in Freelance Operations.

• Show display: The configured display will be opened in Freelance Operations.

• Show faceplate: The faceplate of the configured tag will be opened.

• Write variable: Depending on the configuration, the operator can enter a value 
or a fixed value will be written to the configured variable in the process station.

• Write set of variables: Same as Write variable, but a list of variables will be 
written with one write command to the process station.

• Acknowledge message(s): An acknowledge command will be written to all 
configured messages.

• Execute confirmed operation: An operation that has to be accepted pressing the 
OK or ENTER key, can be ended by selecting this action. All pending actions 
will be executed. If this action is selected, the graphic object will receive the 
function of an ENTER key.

• Cancel confirmed operation: An operation that has to be accepted by pressing 
the OK or ENTER key, can be aborted by selecting this action. All pending 
actions will be canceled. If this action is selected, the graphic object will 
receive the function of an ESC key.
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> Press the button Action in the parameter definition dialog

 Actions.png

For the configuration of actions, the drawing order of the graphic elements is 
important. If the graphic area in Freelance Operations is clicked, the action of the 
topmost object will be processed; the action of a lowermost object will not be 
accessible.

After selecting an Action type only the fields associated with the respective action 
remain accessible. An entry can be made directly or through the selection list by 
pressing the F2 key.

Action type Selects an action type to be configured

Show display When the graphic object is selected in Freelance Operations, the 
display entered here will be called up.

Show facplate When the graphic object is selected in Freelance Operations, the 
faceplate associated with the tag entered here will be called up.

Write variable When the graphic object is selected in Freelance Operations, the 
current value of Value will be written to the variable entered here. 
Entering the name of a variable in this field enables the operator 
action in Freelance Operations. If the action is configured for a 
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graphic symbol, the check box Input by sliding symbol will be 
enabled additionally. See Write variable operation on page 117.If 
the action type Write set of variables is selected, this field shows the 
entry <set of variables>. The variable set will be configured through 
the Operation button. For details, see Write set of variables 
operation on page 124.

Acknowledge Selecting the action Acknowledge message(s) enables the button 
Messages and the check box Operation needs to be confirmed in 
the field acknowledgment. See Selection of messages on page 128. 
 

   Operation needs to be confirmed: If this check box is marked, 
an acknowledgment by the operator will be required.

3.5.11 Write variable operation

After a process variable is specified for writing to by a Freelance Operations 
operation action, the type of operation and associated operations log entry format 
must be specified. The value to be written to the variable is either fixed as a 
configuration setting or to be entered by the Freelance Operations user.

Values for structured variables can also be obtained through a graphic display. The 
operation of each component of a structured variable is configured separately. In 
Freelance Operations the operation of the components is carried out one after 
another. Not all components need participate in the operation procedure.

After a graphic object is selected in Freelance Operations, an operation dialog is 
displayed next to the object. When the operation dialog is called up, the current 
value of the process variable to operate is read and displayed as default value. The 
component values can be changed individually and then transmitted to the process 
station by a write command. 

Only one operation procedure can be configured per graphic display for a given 
process variable. It is not possible, for example, to configure one graphic object with 
an input field and another graphic object with discrete values. It is possible, 
however, to configure a variable to receive a value from the user through one 
graphic object and to receive a fixed value through another graphic object.

The dialog which appears when Operation is chosen for configuring the writing to 
a process variable, depends on the data type of the variable.
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Configuration for operating a variable

Write variables.png

Variable Shows the name of the associated process variable.

fix/operate Choose whether the variable is to receive a fixed value or a value 
obtained from the user. If fix is selected, entries may be made in the 
Text for variable, Dimension, Fixed value and Lock fields.

increment This option allows for incremental process value changes. The step 
width changes while the button is being pressed. For configuration 
see Configuring operation: Increment on page 120.

touch A configured value is written while the button is being pressed. For 
configuration see Configuring operation: Touch on page 122.

Type Shows the data type of the variable.

Component For structured data types only. 
One element of the structured variable is selected at a time from the 
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selection list. The operation of each component is configured 
separately. In Freelance Operations the operation of the components 
is carried out one after another.

write/don’t write component 
For structured data types only. 
Whether or not it shall be possible to operate a component in 
Freelance Operations is specified here for each component.

Text for variable 
Input any text. 
This text is entered as the variable name in the operation log. 

Dimension Input any text. 
In the operation log this text is entered after the old and new values. 

Fixed value Input is only possible here if fix operation has been chosen. This 
value is directly written to the process station, without requiring any 
further entries from the Freelance Operations user. 

Operation needs to be confirmed 
an only be selected together with the Fixed value edit field.  
The changed process value is calculated on the basis of the absolute 
value or as a percentage of the scaling.  

   The value configured as Fixed value is only written to the 
process station if, after having clicked the object with the mouse, 
you additionally actuate the ENTER button or an OK button in the 
graphic display. 

   The value configured under Fixed value is directly written into 
the process station upon a mouse-click on the object in Freelance 
Operations. 

continuous In Freelance Operations the value to be written is either entered 
graphically by using the mouse, or numerically by entering a value 
into the input field. 

discrete  For entering a value, up to six alternative options are displayed. 

Min/Max Validity range for entered value.

Lock The operation of a value can be locked in conjunction with a 
BOOLEAN variable. When the operation menu is called up, this 
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variable is first read and operation refused if it has the value TRUE. 
Also, writing a fixed value can be prevented by the configuration of 
a Lock variable.

negate The value of the variable defined in Lock is negated for the purposes 
of locking out operation, i.e. to lock out operation, the variable must 
have the value FALSE.

Configuring operation: Increment

This option allows for incremental process value changes. When selecting an object, 
the associated process value is increased or decreased within its scaling by the 
calculated difference. This new value is directly transmitted to the process, that is, 
no further confirmation is required. Continuous pressing of this button - that is, 
holding down the mouse button for a longer time period - permanently repeats this 
procedure. With this, the process value is changed continuously and not in a single 
step as it would after entering a new value. The step width changes with the time for 
which the button is held down.
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Increment.png

Direction Direction of the progression of values (up/down). The current 
process value is incremented or decremented, depending on the 
configured parameter setting. 

absolute values 
The changed process value is calculated on the basis of the absolute 
value or as a percentage of the scaling. 

   Calculate process value changes in absolute values. 
   Calculate process values changes as percentage values of the 

scale. 

Change rate The longer the button is held down, the more the process value may 
change. With the values for Initial slope, Maximum slope and Time 
to maximum the curve to be used for this calculation is specified. 

Repeat Frequency with which a new value is calculated and written to the 
process station (100 ms, 500 ms, 1 s).
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Configuring operation: Touch

Touch.png

Value on pressed button 
Entry of a constant value which is written as long as the button is 
pressed (that is, while holding the mouse button down).

Value on releasing button 
Entry of a second constant value (optional), which is written once 
when the button is released.

Repeat Frequency with which a new value is calculated and written to the 
process station (100 ms, 500 ms, 1 s).

Configuring operation: Discrete

When selecting discrete instead of continuous a choice of up to 6 fixed values can 
be offered to the Freelance Operations user for selection.
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Discrete.png

Value Value (must be compatible with data type of the variable to be 
operated). When invoking the operation dialog, the variable to be 
written is read and the text associated with the value is selected. 
When Freelance Operations initiates the write action, the value that 
was configured for the selected text will be written to the variable.

Text Input any text. 
The text is displayed to the user, and the corresponding value is 
entered in the operation log. 

Lock The availability of every individual value can be locked, in 
dependence of a BOOLEAN variable. When the operation menu is 
invoked, this variable is read, and the value is not shown or 
indicated as not available, if this variable has the value of TRUE.

negate The value of the variable defined in Lock is negated for the 
purposes of locking out operation of a radio button, that is, to lock 
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out operation of the radio button, the variable must have a value of 
FALSE.

3.5.12 Write set of variables operation

Write set variables.png

Unlimited global variables can be selected for the Write set of variables operation. 
The variables are configured similar to the configuration for writing a single 
variable. Name, unit, value, input range, continuous or discrete operation are 
provided.

For the whole list, it must be configured whether the fixed or operated values will be 
written out of the Graphic display at Freelance Operations or whether the values are 
defined by the operator.

For operated values, the operator must provide the values one by one, similar to the 
operation for a structured variable. After this all values are sent together with one 
command to the process station.
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This kind of operation is necessary for writing HART parameters. Within the HART 
devices one write command will always write the complete list with all parameters.

If the action type Write set of variables is used for writing HART parameters out of 
a graphic display, the configuration must take care that all HART parameters are 
provided in the list.

Add variable All variables and I/O components of the project are shown in the 
Select variable/component dialog. Any variable can be selected and 
will be added to the list of variables to be written.

Remove variable 
The variable that is currently displayed in the Variable field will be 
deleted from the list.

Show list Displays the list of variables configured.

Variable To select the variables from the drop down list to configure the 
variable properties.

Writing an incomplete list of HART parameters may lead to an unspecific 
behavior of the device.
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3.5.13 Acknowledgment of messages

Freelance Operations can be made to acknowledge messages when an object is 
selected.

Acknowledgement.png

Acknowledgment messages are only sent to message points for which an entry in 
the message page is available. Which of the specified message points are to be 
acknowledged when the graphic object is selected, must be specified with the 
acknowledgment function.

From all message points configured under Messages are acknowledged:

all messages all message points.

It is possible to so configure a dynamic object, that when it is selected in 
Freelance Operations, messages which are not visible in the display will be 
acknowledged.
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most important message 
The most important unacknowledged message is determined using 
the following algorithm:

Criterion A: Message status

Step 1 Active, not acknowledged

Step 2 Not active, not acknowledged

Step 3 Active, acknowledged

All messages being equally important according to Criterion A are 
sorted according to:

Criterion B: priority

Step 1 System messages S1..S3

Step 2 Messages with priority 1

Step 3 Messages with priority 2

Step 4 Messages with priority 3

Step 5 Messages with priority 4

Step 6 Messages with priority 5

All messages being equally important according to Criteria A and B 
are sorted according to: 

Criterion C: Acknowledgment strategy

Step 1 Acknowledgment strategy 1

Step 2 Acknowledgment strategy 2

Step 3 Acknowledgment strategy 3

From all messages being equally important according to Criteria A, 
B, and C the oldest message will be determined.
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highest priority message 
The message with the highest priority. If more than one message 
with the same priority exists, the ‘most important’ will be 
determined.

newest message  
The message with the most recent time stamp. If more than one 
message with the same priority exists, the ‘most important’ will be 
determined.

oldest message  
The unacknowledged message with the time stamp furthest in the 
past. If more than one message with the same priority exists, the 
‘most important’ will be determined.

3.5.14 Selection of messages

Select message.png

All allocated tags in the project that have a faceplate and at least one message point 
are listed. Using the buttons in the column headings, the list can be sorted by 
different entries. Search criteria can be entered in the input fields above the list (see 
Engineering Manual IEC 61131-3 Programming, Tags). 

Each line in the list is provided with a checkbox in which to mark the chosen 
message points.
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Search criteria input fields:

Tag Tag name

Area Plant area

Access by client 
The name of a gateway or Operator station can be given as a search 
criterion, that is, only the tags available on this station are listed.

Type name Function block type

L Library type

Show message points 
Every message point of the listed tag is shown on a line of its own.

Column labels:

Tag Tag name

Type name Function block type

L Type of library (S: Standard, U: User defined, E: Special)

Plant area Plant area

Message point Message points

P Message priority

Message Configured message text

Type Message type

Search The list is redrawn, taking any entries in the search criteria fields 
into account.

Select all All message points in the list are selected. The selections remain 
even after entry of new search criteria provides a new list of 
message points.

Unselect All The selection of all message points is undone. This procedure is 
independent of the search criteria in effect and the contents of the 
displayed list.
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Select marked items 
All message points with marked check boxes are selected.

Unselect marked items 
All message points with marked check boxes are unselected.

3.5.15 Tooltip tab

Tooltip.png

Enable tooltip 
If you select this check box, the subsequent check boxes will be 
enabled. If several tooltip variants are configured, these tooltip 
variants will be indicated one below the other in a tooltip in 
Freelance Operations.

Current process value 
In Freelance Operations the name of the display variable and the 
current process value are indicated in the tooltip: 
Value (<Name>): <current value>

Configured action 
The action triggered by clicking on the object, will be indicated as a 
tooltip: 
Load Display <Name> 
Open Faceplate <Name> 
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Write Variable <Name> 
Acknowledge Message (s) 
Accept Operation 
Cancel Operation

Message data In the tooltip the message information is given which is used to 
display the object.

Text In the input field you may enter any text of several lines which will 
appear in the same format in the tooltip.

3.5.16 Positions tab (only for graphic symbol)

Position tab.png

continuous 
x-, y- coordinates 

Enter the x/y coordinates of maximum movement. The movement 
range is produced from the process variable and the scaling. 
The movement vector set determines the movement of the graphic 
symbol when the value of the variable is equal to the end of the 
scale. When the variable value is equal to the start of the scale, the 
graphic symbol is displayed in the design position.
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> Click on x- or y- field, > switch to the graphic display through the Display 
button,  
> Determine position with cursor.

 

Display Switch to the graphic display, 
Return through > automatical return to the parameter definition by 
double-clicking.

discrete 
All positions Enter all positions

Single position Enter a single position

> Select x- or y- field, > Enter the x/y-position or 
> Switch to the graphic display through the Single position button, 
> Click on required position  
> automatic return to the parameter screen 
> Coordinates are entered.

> Switch to the graphic display through the All positions button, 
> Click positions, > Automatic return to the parameter screen, 
> Coordinates are entered.
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3.5.17 Bar graph

> Animate > Bar graph  
> A mouse-click fixes the position of the top left-hand corner; by dragging the 
mouse (rectangle), the size of the bar graph can be adjusted. Another click of the 
mouse at this point concludes the construction of the bar graph,  
> Enter data in the parameter definition dialogs,  
> Display the bar graph without construction frame.

A current process value can be displayed as a rectangular 
column. The minimum and maximum values of the column 
can be given as constants or as other process values. The 
column can be filled vertically or horizontally. The reference 
line of the bar graph is given in percent; it defines the value 0 
in the bargraph draw area.

The line style, line width, pattern and colors for the 
background are defined with > Change > Line attributes/
Area attributes or through the toolbox with the Line or Area 
buttons

The color settings for the border and the areas are made in the 
color table parameter windows (see Display tab on page 109). 

The colors can be made to change as a function of binary variables and/or messages.

For configuration see General tab on page 114, Process value tab on page 105, Scale 
tab on page 106, Bit allocation tab on page 106, Display tab on page 109.Tooltip tab 
on page 130
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3.5.18 Fill area

> Animate > Fill area, > entries in the parameter definition dialog, 
> From the Display dialog go to the graphic display by pressing the Display 
button  
> Select an existing polygon or create a new one > Edit > Back to the Object > 
OK.

A fill area is linked to a polygon. The area bounded by the 
polygon is filled in dependence of the current process value. 
Minimum and maximum values associated with the fill area are 
set as constants or configured as other process values. The area 
can be filled vertically or horizontally. The fill area reference 
line is given in percent.

The line style, line width, pattern and colors for the background 
are defined with > Change > Line attributes/Area attributes 
or through the toolbox with the Line or Area buttons

The color settings for the borders and the flooded area are made 
in the color selection parameter dialog (see Display tab on page 
109). The colors can be made to change as a function of binary 

variables and/or messages.

The static object polygon can no longer be selected individually, but only as a fill 
area. Assigning a different polygon to a given fill area makes the previously 
assigned polygon available again as static graphic object.

For configuration see Process value tab on page 105, Scale tab on page 106, Bit 
allocation tab on page 106, Display tab on page 109, General tab on page 114, 
Tooltip tab on page 130.

Description of parameters specific to fill areas

Display options
Display The switch to the graphic display is compulsory. An existing 

polygon can be selected or a new one created. Return to the 
parameter definition dialog through > Edit > Return to object.
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3.5.19 Alphanumeric display

> Animate > Alphanumeric display  
> A mouse-click fixes the position of the top left-hand corner and, by dragging 
the mouse (rectangle), the size of the alphanumeric display can be adjusted. 
Another click of the mouse at this point concludes the construction of the 
alphanumeric display, 
> Enter data in the parameter definition dialog,  
> Display the text without construction frame.

The current contents of a process value will be displayed either 
numerically or as text in any required format. All system data 
types can be represented.

Even the display of a configured message can be realized with 
an alphanumeric display.

The size, alignment and the fix point can be set with > Change 
> Text attributes or through the Toolbox with the Line or 
Field button.

The color settings for texts and background are made in the 
color selection parameter window (see Display tab on page 
109). The colors can be made to change as a function of binary 

variables and/or messages.

For configuration see Tooltip tab on page 130, Process value tab on page 105, Bit 
allocation tab on page 106, Display tab on page 109, General tab on page 114.

Description of parameters specific to alphanumeric displays

Display

Format A separate format can be specified for each of the up to 8 states that 
the alphanumeric display can assume.

> Click on format area > Press F2 > Select format > OK
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A window is opened, and the various output formats are indicated 
for selection, including formats conforming to the IEC Standard. 
Custom formats can also be created.

Select and create custom formats

After selecting the table column Format on the Display tab and pressing F2, the 
Select data format dialog shows the standard default data formats for the relevant 
data type. The required format can be selected, then accepted with OK.

Select data format.png

Format 
fixed    Default format for the data type; the Add, Edit and Delete 

buttons cannot be selected. 

user-defined 
   Display user-defined formats; the Add, Edit and Delete 

buttons are selectable.

With the settings fixed and user defined you can switch between the format displays. 
In the user defined display mode, a new format can be specified using the Add 
button. A selected format can be deleted with the Delete button or opened through 
the Edit button and changed in another window.
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Add format.png

Name Name of the new format
Format Required formatting. In the Format field you can enter the letter f 

for the required format, for example, ff.ffff for two digits to the left 
and four digits to the right of the decimal point.  
‘-’ serves as a wild card for negative numbers, and a display with a 
leading sign is indicated by ‘+’.

OK Adds the new format to the existing format list.

Examples of fixed data formats: 

The Standard format is available for each data type, see table: 

The following applies to the representation of Real numbers: Due to internal 
representation constraints, conversion of real numbers to displayable values 
cannot be made to more than 7 significant digits. Because of this fact, in the 
standard format, the number of decimal places is adjusted as a function of the 
numeric value. Very large and very small values are displayed in exponential 
notation.

Data type Name Format Example

REAL Float +f.ffffffE+ee -4.670000E-19

Fixed point 1 f.f 3.1

Fixed point 4 f.fff 3.1415

BOOL BOOL (= Standard) b TRUE

Decimal +fff 1
 Engineering - Operator Station Configuration 137



Alphanumeric display 3  Graphic display
 

INT, UINT, DINT, 
UDINT

Binary 2#ffffff 2#101010

BYTE, WORD, 
DWORD

Octal 8#ffffff 8#605301

Decimal 

(= Standard)

+fff –145

Hexadecimal 16#ffff #16#F90C

TIME Duration

(= Standard)

T#fhffmffsffms T#1h35m50s8ms

hh:mm:ss.sss hh:mm:ss.sss 15:36:55:041

hh:mmm hh:mmm 15:36

ss.sss ss.sss 55.041

DT Time of day

(= Standard)

DT#yyyy-mm-dd- 
hh:mm:ss,sss

1998-09-15-
14:36:55,041

Summertime / 

wintertime (*)(1)
DT#yyyy-mm-dd- 
hh:mm:ss,sss a

1998-09-15-
15:36:55,041S

hh:mm:ss.sssa (*) hh:mm:ss.sssa 15:36:55.041S

hh:mm:ss.sss hh:mm:ss.sss 14:36:55.041

dd-mm-yy dd-mm-yy 15-09-98

STRING Pure string Pur s:0:0:n,n ABCDEFG12345

String (= Standard) s:0:0:y,y ‘ABCDEFG$N12345’

(1) If the time to be displayed is in summertime, the value is increased by the summertime 
differential and flagged with S, both in Freelance Operations and in the graphic editor).

Data type Name Format Example
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Examples of user defined data formats:

Example:

Data type Format Example

REAL [+|-| ]f.ff...{E[+|-]ee} 3.141E+00, 3.0, –4.2,

+6.2E-05

INT,UINT,DINT, UDINT [+|-]fff... 35, 4000, +500

BYTE,WORD, DWORD 0f 07

TIME see fixed data format

DT see fixed data format

STRING types s:L{,S}:Z:I:T(1) (2)

(1) Control characters: 
$R Carriage Return (CR),
$N Line Feed (LF),
$L Carriage Return and Line Feed corresp. $R$N,
$T Tabulator,
$ff Hex-coded ASCII character (e.g. ‘$41’ synonymous with ‘A’),
$’ Apostrophe (’),
$$ Dollar sign ($).

(2) Control characters for use with strings: 
L: Number of displayed characters. Default: all
S: Position of the first character to be displayed. 1. Character 1 occupies position 0. Default: 0.
Z: Line to be displayed, for all lines enter 0. Default: 0
I: Display of control characters and margin delimiters; Options y or n. Default: y
T: Interpret tab signs, options y or n. Default: n 

High, Low

Format STRING variable Output STRING variable

s: ‘ABCDEFG$N12345’ ‘ABCDEFG$N12345’

s:11 ‘ABCDEFG$N12345’ ‘ABCDEFG$N

s:10,5 ‘ABCDEFG$N12345’ EFG$N1234

s::2 ‘ABCDEFG$N12345’ 12345’

s:2,1 ‘ABCDEFG$N12345’ A
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s:10   'ABCDEFG$N12345'
       :        :
       0        9
                  and one space   'ABCDEFG$ 
s:10,5 'ABCDEFG$N12345'
       :   ::       :
       0   4:       :
            5       :
            0       8
                  and one space   EFG$N1234

3.5.20 Graphic symbol

A graphic symbol is used to animate static graphic objects. As with the other 
dynamic objects, a maximum of 3 binary process states, and consequently eight 
different states can be configured for this object. Two colors and one static object 
are defined for each state. The static objects can be single objects or groups 
containing several objects (SGM). It is thus possible, for example, to display a line 
in a variety of different colors and also to select completely different representations 
for the various different states.

s:2,1:2 ‘ABCDEFG$N12345’ 2

s:2,0:2 ‘ABCDEFG$N12345’ 1

s:::n ‘ABCDEFG$N12345’ ABCDEFG | | 12345

Format STRING variable Output STRING variable
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The following Animate options are available: 

Do not move 

The static elements of the graphic symbol are output on the 
defined xy coordinates. The coordinates are determined by 
positioning the graphic objects in the graphic display.

Discrete move

The pre-set coordinates at which the graphic symbol is 
displayed are a lookup function of binary variables (maximum 
3). Customized colors can also be specified for the different 
states (maximum of 8).

Continuous move

The graphic symbol is moved continuously between two x/y coordinate points as a 
function of an analog signal. Up to 3 binary variables can also be set in order to 
define a maximum of 8 different color and display states for the graphic symbol.

When a graphic symbol is moved, all associated items are always moved together.

For configuration see Tooltip tab on page 130, General tab on page 114, Bit 
allocation tab on page 106, Display tab on page 109. Depending on the animation 
type see also Scale tab on page 106, Process value tab on page 105.

Color table

By configuring a maximum of 3 binary variables, the graphic symbol can be 
displayed in up to 8 states. For each of these states, a static graphic object and a 
color combination is specified (see also Display tab on page 109).

> Animate > Graphic symbol 
> Fill in the parameter dialog, 
> In the Display dialog select one of the object names and then the Display 
button, 
> In the graphic display select a graphic object or object segment (SGM) or 
create a new one, 
> Return to the parameter definition dialog through > Edit > Return to object 
> OK.
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Object name > Click field > Press F2, 
> Names of the static graphic objects not yet in use are output. 
> Select and OK, 
> Name of the selected graphic object is shown in this field.

or

> Click the required field under Object name  
> Press the Display button to switch to the graphic display, 
> Select existing or newly created static graphic object which is not yet in use  
> Return to parameter definition through > Edit > Return to object  
> Name of the graphic object is entered in the field (if a static graphic object 
without a specified name has been selected, a system-generated name will 
automatically be assigned to this object).

3.5.21 Self-animated object

> Animate > Self-animated object 
> Fill in the parameter definition dialog, 
> In the Display dialog select one of the object names and then the Display 
button, 
> In the graphic display select a graphic object or object segment (SGM) or 
create a new one, 
> Return to parameter definition dialog through > Animate > Return to object 
> OK.

Up to 8 static graphic objects will be displayed in turn for 125 or 250 ms each.

When selecting an existing self-animated object, a construction frame is drawn 
around the displayed symbol. The symbol is displaceable. When a graphic symbol is 
displaced, all associated items are always displaced together.

If the View all check box is ticked in the Display parameter definition dialog, all the 
elements of the selected object that are being used will appear in the display, and - 
when selected - will be surrounded by a common construction frame.

For configuration see Tooltip tab on page 130, Bit allocation tab on page 106, 
Display tab on page 109, General tab on page 114.
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Description of defining parameters specific to self-animated objects 

The variables have different meanings in the bit variables dialog.

Visible/Invisible Depending on the value of a process variable, the graphic object is 
either shown or not shown in the graphic display sequence.

On/Off Depending on the value of a process variable the intermittent 
display of static objects is switched either on or off.

Fast/Slow The speed of animation is made to change with the value of a 
process variable.

Display 

Up to 8 static objects and color combinations can be assigned to a self-animated 
object. Depending on the values of the specified process variables, the next object 
appears in the Graphic display every 125 or 250 ms, the animation is started or 
stopped, or the display of a given object is included or not.

If self-animated objects are used in a Graphic display, the appearance of text objects 
may be unclear.

This problem can be solved by changing the display sequence of the objects in the 
Graphic editor. All self-animated objects are configured in the foreground of the 
other objects through.

3.5.22 Trend window

> Animate > Trend window,  
> Upper left corner of the Trend window is positioned with a mouse click,  
> Define Trend window size by moving the mouse, terminate by clicking mouse, 
> Enter data in the parameter definition dialog,  
> Display Trend window with a frame.

Display up to 6 trends within a trend window.

Select Self-animated graphic object > Edit > Overlap > Foreground
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A Trend window can be positioned and sized within a graphic 
display. Up to 6 trends may be displayed in one window. These 
trends have no history, that is, display of the measured values 
commences when the corresponding graphic is called up. The 
color can be set separately for each trend, as it can for the Trend 
window foreground and background. Standard scaling is 
specified but can be changed within Freelance Operations.

The Trend window can be shown with or without 3-D formatting.

The trend data are captured according to the cycle time defined for the graphic. A 
maximum recording time can be set in TIME format.

Trend window parameters

Trend window.png

Tooltip After selecting the Tooltip button the Activate Tooltip tab appears. 
For the trend window only the check box Text is available.

Trends List of variables specified for display in the Trend window.

The Trend window cannot be moved in Freelance Operations. No trends can be 
added in Freelance Operations.
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Insert On selecting the Insert button, the Trend data dialog appears, 
where the trend variable can be entered with its characteristics.

Edit On selecting a specified variable (click on variable under Trends) 
and pressing the Edit button, the Trend data dialog appears with 
the entries for that trend variable. The entries can be changed in this 
dialog box.

Delete On selecting a specified variable (click on variable under Trends) 
and pressing the Delete button, the variable is deleted from the 
Trend window. 
The display of the scaling axis on the left is determined by the 
settings for the variable selected when exiting this dialog box.

Time axis 
Record duration 

Specify the maximum duration for which the trend can be captured 
without leaving this graphic display. Thereafter each new value 
overwrites the earliest value. Entry is in TIME format (maximum 
approximate value depends on cycle time of the display, for 
example, for a graphic display with cycle time of 1s the maximum 
duration of each trend window is about 2h15m).

Display duration 
Specify the visible time range in the Trend window. Entry is in 
TIME format (maximum approximate 24 days).

Colors 
Background Specify the background color of the Trend window.

Foreground Specify the foreground color (scaling, raster) of the Trend window.

Window Specify Trend area color for the Trend window. Click on color field 
and color selection through the Color selection parameter 
definition dialog (see Color selection on page 87), select color and 
confirm with OK. 
Selected color is displayed in the color field.

Display Depiction of Trend window in the graphic display.

3D    Trend window in 3-D formatting. 
   Trend window without 3-D formatting.
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Scale below 
   The time axis is displayed under the trend window. 
   Trend window displayed without time axis.

Scale left    Scaling is displayed in physical dimensions to the left of the 
Trend window. The scaling values used are those which were 
configured for the variable selected in the trends list upon exiting 
this dialog box. 

   Trend window without left scaling.

Scale right    Scaling is displayed as percentage to the right of the trend 
window. 

   Trend window without right scaling.

Operation Operation of the Trend window from within the graphic display.

Inplace    Operation from within the graphic object. 
   Operation from outside the graphic object.

Buttons per row 
Indication of the visible trends per line.

Single curve options 
   On the bottom part of the trend window on the left, a set of 

buttons is displayed to displace the Y axis of the marked trend. 
   In the trend window there are no buttons for operation 

displayed.

Time    On the bottom part of the trend window on the right a set of 
buttons is displayed to displace the X axis of the marked trend. 

   In the trend window there are no buttons for operation 
displayed.

Trend window variables parametrization 

Insert new Trend window variable

> Press the Insert button in the Trend window parameter definition dialog.
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Change existing trend variable

Trend Data.png

Variable Enter trend variable. Enter directly or select through the F2 key.

Comment A comment with up to 19 characters may be entered; it will be 
displayed to the left of the scaling and be visible only if Scale left is 
selected. Visible only if Scaling left has been checked off. (The size 
of the trend window within the graphic display is defined by the 
maximum length of the comments for all entered variables.)

Tag allocation Enter the name of a tag. It will be possible to open this tag directly 
in Freelance Operations through the Trend window. Enter the tag 
name directly or select through the F2 key.

Value range
Min. Start of scale range in physical units.

Max. End of scale range, in physical units.

Color Specify trend color for the Trend window. Click on color field and 
color selection through the Color Selection parameter definition 
dialog (see Color selection on page 87), select color and confirm with 
OK. Selected color is displayed in the color field.

> Select an existing variable, 
> Press the Edit button in the Trend window parameter definition dialog, 
> In the Trend data dialog, the variable can be configured.
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Interpolation Specify trend depiction.

None    No interpolation is performed,

Linear    Trend is interpolated in a linear fashion,

Stairs    Trend is depicted in discrete steps.

Marker Specify depiction of individual measured values.

None    Individual measured values are not marked,

Point/Pixels    Individual measured values are marked with points,

Rectangle    Individual measured values are marked with rectangles.

di0559uk.bmp

3.5.23 Selection area

> Animate > Selection area 
> A mouse click fixes the position of the top left-hand corner and, by pulling the 
rectangle, the size of the selection area can be specified. Another click of the 
mouse at this point concludes the procedure,  
> Enter data in the parameter definition dialog,  
> Display the select field without frame.
148  Engineering - Operator Station Configuration



3  Graphic display Button, Button field, Radio button
 

A selection area enables tag faceplates to be called up in graphic 
displays. It is also possible to change over into another specific 
display (graphic, group display, trend,..) or to write a fixed or 
operated value to a process variable or to acknowledge 
messages. In case of selection the configured action will be 
carried out.

The field and the border of the selection area can be displayed 
visibly and colored or they can lie transparent underneath other 
graphic objects.

On selecting the select field in the graphic display, a frame 
appears. The select field can then be resized and moved.

For configuration see Tooltip tab on page 130, Display tab on page 109, General tab 
on page 114

3.5.24 Button, Button field, Radio button

> Animate > Button (or Button field or Radio button), 
> Upper left corner of the button is positioned with a mouse click, 
> Define button size by moving the mouse, terminate by clicking the mouse, 
> Enter data in the parameter definition dialog, 
> Display the button with a frame.

These buttons can cause displays or faceplates to be called up, variables to be set to 
preset numeric values, messages to be acknowledged or states to be displayed.

All the buttons, button fields and radio button fields can be displayed 
in a variety of different formats (rectangle, rectangle with rounded 
corners, 3D-rectangle, ellipse).

When a button is configured, either text can be specified for the 
button or any static graphic object can be defined as the button 
symbol. For each separate button, the text or button symbol, as well 
as the text and button colors are specified in the button/radio button 
configuration. The size, orientation and font for the text can be set or 
changed separately from the definition of button parameters using the 
text attribute settings.
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A button press under Freelance Operations does not require any additional 
confirmation, and can write a process variable or open a faceplate or display. A 
button can be linked with any variable and displayed as either pushed or unpushed, 
as well as in different pairs of colors.

A button field consists of one or more buttons with an associated confirm button. 
When entering the parameters, the confirm button is always automatically displayed 
alongside. A button field can comprise up to 25 separate buttons. The buttons in a 
button field can be configured completely independently of one another. By 
pressing a button under Freelance Operations, a value can be entered or a faceplate 
or display called up. The action is not actually performed until the confirm button is 
pressed.

A Radio button field can comprise up to 25 buttons. All the keys in a radio button 
field are linked with the same process variable. A value for this variable can be pre-
set for each key. When one of these keys is pressed under Freelance Operations, the 
value configured is written to the process variable. If the process variable is set to 
one of the configured values, this can be displayed on the corresponding key. With a 
radio button it is not possible to open faceplates or graphics and there is no confirm 
button.

Changing the text attributes of a button, button field or radio button:

> Select button (or button field or radio button),  
> Change > Text attributes or through Toolbox text,  
> Enter or change text displays  
> Accept with OK,  
> Button text appears as it was entered.
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Set button parameters

Button.png

ToolTip After selecting the ToolTip button the Activate Tooltip tab 
appears. The only available check boxes for that button are 
Configured action and Text.

Variable The value of these variables will determine the text and color with 
which the button is displayed, as defined below.

Value Reference value for determining the display format: 
Variable <> Value or Variable = Value.

Button type Display format of the button in the graphic display. 
   As a rectangle. 
   As a 3D rectangle 
   As an ellipse. 
   As a rectangle with rounded corners.

Variable <> Value 
When the variable shown has a value different from the reference 
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value, the button will be displayed with the text or object, text color 
and button color specified here. 

Variable = Value 
When the variable shown is the same as the reference value, the 
button will be displayed with the text, text color and button color 
specified here. Entries are not accepted here until a variable name 
and its reference value have been specified (Variable, Value).

Text/Button object 
Determines whether button text or a graphic object is to be used for 
displaying the button, followed by: 
Specification of the text to be shown on the button, or 
The name of a static graphic object, either entered directly or 
selected after switching to the graphic display through the Display 
button.

Color Colors are selected for the border, button background and (if 
applicable) for the text through the parameter definition dialog (see 
Color selection on page 87).

Show pushed    Button is shown as pushed. 
   Button is shown as not pushed.

Action Calls up the Action parameter definition dialog, see Configuring an 
action on page 115.

Action needs confirmation 
If an action has been configured which requires a confirmation 
before it can be executed - checkbox Action needs confirmation 
selected when configuring this action - you can select a foreground 
and background color for this state (action has been triggered, but is 
not yet written) so that the button will clearly indicate that a 
confirmation is required. See Color selection on page 87.
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Set parameters for button field

Button field.png

Rows/Columns Number of button rows and columns, maximum 5 each. The button 
display is modified accordingly.

OK caption /OK button object 
Text or graphic object for confirm button (pre-set to OK).

Button Diagrammatic representation of the buttons, excluding the confirm 
button. A mouse click on a button opens the dialog for specifying 
the button parameters.

Colors Color definition is relevant to all button texts and the background of 
all buttons.

Unmarked/Marked 
Respective color settings for button texts and buttons when the 
button is not selected or selected. A mouse click on the upper color 
field selects the text color, and a click on the lower color field 
selects the button color, both selections being performed in the 
Color Selection parameter definition dialog (see Color selection on 
page 87).

Pushed    The button is shown as pushed.
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Button type Display format of the button in the graphic display.

Set parameters for radio button fields

Radio button.png

Variable The process variable associated with all the buttons in the radio 
button field. For details of select fields, see Configuring an action 
on page 115.

Rows/Columns Number of button rows and columns, maximum 5 each. The button 
display is modified accordingly.

Button Diagrammatic representation of the buttons. A mouse click on a 
button opens the dialog for specifying the button parameters. For 
details of select fields, see Set parameters for button field on page 
153.

Colors Color definition is relevant to all button texts and the background of 
all buttons.

Variable <>Value / Variable = Value  
Respective color settings for the buttons and button texts when the 
value of the associated variable is different from or the same as the 
specified value. 
A mouse-click on the upper color field selects border and text color, 
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while a click on the lower color field selects the button background 
color, both through the color selection parameter definition dialog 
(see Color selection on page 87).

Pushed    The button is shown as pushed.

   Pushed, the button is shown as not pushed.

Button type Display format of the button in the graphic display.

Set parameters for individual buttons using the button parameter definition 
dialog

The procedure is basically the same as configuring an individual button (see Button, 
Button field, Radio button on page 149) but the following special considerations 
must also be taken into account:

Variable Not used for buttons in a button field, but for radio buttons, the 
associated variable is shown here.

Value For radio buttons, the reference value of the associated variable is 
shown here.

Without function 
   The selected button is eliminated optically and functionally 

from the button field. 
   The button is displayed with the selected color and with the 

text entered.

Action Calls up the Action parameter definition dialog. See Configuring an 
action on page 115.

Variable = Value 
No function
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3.5.25 Tab control

> Animate > Tab control 
> A mouse click fixes the position of the top left-hand corner and, by pulling the 
rectangle, the size of the Tab control can be specified. Another click of the mouse 
at this point concludes the procedure, 
> Enter data in the parameter definition dialog,  
> Display the Tab control with frame.

The Tab control exists as a new dynamic object. Up to 8 tabs can be administered in 
this element. To each tab a group of static and/or dynamic graphic objects can be 
assigned.

By selection of one of these up to 8 tabs the assigned graphic object is put into the 
display foreground in Freelance Operations.

Set parameters for tab control

Tab control.png

Tab for Tabs

Tab Number of possible tabs (1 to 8)

Display Specifies which tab is displayed first.
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Heading Indicates the heading of the corresponding tab (can be selected 
freely).

Object name Indicates the name of the associated graphic object.

Display The button is used to select the graphic object or object group to be 
displayed on the marked tab. The object is selected and switching 
through “Return to object” to the field “Object name” its name is 
entered there.

General Tab 
For General Tab see General tab on page 114.

3.5.26 List of the dynamic objects in a graphic display

> Animate > Reedit... > Display of the object list

The tree structure of the object list is used for displaying all dynamic graphic objects 
in the current graphic display, and for selecting one of them. After an object has 
been selected, it can then be modified using the appropriate parameter definition 
dialog.

3.5.27 Reedit

A graphic object must be selected before its parameters can be changed. This can 
occur in two ways: select the object in the graphic display and double-click on it, or 
use the alternative through the Reedit menu.

All the dynamic graphic objects are displayed in the object list with their type and 
name. A dynamic object that has been previously selected is preselected in the list. 
After an object has been selected, clicking on OK or double-clicking on the list 
entry will open the parameter definition dialog for the selected object.

> Select animated graphic object > Animate > Reedit 
Or 
> Animate > Reedit > Display object list
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For the configuration of Actions, the drawing order of the graphic elements is 
important. If the graphic area in Freelance Operations is clicked, the action of the 
topmost object will be processed; the action of a lowermost object will not be 
accessible.

 

3.5.28 Reediting allocated static objects

Static objects that have been allocated to a dynamic object are no longer directly 
available in the graphic display. This applies to objects that have been configured as 
foreground or background objects as well as to objects used in defining the dynamic 
object states (graphic symbol, Tab control or fill levels). These objects which have 
already been assigned can be modified through the following procedure taking the 
graphic symbol as an example: 

The static object can now be modified using the usual functions.

A corresponding procedure can be used to retrospectively modify foreground and 
background objects as well as polygon figures that have been assigned to a fill level.

An additional step is required in order to retrospectively modify a message type 
symbol: the message type symbol must be detached from the graphic symbol. To 
avoid losing the parameters of the graphic symbol in this process, a new static object 
is defined for the duration of the editing process.

> Click on the graphic symbol and select the Display tab 
> Position the cursor in the field containing the name of the object to be modified 
> Switch to the graphic display using the Display button

The graphic editor is still in “Define parameters for a graphic symbol” mode. 
This mode can be recognized: most of the toolbar buttons are disabled. This 
mode must be exited using the menu command Edit/Return to object.

> Click on the graphic symbol and select the Display tab  
> Position the cursor in the field containing the name of the object to be modified 
> Switch to the graphic display using the Display button 
> Draw any static object  
> Return to graphic symbol parameters through Edit/Return to object  
> Exit parameter definition for graphic symbol with OK.
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The message type symbol can now be modified with the usual functions.

After all the changes have been carried out:

The newly drawn object is now once more freely available, and can be deleted.

3.6 Macro
Graphic objects can be grouped together and stored as a macro. Macros are available 
anywhere in an entire project and can be used as many times as required in graphic 
displays. Subsequent changes to a macro effect all displays in which the macro was 
used.

A macro consists of any combination of static and dynamic graphic objects. All 
attributes of the objects contained in the macro can be defined as macro parameters. 
Each time a macro is used, these attributes, which are part of the macro definition 
are stored; all the values specified as parameters can be individually adjusted at each 
instance of the macro’s use.

Macros can be saved in libraries and thus be made available for other projects. 
Similarly, macro libraries can be loaded, in order to make one or all of their macros 
available in the current project. Library files have the extension .BOL.

All macros which are available in a project, are listed below the Project tree node 
Graphic macro pool (P-MAC). A graphic macro in a project can be created through 
several methods:

• Directly from a graphic display by saving any objects as a macro.

• Create new entry below Graphic macro pool (P-MAC) node in the Project tree 
and edit with the macro editor.

> Select graphic symbol and invoke tab Display 
> Position cursor in the field with the name of the newly drawn object  
> Switch to the graphic display using the Display button 
> Select the changed message type symbol (the newly drawn object will be 
deselected at this point). 
> Return to parameter definition dialog for graphic symbol through Edit  
> Return to object 
> Exit parameter definition dialog for graphic symbol with OK.
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• Open any macro library and load a graphic macro from the library into the 
project.

Macro.png

3.6.1 Library functions

Graphic editor > Macro > Library functions...

Library.png

Library Path and filename of the most recently loaded macro library.

Project In the left portion of the dialog, the graphic macros available in the 
project are listed. An icon with red background displayed on top of 
a macro name indicates a macro that was used in the project.

Library In the right portion, the contents of the most recently loaded macro 
library are listed. 

Load A macro library can be loaded from a data carrier. After loading, the 
macros in the library are displayed in the right portion of the dialog.
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Save After entering a directory and filename all macros listed in the right 
portion of the dialog are saved on the data carrier. The dialog 
display is not changed.

> All marked graphic macros of the project (left portion of the dialog) 
are copied to the library list (right portion).

>> All graphic macros of the project (left portion of the dialog) are 
copied to the library list (right portion).

< All marked graphic macros in the library list (right portion of the 
dialog) are copied for use in the project (left portion).

<< All graphic macros in the library list (right portion of the dialog) are 
copied for use in the project (left portion).

DEL All marked graphic macros are deleted from the list. In the project 
list, only macros can be deleted which have not been used in the 
project.

3.6.2 Draw macro

> Macro > Draw  
> All macros which are currently available in the project are listed. This list is 
identical to the content of the Graphic macro pool (P-MAC) in the Project tree. 
> Select macro > OK,  
> Position the top left corner of the macro with a mouse-click.
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3.6.3 Create macro

> Select one or more graphic objects in the graphic display 
> Macro > Create macro...

The list of all macros available in the project will be displayed. The 
name of the new macro must be entered in the input field above the 
list. After entry of a valid name, the dialog is concluded and the 
selected objects are displayed with a common frame. The 
individual objects are no longer available: they have been replaced 
by a macro reference.

A graphic macro can also be created from the Project tree in the 
Graphic macro pool (P-MAC):

3.6.4 Edit macro

Graphic editor > Macro > Edit... 
Or 
Double-click a Graphic macro in the Project tree

The list of all macros available in the project will be displayed. If a macro had been 
selected in the graphic display, then that macro will be shown selected in the list. 
After a macro is chosen from the list, the graphic editor is called up in macro edit 
mode (macro editor).

In the graphic display the background color is changed and only the graphic objects 
belonging to the macro will be shown.

All graphic editor functions are available in the macro editor. Any combination of 
static and dynamic graphic objects can be added to or deleted from the macro. 
Similarly, all attribute changes and animations possible with the graphic editor are 
also allowed.

Right-click on Graphic macro pool > Insert > next level  
> select Graphic macro MAC
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3.6.5 Define macro parameters

The parameters of a macro are set with the macro editor. All graphic attributes 
defined to be parameters can be adjusted individually in each instance of the 
macro’s use. All values which are not defined to be parameters remain the same in 
all instances and not be varied.

All animation (display and bit variables) must be defined to be parameters.

tu0602us.bmp

In the right portion of the dialog all attributes of all named objects are listed. 
Dynamic objects always have names, so their attributes always appear in the list. 
Static objects whose attributes are to made adjustable as macro parameters must be 
given names (Change > Define object name, see Object name define on page 183).

Graphic attributes are displayed with the name of the object and a system-assigned 
designation for the attribute: <Objectname>.<Attribute designation>.

In the left portion of the dialog, the macro parameters are listed. For each macro 
parameter, the object attributes which will take on that parameter value are shown.

New Parameter 
A new entry in the left dialog field is created with a standard name. 
The standard name can be changed.

> Macro > Parameter...
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Delete Parameter 
The macro parameter selected in the left dialog field is deleted. The 
attributes which were assigned to the deleted parameter are 
transferred to the right portion of the dialog.

< A graphic attribute in the right portion of the dialog is assigned to 
the macro parameter which is selected in the left portion. The macro 
parameter data type is determined when it is assigned its first 
attribute. Any number of attributes of the same type can be assigned 
to a macro parameter. Attributes which have been assigned to a 
macro parameter no longer appear in the right portion of the dialog.

> The assignment of an attribute to a macro parameter is undone. The 
attribute selected in the left portion of the dialog is disassociated 
from the macro parameter and reappears in the list of attributes in 
the right portion.

The following attribute designations are used in the system:

When used in dynamic objects, the designators are extended by sequence numbers 
(usually 1–8 or for objects in a trend window, 1–6) or, for button fields, by 
<column> and <line number>, see also General parameters for dynamic graphic 
objects on page 103.

Attribute
designator

Object type Meaning

Action BG, FA, AD, SEL, SA, 
GS, BUT,BTF, TC

Action which can be triggered by 
this object in Freelance Operations

Bit variable_1..3 BG, FA, AD, SA, GS Bit variables which control attribute 
changes in the object

Caption, Cap-
tion_1..2

TXT, BUT, BTF, BTR, 
CUO

Static text, button text or trend graph 
labeling

Faceplate_1..6 CUO Tag faceplates assigned to the 
curves
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Windowcolor_1..3 CUO Trend window colors:

1: Background color, 2: Grid and la-
beling color, 3: Graph area back-
ground color

Fillcolor, Bordercolor BG, FA, SA, GS, SEL, 
BUT, BTF, BTR

Border and fill color

Fillpattern PIE, ELP, PLG, REC, 
BG, FA, SEL

Fillpattern

Trendcolor_1..6 CUO Curve colors

Line_start ARC, LIN, PLN Starting end of line: round or with ar-
row

Linewidth ARC, PIE, ELP, LIN, 
PLG, PLN, REC, BG, 
FA, SEL

Line width

Line_end ARC, LIN, PLN Ending end of line: round or with ar-
row

Line color ARC, PIE, ELP, LIN, 
PLG, PLN, REC, BG, 
FA, TC

Line color

Line_rounded ARC, LIN, PLG, PLN, 
REC, BG, FA, SEL

Rounding of corners

Line style ARC, PIE, ELP, LIN, 
PLG, PLN, REC, BG, 
FA, SEL

Type of line: solid or dotted, ...

Max_Duration CUO Maximum trend collection period

Reference BG, FA Bar graph and fill area reference line

Text_direction TXT, AD, BUT Text direction: horizontal or vertical

Attribute
designator

Object type Meaning
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Character font AD, BTF, BTR, BUT, 
TC

Character font of the text: Arial, 
Courier New, Lucida Console or MS 
Sans Serif

Character size TXT, AD, BUT, TC Text size: 8, 12, 20 or 26 point

Scale_start, 
Scale_end

BG, FA Scale range for object or curve

Scale_start_1..6, 
Scale_end_1..6

CUO Scale range for curves

Std_Duration CUO Trend display duration

Tab Control_1..8 TC Tab Control

Text_alignment TXT Text alignment: top or bottom

Text_bold TXT, AD, BUT Bold text

Text_fixpoint TXT, AD, BUT Text justification: start, center, end

Text_italic TXT, AD, BUT Italic text

Text_underlined TXT, AD, BUT Underlined text

Textcolor, Back-
ground

TXT, AD, TC Text color and background color

Tooltip AD, BTF, BTR, BUT, 
CUO, FA, GS, SA, 
SEL, TC

Tooltip

Variable BG, FA, AD, BUT, 
BTR

Display variable

Variable_1..6 CUO Variables for trend monitoring

Background color, 
Foreground color

PIE, ELP, PLG, REC, 
BG, FA, SEL, TC

Fill pattern colors

Value BUT, BTR Button value, used for state display

Attribute
designator

Object type Meaning
166  Engineering - Operator Station Configuration



3  Graphic display Specifying parameters for a macro instance
 

3.6.6 Specifying parameters for a macro instance

A macro is inserted into the graphic display with its default settings. All attributes 
which were defined in the macro editor to be parameters can be individually 
adjusted for each instance of the macro’s use. When a macro is selected in the 
graphic display, all the macro’s parameters and their current values are listed.

tu0603_us.png

Edit The selected macro parameter can be specified for the present 
instance of the macro. Depending on the type of parameter, the 
appropriate dialog is opened. Only those entries relevant to the 
specification of the macro parameter are available. All attributes 
which were assigned to this macro parameter in the macro editor 
will take on the new parameter value. The new value will be shown 
in the list.

> Macro > Parameter...
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3.6.7 Resolve macro

With a macro selected in the graphic display > Macro > Resolve will 
disassociate the macro objects. All elements of the macro will be displayed with 
their own construction frames and can be changed individually.

3.6.8 Macro: Resolve in all layers

 

Resolve all layers upon selection of several objects in the graphic display and > 
Macro.

Whilst Resolve macro only applies to the previously selected macro, the Resolve 
in all layers menu item ungroups all selected objects like the graphic symbol or 
tab control, including all underlying grouped macros. 

3.7 Editing and changing display objects

3.7.1Changing the size of a graphic object

Changing the size without altering the height-to-width ratio 

Changing height or width 

Each graphic object be it a static, dynamic, combined object or a macro is displayed 
with its attributes at its assigned position. When selected, a frame with marks 
(handles) at the corners and edge center points surrounds the graphic item. 
(Exceptions are horizontal or vertical lines, on which only the two end points are 
marked). A cursor click outside this rectangle deselects the graphic object, and a 
click within the rectangle selects it again. If one clicks one of the corner handles of 
the frame, the cursor arrow changes. With the mouse button depressed, the frame 
can then be enlarged or reduced while maintaining its height-to-width ratio. After 

> Select > place cursor arrow on a corner handle, > Press mouse button and drag, 
> Frame gets larger or smaller > Release mouse button, > Graphic item/symbol is 
redisplayed.

> Select > place cursor arrow on an edge-center handle > Press mouse button and 
drag, > Frame gets larger or smaller > Release mouse button, > Graphic item/
symbol is redisplayed.
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releasing the button, the graphic object is displayed within the new frame. Clicking 
on an edge-center handle allows the height or width of the object to be changed 
independently.

3.7.2 Move a graphic object

> Select > Cursor arrow into the center > Press mouse button and drag.

After clicking on a graphic object, its frame is displayed. By positioning the cursor 
inside the frame and keeping the left-hand mouse button depressed, the cursor 
changes into a cross. While the mouse button is depressed, the rectangular outline of 
the graphic can be moved about the entire draw area. On releasing the mouse button, 
the item is redisplayed at this point.

When moving several graphic objects (see Selecting multiple graphic objects on 
page 169), a common frame surrounds them all. They can then be moved in exactly 
the same manner as a single graphic object.

3.7.3 Selecting multiple graphic objects

> SHIFT key and click on each of the required graphic objects.

Or

> Position cursor outside the graphic objects to be selected, > With the left mouse 
button depressed, drag a marking rectangle over the area.

Or

> Right-click > Select > All/all static objects /all dynamic objects

In order to change attributes of several graphic objects together, it is possible to 
select various graphic objects at once. With the SHIFT key depressed, the required 
graphic objects can be clicked. Several graphic objects can also be selected together 
with a marking rectangle. In doing so, only those graphic objects are included which 
lie completely within the marking.
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Each graphic object is displayed with its frame. Alterations of the line and area 
attributes effect all selected objects.

Use the following procedure to delete these objects from the graphic display:

After all static objects have been selected the display background can be stored as a 
bitmap with Display > Export > As bitmap to clipboard (or CTRL + B).

If several graphic objects have been selected and if one then wants to select a 
single one of them, click on the free draw area with the left mouse button (all 
graphic objects will be deselected) and proceed as above.

Several objects can be selected and moved together. As a result, it is possible that 
individual objects are moved outside of the visible drawing area. If the selection 
is then canceled, these objects cannot be selected with the common procedures 
The plausibility check generates a message, that the graphic contains objects 
outside the visible area.

> Edit > Select all > all objects in the drawing are selected. 
> Press SHIFT key and left mouse button to select all visible objects.  
> Press DEL key or select Edit > Delete to delete all objects that are not visible 
in the display.

In order to achieve the shortest possible display build-up times under Freelance 
Operations you are strongly advised to store and continue using the static part of 
the display as a bitmap after the editing is finished. In a new graphic display this 
bitmap is imported as a background, and the animation is performed in the 
foreground of this bitmap.
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3.7.4 Edit

Under the menu Edit are listed the items which facilitate the creation and 
modification of displays.

Edit.png

Return to object

> Edit > Return to object...

For some graphic objects (message type symbol, fill area, graphic symbol, self-
animated object, button) there is the possibility of switching to the static graphic 
section from the parameter definition dialog pressing the Display button during 
configuration. The Return to object menu item must be selected in order to return 
to the parameter definition dialog.
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Undo

> Edit > Undo

This is a one-level function and undoes the last change made to the graphic object.

Repeat

> Edit > Repeat 
Or 
Press F8

The last action can be repeated, e.g. deleting the end point of a polyline or drawing 
graphic objects of the same type one after the other, without having to select the 
type again under Draw.

Select single object

If several graphic objects have been selected and one wants to select a single one 
of these, then click on the free draw area with the left mouse button (all graphic 
objects will be deselected) and proceed as above.

> Click graphic object.

Every graphic object selected is marked by a frame.

Select all

> Sweep over the whole drawing area with the left mouse button pressed.

All graphic objects in the drawing area are displayed with their frames. Alterations 
of the attributes impinge on all the graphic objects selected.
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Select graphic objects in the background

If the CTRL key is held down and the mouse clicked, all covered graphic items/
symbols can be selected in turn and then edited.

Group

> Select graphic objects > Edit > Group.

Several graphic objects can be grouped to form a new graphic object with a common 
frame. Alterations of size, attributes or movement now apply to the newly created 
graphic object.

Ungroup

> Select combined graphic object > Edit > Ungroup.

Grouped graphic objects are dispersed into their individual graphic objects. In doing 
so, the common frame disappears and all the components of the combined graphic 
objects are displayed separately with their frames.

Cut

> Select one or more graphic objects > Edit > Cut.

The selected graphic objects are removed from the draw area and saved in a buffer 
memory (not the standard Windows clipboard).

With Paste the saved objects can be reinserted into the graphic one or more times.

No combined graphic objects can be used for the creation of macros. If necessary, 
a grouped graphic must be broken down into its elements (Menu item Edit > 
Ungroup).

Graphic objects which are connected with one another through animation cannot 
be broken down into their elements with this menu item. To separate them, see 
General parameters for dynamic graphic objects on page 103.
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Copy

> Select one or more graphic objects > Edit > Copy

The selected graphic objects are copied and saved in a buffer memory (not the 
standard Windows clipboard).

Paste

> Edit > Paste

The graphic objects which were saved in the buffer memory (not the standard 
Windows clipboard) via a Cut or Copy command can be inserted into the draw area.

Delete

> Select one or more graphic objects > Edit > Delete

The selected graphic objects are removed from the draw area.

Duplicate

> Select one or more graphic objects > Edit > Duplicate

The selected graphic objects are duplicated on the draw area and not saved in the 
buffer memory. The duplicate is displayed slightly offset from the original and is 
selected. It can then immediately be positioned as required (see Move a graphic 
object on page 169).

With Paste the saved objects can be inserted into the graphic one or more times. 
The copied object is copied to match the original and displayed as it was when 
selected. It can be moved to any position. See Move a graphic object on page 169.

Items are inserted at the location from which they were cut or copied.
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Rotate

> Select one or more graphic objects > Edit > Rotate 

Each of the selected graphic objects is rotated 90 degrees counterclockwise around 
the center point of its frame.

Texts are rotated around their fixed reference points.

Mirror

> Select one or more graphic objects > Edit > Mirror > Horizontal or Vertical.

The selected graphic items are mirrored horizontally or vertically, as required. The 
imaginary mirror axis passes through the center point of the surrounding frame.

Texts cannot be mirrored. If text exists in a grouped graphic object, its position is 
mirrored but not the text itself.

Overlap

Serves to determine which of superimposed graphic objects lies in the foreground or 
background.

It should be noted here that in a graphic display under Freelance Operations, all 
static items are located in the background behind any dynamic objects as a result of 
the cyclical redisplay of those dynamic objects. There is, however, one exception. 
See Animate, dynamic graphic objects on page 100.

If self-animated objects are used in a Graphic display, the appearance of text objects 
may be unclear.

This problem can be solved by changing the display sequence of the objects in the 
Graphic editor. All self-animated objects are configured in the foreground of the 
other objects through select Self-animated graphic object > Edit > Overlap > 
Foreground.
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Foreground

The selected graphic object is displayed on top of the other graphic objects. It may 
cover the other items partly or entirely.

Background 

The selected graphic object is displayed underneath the other graphic items. It may 
be partly or completely covered.

In front of object

In case of several overlapping graphic objects, the overlap sequence can be specified 
here.

Behind object

In case of several overlapping graphic objects, the overlap sequence can be specified 
here.

> Select graphic object > Edit > Overlap > Foreground

> Select graphic object > Edit > Overlap > Background

> Select graphic object > Edit > Overlap > In front of object,  
A Select object dialog with OK and Cancel buttons appears,  
> Select the graphic object in front of which the object first selected is to be 
inserted,  
> Accept with OK in the superimposed window. 
Cancel can be used to abort the process at any time.

> Select graphic object > Edit > Overlap > Behind object, 
A Select object dialog with OK and Cancel buttons appears,  
> Select the graphic object behind which the object first selected is to be inserted, 
> Accept with OK in the superimposed window. 
Cancel can be used to abort the process at any time.
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Align

> Select one or several graphic objects > Edit > Align > Left, Horiz. center, 
Right, Top, Vert. center, Bottom, Space evenly across, Space evenly down

The selected graphic objects are aligned to the left, horizontally centered, to the 
right, towards the top, vertically centered or towards the bottom or distributed 
horizontally or vertically. Reference point is always the object selected last.

To graphic pool

> Edit > To graphic pool

The command is used to switch to the graphic pool. If graphic objects are selected, 
they are also added to the graphic pool, being inserted at the same location as in the 
graphic display. 

To display

> Edit > To display.

Switch to the graphic display. If graphic objects are selected, they are accepted into 
the graphic display and inserted at the same location as in the graphic pool. 

Switch contents display/pool

> Edit > Switch contents display/pool.

The entire contents including background color of the graphic display and the 
graphic pool are exchanged.

In this process, some graphic objects may be covered up and thus need to be 
moved. See Move a graphic object on page 169.

In this process, some graphic objects may be covered up and thus need to be 
moved. See Move a graphic object on page 169.
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Insert pool in display

> Edit > Insert pool in display.

The complete display contents of the graphic pool are accepted into the graphic 
display. The background color of the graphic display is retained.

3.7.5 Change attributes

The various line, area and text attributes, as well as the text content of the selected 
graphic objects can be altered. If similar graphic objects or grouped graphic objects 
comprised of several graphic objects of the same type have been selected, then all 
attributes are changed together. A general alteration of attributes, however, to effect 
subsequent graphic objects, must be made through the Toolbox.

Change.png

Several objects can be selected and moved together. As a result, it is possible that 
individual objects are moved outside of the visible drawing area. If afterwards the 
selection is canceled, these objects cannot be selected any more with the common 
procedures The plausibility check generates a message, that the graphic contains 
objects outside the visible area.

Use the following procedure to delete these objects from the graphic display:

> Edit > Select all > All objects in the drawing area are selected.  
> Deselect all visible objects pressing the SHIFT key and the left mouse button. 
> Edit > Delete or press the DEL key to delete all objects not visible in the 
graphic display.

In certain cases, graphic objects may be covered up in this process and thus need 
to be moved. See Move a graphic object on page 169.
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Line attributes

> Change > Line attributes

The graphic object line with the attribute invisible is not particularly useful. It can 
be obtained, if required, through > Edit > Select all.

The line attributes of the selected graphic objects are altered in a dialog window.

Line Attributes.png

Color The attribute Line color is available both for all static graphic 
objects, with the exception of text and bitmaps, and for the dynamic 
objects bargraph, selection field and fill area. You can choose any of 
the 237 colors or invisible. See Color selection on page 87.

Width The attribute line width applies to all static graphic objects with the 
exception of text and bitmaps, and also to the dynamic objects bar 
graph, selection field and fill area. 6 width sizes can be selected. 
Dimensions like 1P, 5P etc. are abstract and depend on the screen 
resolution; they do not refer to the pixel size.

Style The attribute line style applies to all static graphic objects with the 
exception of text and bitmaps, and also to the dynamic objects bar 
graph, selection field and fill area. Continuous, dashed, dotted, or 
dash-dotted can be selected.

Line start/Line end 
The attribute line start/end only applies to the static graphic objects 
line, polyline and arc. An arrow can be selected at the start and/or 
end. The size of the arrow depends on the line width.
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Rounded Corners 
The attribute rounded corners applies to the static graphic objects 
rectangle, polyline and polygon, and to the dynamic objects bar 
graph, selection field and fill area. None, small, medium or large 
can be selected.

Area Attributes

> Change > Area attributes

The area attributes apply to the static graphic objects rectangle, polygon, ellipse and 
circle segment and to the background of the dynamic graphic objects bar graph and 
fill area. The attributes of an area are changed in a dialog box. In the bottom left-
hand corner of that window a preview of the selected area attributes is shown.

Area Attributes.png

Color Any of 237 colors each can be selected for foreground and 
background. The color settings have no effect with the pattern 
setting invisible, and the background color chosen has no effect 
with a filled pattern. See Color selection on page 87.

Pattern Any of 15 patterns or invisible can be selected. For the pattern 
“black bars”, the fill area is displayed in the fill color selected for 
the foreground. For the pattern invisible, the underlying graphic 
items/symbols are visible.

Points

The construction points of the graphic objects polyline and polygon can be moved 
or deleted.
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Delete 

Move 

Text edit

> Change > Text edit.

Selected texts can be altered. An input dialog box with the existing text appears in 
which text can be added or deleted. The text attributes are not effected.

If a combined graphic object contains several texts, the texts are presented for 
modification one after the other.

Text attributes

> Change > Text attributes.

Text attributes apply to the static graphic object text and to the dynamic objects 
alphanumeric display, button, button field and radio button field. The attributes 
of selected texts can be changed in a dialog box.

> Select graphic object polyline or polygon, > Change > Points > Delete > 
Click the point to be deleted. The graphic object remains selected and is 
redisplayed in the altered form.

> Select graphic object polyline or polygon, > Change > Points > Move > Click 
the point to be moved and move it to the required position with left mouse button 
pressed (the frame disappears). > Releasing the left mouse button completes the 
action. The graphic object remains selected and is displayed with the shifted 
points.
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Text Attributes.png

Character font 
Arial, Courier New, Lucida Console, or MS Sans Serif can be 
selected.

Color Any of 237 colors can be selected for foreground and background. 
In addition, invisible may be selected as background.

Size Choice of text size in pixels. Display created with the Graphic 
editor are independent from the screen resolution. Therefore the 
font size is not identical with size used in other Windows 
applications. 
The font size can be increased/decreased by changing a text object 
with the mouse. Likewise the font size of texts configured within a 
graphic symbol, a macro, or within foreground or background 
objects in dynamic graphic objects is automatically adjusted when 
the encompassing objects are changed in size.

Alignment There is a choice between horizontal and vertical text.

Fix point Point used for positioning a text. It is situated on the frame at the 
site specified horizontally at start, middle or end and vertically by 
top or bottom. The Rotate and Horizontal/vertical Alignment 
functions turn the text around this point. The selections Top and 
Bottom are only available for the object Text.

Start    Left frame edge

Middle    Horizontal center of frame
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End    Right frame edge

Top    Upper frame edge

Bottom    Lower frame edge.

Character attribute 
Additional choice for text output between Bold, Italics and 
Underlined.

Object name define

> Select individual or combined graphic object, > Change > Object name 
define...

A name must be unique in a graphic display.

Graphic objects can be provided with names (maximum 12 characters). Using these 
names for the dynamic or graphic symbols they can be moved, shifted or exchanged. 
If a name has already been assigned to the selected graphic object, that name will be 
displayed and can be changed.

Background color

See Background color on page 87.
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3.8 Display options for graphics in the draw area
Under the View menu are the various options relating to viewing graphics on the 
screen.

View.png

3.8.1 View

> View > View display  
> Displays the graphic with no grid, no toolbox and no frame. Most of the menu 
choices are disabled. 
To return for further editing, 
> View > View display, 
> Display the graphic and enable the menus prior to quitting; or click mouse 
within the draw area.

View allows the graphic currently being created to be viewed at zoom level 1 (full 
display) and without the distraction of the editing tools (snap, frame, toolbox). In 
this state most of the menu functions are disabled. Selection from menu or pressing 
the Spacebar once returns to a state in which editing can be performed.

3.8.2 Simulation

> View > Simulation  
> Switch simulation on or off and select the simulation speed. 
> All self-animated graphic objects are shown in the graphic display with the 
chosen simulation attributes.

When in View the simulation attributes come into play for all self-animated objects; 
when the graphic editor is in View the simulation attributes can also be modified.
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3.8.3 Redraw

> View > Redraw  
> Graphic is redisplayed on the screen with no change to the zoom level.

The graphic is reconstructed. This is necessary, if the current display of the graphic 
on the screen does not correspond to the real graphic (parts of the frame may, for 
example, have been left behind).

3.8.4 Zoom

A graphic display is usually displayed with Zoom switched off (Zoom 1-fold) as a 
whole graphic in the draw area. For easier editing it is possible to display a section 
of the graphic with various enlargement. The selected zoom level is indicated in the 
toolbox under Display. 

> View > Zoom > Overview 
The Overview function shows an area corresponding to 9 x the drawing size. The 
actual draw area is shown in the center, marked with a border. This function 
enables objects located completely or partially outside the applicable draw area 
to be displayed and identified.

> View > Zoom > 1:1 
The full graphic display will be shown on screen.

> View > Zoom > Continuous Zoom 
> Display the graphic with a dashed rectangle  
> Use the mouse to move the rectangle over the required region of the graphic  
> Left mouse click for zoom in 
> Right mouse click for zoom out 
> press "ESC" or click the zoom button on toolbar again to stop continuous 
zoom.
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3.8.5 Visible region 

> View > Select visible region 
Or 
Right-click > Graphic is displayed with a dashed rectangle, 
> Use mouse to move rectangle and position it over the required region, 
> Click mouse to display this region with the selected zoom level.

In order to select a display region (for zoom level > 1), Select visible region makes 
a rectangle appear in the draw field. This rectangle can be moved around the draw 
area. Following a mouse click or after pressing the Spacebar, the area located 
underneath it will be displayed enlarged by the selected zoom level.

3.9 General handling functions
All functions necessary for the general handling of graphics are located under the 
Editor menu.

Editor.png

3.9.1 Save

> Project > Save tab

Save graphics is either carried out explicitly with Save or at a prompt when quitting 
the project. During the creation of a Graphic display it is advisable to occasionally 
save in order to keep data loss as low as possible in the event of any unexpected 
problems with the PC. The buffer display is always saved automatically as well.
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3.9.2 Plausibility check

> Editor > Check

The entire graphic display with its static and dynamic graphic items, macros and 
parameter inputs undergoes a plausibility check for errors, missing inputs or 
contradictions. Any errors are listed in a window and must be remedied afterwards. 
A listed error message from the plausibility check can be selected with a double-
click on the message with the left mouse button or by pressing the relevant screen 
button. Either of these actions has the effect of selecting the appropriate graphic 
object for editing.

3.9.3 Export to a file

> Editor > Export > To file...,  
> Specify file type: Freelance metafile or bitmap file 
> Enter path and file name > Save.

Individual graphic displays can be exchanged between different projects through 
files. A file is created with Export. After invoking Export a window is opened in 
which the filename and path should be entered. As export data type you can choose 
between the Freelance file format with the extension DMF or a bitmap file with the 
extension BMP.

3.9.4 Export to clipboard as a bitmap

> Editor > Export > As bitmap to clipboard

The Graphic display is saved on the Windows clipboard as a bitmap, and is thus 
available for further processing by other Windows applications. If graphic objects 
are selected, these are saved as a bitmap; if no object is selected the complete 
Graphic display is saved.
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3.9.5 Import

> Editor > Import 
> Enter path and filename with extension, .DMF or .DXF 
> Open, Graphic display is loaded.

To import a Freelance graphic metafile (extension .DMF) created under Export or a 
file created in AutoCAD (extension .DXF) into a project, Import must be selected. 
After selection, a window is opened, where the path must be entered and the 
filename entered or selected. The corresponding Graphic display is loaded and 
shown.

Instructions for loading AutoCAD files

The graphic files created with AutoCAD exist in the Data Exchange Format (.DXF) 
and will be converted automatically into the Freelance Metafile Format (.DMF) 
during the loading process.

The following items from the full range supported by the AutoCAD language can be 
converted:

The DXF script size (font size) is converted according to the DMF coordinate sizes. 
The resultant font size is compared with the displayable script sizes defined in 
Freelance Engineering and assigned to the size most closely matching the size to be 
converted. The DMF text attribute “RefPoint, Start” is assigned to the DXF text 
attributes “Aligned” and “Adapt”.

An import file can be imported only into a blank Graphic display.

To be convertible, the AutoCAD version must be at least Release 10 or 11.

Shapes, polynets defined with the polyline item, B-Splines and 3D-Polylines, 
3D-Face and viewport items are not convertible.

Line Period Circle Arc String
Solid Text Polyline Block 

(Macros)
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Only text with rotation angles of 0, 90, 180 and 270 degrees can be converted 
properly; the closest angle is assigned in all other cases.

All AutoCAD elements are converted irrespective of their assigned layer. Individual 
layers cannot be blanked out.

Blocks that are rotated or reflected are not converted properly.

Instance objects (SECTION ENTITIES) of any type showing negative coordinates, 
are not converted. An exception here is the element objects of a block.

User Coordinate Systems (UCS), external references (XREF) and nested blocks 
(Insert instruction in block) are not supported.

Color conversion of AutoCAD files

In order to map AutoCad colors to Freelance colors a color conversion table which 
can, if necessary, be changed is entered in the Windows registry editor under the 
[ACADCOLORS] entry.

If no such entry exists, a standard conversion table is used which assigns only the 
AutoCAD color numbers 1-8 to the corresponding DMF color numbers. In this case, 
the DMF color black is assigned to the AutoCAD colors number 9 to 255.

The conversion tables consist of two components. The first entry in Table Entries 
denotes the number of color assignment entries to follow in the conversion table.

The color assignment entries have the following format:

colxx=lacadcolor,hacadcolor,dmfcolor

where:

During conversion, a log file with the file name DXF2DMF.LOG is created or 
updated. Non-convertible elements, non-supported objects and conversion errors 
are logged in this file. The path name of the DXF source and the line number 
within the DXF file are recorded, followed by an error description text.

xx Index of the entry in the color assignment table; must be smaller than 
the TableEntries entry.

lacadcolor Lower AutoCAD color number of the range to which the DMF color 
number is assigned. The lower limit is included in the range.
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The following must be noted when changing the color assignment entries:

The index indicated by xx must be smaller than the value specified in the 
TableEntries entry. A color assignment table is always generated with TableEntries 
entries. Lacadcolor must be smaller or equal to hacadcolor, and they must be in the 
range between 0 and 255. Overlapping ranges should be avoided. See Appendix - 
Color table on page 190.

3.9.6 Exit the graphic editor

> Editor > Close,  
> The graphic display tab is closed.

3.9.7 Copy, rename and delete graphic displays

Naming, renaming and copying a free graphic must be carried out in the Project 
tree.

3.10 Appendix - Color table
The following table lists the colors available for graphic displays.

The color tables have three entries for each color:

• Sequence number = display rank in the graphic editor,

• Internal color number, used, for example, when converting AutoCAD files into 
files for the graphic editor,

• Designator (name) used for the color in the graphic editor.

hacadcolor Upper AutoCAD color number of the range to which the DMF color 
number is assigned. The upper limit is included in the range.

dmfcolor Assigned DMF color number.
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Color table (serial number, internal index, name)   

Static colors

1 0 White 21 28 LightYellow

2 12 Grey93 22 29 Yellow

3 13 Grey80 23 30 MediumYellow

4 14 Grey68 24 31 DarkYellow

5 16 Grey58 25 1 LemonChiffon1

6 15 Grey48 26 2 LemonChiffon2

7 17 Grey35 27 73 LemonChiffon3

8 7 Black 28 3 LemonChiffon4

9 8 Lightblue 29 22 MistyRose1

10 9 MediumBlue 30 74 MistyRose2

11 10 Blue 31 23 MistyRose3

12 11 DarkBlue 32 24 MistyRose4

13 18 LightMagenta 33 76 LightPink

14 19 MediumMagenta 34 80 Pink

15 20 Magenta 35 77 MediumPink

16 21 DarkMagenta 36 78 DarkPink

17 4 LightGreen 37 25 LightPurple

18 5 MediumGreen 38 75 MediumPurple

19 72 Green 39 26 Purple

20 6 DarkGreen 40 27 DarkPurple
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Message colors Signal colors

41 36 RGB1(PrioS1-3) 49 64 SigBlue

42 32 RGB2(Prio1) 50 65 SigCyan

43 33 RGB3(Prio2) 51 67 SigRed

44 34 RGB4(Prio3/4) 52 68 SigGreen

45 35 RGB5 53 69 SigDarkGreen

46 37 RGB6 54 70 SigYellow

47 38 RGB7 55 79 SigOrange

48 39 RGB8 56 190 SigMagenta

57 66 SigBrown

Media colors Free colors

58 44 Flash1(PrioS1-3) 86..104 144..162 Grey1..Grey19

59 40 Flash2(Prio1) 105..123 163..181 Blue1..Blue19

60 41 Flash3(Prio2) 124..139 48..63 Cyan1..Cyan16

61 235 RGB3(Prio2alt.) 140..142 232..234 Cyan17..Cyan19

62 42 Flash4(Prio3/4) 143..161 100..118 Magenta1..Magen-
ta19

63 236 RGB4(Prio3alt.) 162..180 81..99 Green1..Green19

64 43 Flash5 181 119 Yellow1

65..67 45..47 Flash6..Flash8 182..196 129..143 Yellow2..Yellow16

68..76 120..128 Flash9..Flash17 197..199 191..193 Yellow17..Yellow19

77..84 182..189 Flash18..Flash25 200..218 213..231 Brown1..Brown19

85 71 Flash26 219..237 194..212 Red1..Red19

238 Bluish grey: 

Faceplate
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3.11 Appendix - Graphic macro library

di3003uk.bmp

di3004uk.bmp

239 Bluish grey: 

Operation

240 Bluish grey: 

Animate

241 Button color

Media colors Free colors
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di3005uk.bmp

di3006uk.bmp
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 Engineering - Operator Station Configuration 197



Appendix - Graphic macro library 3  Graphic display
 
di3013uk.bmp
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di3016uk.bmp
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di3017uk.bmp

di3018uk.bmp
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di3019uk.bmp

di3020uk.bmp
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di3023uk.bmp

di3024uk.bmp
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di3027uk.bmp

di3028uk.bmp
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di3029uk.bmp

di3030uk.bmp

A file containing the complete set of graphic objects can be found in the 
Freelance software CD at the location \LANG\US\Bonus\3dlib.
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4.1 General description of logs
Logs are used for displaying and permanently logging information and messages 
from the process and from the Freelance system. Logs are output on a printer, screen 
or storage device (through data transfer). A distinction is made between two 
different types of log – event logs and state logs.

4.1.1 Event logs

Event logs are used for logging events such as messages, faults, switching 
activities and operator actions (including user names, if Security lock installed). 
Logging is effected spontaneously when an event occurs.

The signal sequence log is used for acquisition of events and is therefore classified 
with the event logs. A further distinction is made between signal sequence log 1 
and signal sequence log N. Data of signal sequence log 1 are output continuously 
on a printer. By contrast, data of the signal sequence log N are output only on 
completion of logging or per manual intervention.

Various different types of messages can be logged: process messages and system 
messages are generally used to indicate events and faults, while a sequence of event 
log can be used to log switching events in the field with a resolution of 2 ms.

4.1.2 State logs

State logs are used for cyclic logging of process states. These include the cyclic 
acquisition of the state of a tag or the logging of sequences within the process.

The disturbance course log, the operation log and the Excel report are classified as 
state logs. The disturbance course log uses a special disturbance course log 
acquisition module from the process station. The module acquisitions cyclically the 
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input signals and saves them in a ring buffer of maximum 200 values per input 
signal.

4.1.3 Logs in an operator station

A maximum of four operation logs, four disturbance course logs, one signal 
sequence log 1, three signal sequence logs N and any amount of Excel reports can 
be set up for each Operator station (The display and operation of the logs on an 
Operator station is described in the   Operators Manual Freelance Operations ).

The various logs are all programs in the Operator station resource of the Project tree. 
Logs can be set up, deleted, moved and copied in the Project tree.

4.1.4 Sequence of events

In certain applications there is a requirement to log selected binary signals with a 
time stamp in correct chronological order.

In order to achieve this end, the ‘Time stamp’ function must first be activated in a DDI 
001 module (see Engineering Manual, Communication and Fieldbusses, Rack 
Modules). When this function is activated, an extra binary value and time value for 
each channel are made available at the output of this hardware block in addition to the 
‘standard’ 32 binary outputs. When there is an edge change of the binary value on 
these outputs, the current value and the associated time (resolution = update cycle of 
the module) are stored for each channel.

In an FBD program a function block ‘Sequence of events monitoring M_SOE’ must 
be configured (see Engineering Manual, Functions and Function Blocks, 
Monitoring function blocks). This block can be used to transfer binary values with 
time stamp of a DDI 01 to a signal sequence log. In addition, during 
parameterization a DDI 01 block is assigned to this block, and the channels to be 
monitored are defined. 

With each cycle of the user task the binary values and time stamps of the DDI 01 
block are read. When the stored binary values are read and time-stamped, the 
timestamp function in the DDI 01 module is re-activated, that is, the next edge 
change of this binary value can be detected and stored.

For each change of value of a monitored channel that is detected in the M_SOE 
function block, a message is generated using the binary value and the associated 
time stamp; this signal can then be processed further in the signal sequence logs. 
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These messages are not displayed in the Freelance Operations message line or 
message list.

4.2 Signal sequence log

4.2.1Create signal sequence log

A Signal sequence log is created and edited in the Project tree below an Operator 
station resource or in the Common display pool (P-CD). See Engineering Manual 
System Configuration, Project tree. 

4.2.2 Configure signal sequence log

> Double-click the name of the Signal sequence log in the Project tree

The definition of parameters for signal sequence log 1 or signal sequence log N is 
virtually identical; they are therefore described together. Where differences do arise, 
these are shown separately.

The configuration of the signal sequence logs 1 and N consists of a parameter 
definition dialog with 4 tabs. 

Active log files of any type of log must not be deleted manually by the user from 
the Freelance data folder. If an active log file is deleted, the respective log go to 
Emergency mode or will be disturbed.

> Select an Operator station resource or the Common display pool (P-CD) in the 
Project tree

> Edit > Insert next level > Signal sequence log

Or

Right-click > Insert > next level > Signal sequence log

If a signal sequence log is configured in the Common display pool (P-CD), this 
signal sequence log will be available in all Operator stations.
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4.2.3 General data tab - Signal sequence log 1 and N 

SSLN.png

General data
Name The name of the signal sequence log. The name has been fixed in 

the Project tree and cannot be changed here.

Short text A Short text can be assigned to the signal sequence log. Up to 12 
characters can be entered.

Long text A Long text can be assigned to the signal sequence log. Up to 30 
characters can be entered. 
Short and long text are output with the documentation of the project. 
In addition these texts can be configured for the header and footer 
of the printed log, see Header and footer lines in logs on page 238.

Start/Stop
Automatic Logging is automatically started by starting Freelance Operations.

Event controlled 
Logging is started and stopped by an event.

Tag name of event function block 
Name of event starting logging, Engineering Manual Functions 
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and Function Blocks, Monitoring function blocks. Press the 
function key F2 to open a selection list.

Manual The operator at the Operator station can start and stop logging.

Filing

in .. files Specifies the number of log files which are created on the operator 
station PC. The value must be between 1 and 400.

named The name of the log file, which is filed on the operator station PC 
hard disk. The preset name can be accepted, or a new one given.

With max. runtime of ... per file 
The recording period per log file can be defined with this field. 
Entries are made in the IEC 1131-3 format. The value must be 
between 0 and 2147483 s.  
Example: T#2147483s or T#24d20h31m23s

but not more than ... events 
The value must be between 3 and 32767. Default 1000 events. 

Disk space requirements for this log 
The size which log files can attain is displayed in this field. This 
amount of storage should be available on the operator station PC.

The log file size should not exceed 1 Gbyte in order to limit the Freelance 
Operations load time.
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4.2.4 Logs tab – Signal sequence log 1 and N

Logs tab.png

Print
Manual The printing of logs can be activated manually by the operator at 

the Operator station.

Print to Channel 1/2 
Two printer channels are available for log output on the printer. The 
printer channel is selected by activating the corresponding option 
button.

Signal sequence logs should always be printed on a line printer, otherwise the 
formatting may not be correct.

Delete log files
Automatic When the automatic delete option is selected and the configured 

number of files is exceeded, the oldest log file is overwritten by the 
current file.

Manual The operator can select and delete individual log files.

If the automatic delete option is not selected then logging is suspended as soon as 
the maximum number of files has been reached. 
212  Engineering - Operator Station Configuration



4  Logs Logs tab – Signal sequence log 1 and N
 

Record event from 
Local resource D-OS 

Events on the Operator station are logged. These include events 
such as switching operations and operator actions.

Stat. filter    Activates logging of events such as messages and faults on the 
corresponding resource. 

Connection    Indicator showing that a connection is configured to the 
corresponding Operator station.

Filter Either all configured stations or only connected stations are 
included in the events selection list.

Areas Messages from the selected areas are set in the signal sequence log. 
For easier pre-configuration, the buttons “All” and “No” can be 
used to activate or deactivate all plant areas.

Kind of messages 
Configures which messages are to be recorded in the log: process 
messages, system messages and sequence of events.

Enhancements to parameter definition dialog 2 in signal sequence log N

Unlike signal sequence log 1, data of signal sequence log N are not printed 
continuously. Hence the parameter definition dialog 2 differs from signal sequence 
log 1.

Enhancements.png

The following virtual keys are to choose additionally:

Printing 
Automatic Printing takes place automatically after completing the logging.

Delete log files 
Printed files only 

Only printed log files can be deleted manually.
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4.2.5 Format tab – Signal sequence log 1 and N 

Format tab.png

Logging format

Active going/Inactive going 
A separate log can be configured for active going and inactive going 
messages.

Empty No logging

Value Value-based output format for messages (no display of long text)

Long text Long text-based output format for messages (no display of process 
value and dimension)

All Combined output of value-based and long text-based format (only 
allowed for 132 characters per line)

Operat. If operator actions should be logged, a format other than Empty 
must be selected. 
If the optional program Security lock is installed on the Operator 
station, the logged user name at this particular time will also listed 
during the logging of every operator action.

Logging format of acknowledge from 
Message line/list 

The format for a message acknowledgment is ascertained separately 
according to the place of acknowledgment – message line and 
message list.

Page layout Defines page layout for the printout. The Lines per page must be 
entered, and is between 10 and 100 lines. The number of characters 
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per line can be defined as 80 or 132 characters, according to the 
paper format. 

Select the appropriate line length according to the connected line printer.

When specifying a line length of 80 characters and using tag names with a length 
of 16 characters, the time stamp will be printed without a separator, i.e. 
“hhmmssmssS” will be printed instead of “hh:mm:ss.mssS”. 
Example: 12:30:24:333 will be printed as 123024333.

Header/Footer 
The contents of the log header and footer are freely definable. 
They can include both static text and dynamic process variables. 
There is also a collection of globally preset variables. The default is 
a commonly used form of the layout. See Header and footer lines in 
logs on page 238.

Changes in the header and footer lines generally lead to a change in size of the 
log. When the log is downloaded to the operator station, the file size is checked. 
A log whose file sizes have been changed is treated as new log. All existing log 
files are renamed, and therefore no longer displayed in Freelance Operations. The 
files may only be viewed using the Archive Browser.

4.2.6 File transfer tab – Signal sequence log 1 and N

Defining parameters for the signal sequence log through parameter definition dialog 
4 includes copying the stored logs to other data carriers, primarily external devices, 
for data protection and archiving purposes. 
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SSL-FT.png

File transfer

Specifies whether and how a copy of the log file is to be transferred from the 
operator station PC to another PC. The PC selected to receive the archives must 
have a network communication link to the operator station PC and a FTP server 
must be installed.

Archives are usually sent to a target station which is not identical with the operator 
station PC. A further possibility is to export the archive files to a Windows drive on 
the operator station PC. This drive can be mapped on to another PC in the Windows 
network. In this case the station address is its own TCP-IP address.

The Freelance component Archive Browser can be used on the archiving PC to 
visualize the log archives and convert them to CSV format.

Automatic file transfer (FT) 
The mode of file transfer enabling or disabling is specified.

Enable/disable 

Enable FT with Freelance Operations start 
   As soon as Freelance Operations is started, file transfer is 

enabled. 
   File transfer is not automatically enabled when Freelance 

Operations is started.
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Event controlled 
   File transfer is enabled or disabled depending on the status of 

the event module entered. It is mandatory to specify an event 
module. 

Tag name of event 
Press the function key F2 to open a selection list with event function 
blocks.

Manual controlled 
   The operator at the Operator station can enable or disable file 

transfer. 
   File transfer cannot be enabled or disabled manually.

Trigger This area in the parameter dialog is used for specifying how data 
transfer is to be triggered.

After file completion 
   Every completed file is immediately transferred. This mode is 

the default setting for the signal sequence log.

Cyclic, Cycle time 
   This time parameter is used to specify the cyclical time interval 

between copies of the log file being written to the specified target 
station. Entered in time format (for example, T#10h).

Manual FT 

Access    The operator at the Operator station can start the file transfer at 
any time by pressing the File trans. button. 

   File transfer cannot be started spontaneously. The FILE TRANS 
button in the signal sequence log operation in Freelance Operations 
is disabled.

Target The target for the data to be transferred should be specified here. 
Ideally the target station will also have the Archive Browser 
software installed on it, so that the trend and log archive files can be 
displayed and further processed.

Station IP address of the target computer. If the operator station PC is to 
be used as export target, its own IP address must be entered here.
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Path If the archive files are to be copied to a certain directory, the 
complete directory name must be specified here. When using the 
Internet Information Services on the target station, a path 
preselection is possible so that only a backslash \ is entered, 
possibly followed by the rest of the path branch. For example, the 
path C:\ARCHIVE\STATION\SSL for the target computer can 
mean that it diverts all received archives to the preset path 
C:\ARCHIVE, and the incoming archive contributes the path 
information \STATION\SSL. 

It should be noted that when transferring data the target computer is responsible 
for any additional manipulation of the files. The copied file is only temporary and 
is overwritten the next time the corresponding archive is exported.

The target path to the archive storage must be present and may not be write-
protected.

File The export files are stored with the file name entered under Target 
path. 
Example: STATION\SSL\SSL_MANUFACTURE. This file is 
overwritten in every export. Path and file name together may have a 
total length of 100 characters.

Directory [8.3] The files are exported with a generated file name that corresponds 
to the export date in the format “YMMDDhhm.mss”, for example, 
30528162.320.

The file name contains no information about the archive type. Choose a suitable 
path name to ensure it is recognizable afterwards.

Directory The export files are stored in the directory shown under Target path 
with their original name (from parameter definition dialog 1). The 
export date in the format ‘.YYMMDDHHmmss’ is also appended 
to the name (separated by a period). 
Example: SSL_MANUFACTURE.130528162.320. Path and file 
name together may have a total length of 100 characters.

Suffix for incre- mental/complete 
   In order to distinguish between files containing complete data 
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sets and those containing incremental data sets, the suffixes ‘_INC’ 
or ‘_FULL’ are appended to the basic file names. This extension 
renders it impossible for files to be lost by overwriting one another.

FTP timeout FTP utilities are synchronous utilities. In order to prevent the 
system from becoming congested a maximum time should be 
entered here within which a transfer must be completed. If this 
value is exceeded, it causes a system alarm in Freelance Operations.

User name Enter a user name which is known to the FTP server of the target 
station.

Password The password corresponds to the user password for the target 
station.

4.3 Disturbance course log

4.3.1Create disturbance course log

A Disturbance course log is created and edited in the Project tree below an Operator 
station resource or in the Common display pool (P-CD). See Engineering Manual 
System Configuration, Project tree. 

> Select an Operator station resource or the Common display pool (P-CD) in the 
Project tree

> Edit > Insert next level > Disturbance course log

Or

Right-click > Insert > next level > Disturbance course log

If a Disturbance course log is configured in the Common display pool (P-CD), 
this Disturbance course log will be available in all Operator stations.
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4.3.2 Configure disturbance course log  

> Double-click the name of the Disturbance course log in the Project tree

The configuration of a disturbance course log consists of a parameter dialog with 4 
tabs.

4.3.3General tab - Disturbance course log

DCL.png

General data
Name The Name of the signal sequence log. The name has been fixed in 

the Project tree and cannot be changed here.

Short text A Short text can be assigned to the signal sequence log. Up to 12 
characters can be entered.

Long text A Long text can be assigned to the signal sequence log. Up to 30 
characters can be entered. 
Short and long text are output with the documentation of the project. 
In addition these texts can be configured for the header and footer 
of the printed log, see Header and footer lines in logs on page 238.
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Start/Stop
Automatic Logging is automatically started by starting Freelance Operations.

Event controlled 
Logging is started and stopped by an event.

Tag name of event function block 
Name of event starting logging, see Engineering Manual, 
Functions and Function Blocks, Monitoring function blocks. 
Press the function key F2 to open a selection list.

Manual The operator on the operator station can start and stop logging.

Filing 
in .. files Specifies the number of log files which are created on the operator 

station PC. The value must be between 1 and 400. Exactly one 
disturbance course is logged in each file.

named the name of the log file, which is filed on the operator station PC 
hard disk. The preset name can be accepted, or a new one given.

with max. runtime of  ... per file 
The recording period per log file can be defined with this field. 
Entries are made in the IEC 1131-3 format. The value must be 
between 0 and 2147483 s. 
Example: T#2147483s or T#24d20h31m23s

Allocated disturbance log function block 
Name of log acquisition module (see Engineering Manual, 
Functions and Function Blocks, Acquisition blocks). Press the 
function key F2 to open a selection list.

Disk space required 
The size which log files can attain is displayed in this field. This 
amount of storage should be available on the operator station PC.

The log file size should not exceed 1 Gbyte in order to limit the Freelance 
Operations load time.
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4.3.4 Logs tab - Disturbance course log

Log tab.png

Delete log files
Automatic When the automatic delete option is selected and the configured 

number of files is exceeded, the oldest log file is overwritten by the 
current file.

Manual The operator can select and delete individual log files.

Printed files only 
Only printed log files can be deleted manually.

Page layout Defines page layout for the printout. The number of Lines per page 
must be entered and is between 10 and 100 lines. The number of 
characters per line can be defined as 80 or 132 characters, 
according to the paper format.

Header/Footer 
The contents of the log header and footer are freely definable. 
They can include both static text and dynamic process variables. 
There is also a collection of globally preset variables. The default is 

If the automatic delete option is not selected then logging is suspended as soon as 
the maximum number of files has been reached.
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a commonly used form of the layout. See Header and footer lines in 
logs on page 238.

Changes in the header and footer lines generally lead to a change in size of the 
log. When the log is downloaded to the operator station the file size is checked. A 
log whose file sizes have been changed is treated as new log. All existing log files 
are renamed, and therefore no longer displayed in Freelance Operations. The files 
may be viewed using the Archive Browser. 

Print to
Channel 1/2 Two printer channels are available for log output on the printer. The 

printer channel is selected by activating the corresponding option 
button.

Printing
Manual The printing of logs can be activated manually by the operator at the 

Operator station.

Automatic Printing takes place automatically after completing the log.

4.3.5 Variables description tab - Disturbance course log

Variables description.png

No plausibility check is performed on the entries in this tab as the trigger and 
variables are configured permanently with the acquisition function block. Details 
included here serve only to provide information and are included in the log when 
it is printed out.
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Parameters trigger (Trig:)

The time of acquisition of the variables to be parameterized is based on the configured 
signal situation on the disturbance course log acquisition module.

Name Name of the variable that triggers the switch on the disturbance 
course log acquisition module. This name appears for information 
only and is included in the printout. It is not evaluated further as the 
acquisition modules trig input bears this responsibility. Even if the 
trigger is not actuated by a variable, a text must be entered here.

Text Text that will be output as a comment after the name of the trigger 
variable.

Parameters variable specification (V1: - V6:)

Up to six variables can be configured for data acquisition for the disturbance course 
log. The number of variables is limited by the inputs in the disturbance course 
acquisition module.

V1 ... V6 
Name Name of the variable on the process station. This information will 

appear in each printed log.

Text Text output on logging the variable.

Format Required for output of variables in the log (see Select and create 
custom formats on page 136). 

Dimension The dimension assigned to the variable. The dimension is output 
with the variable value during logging.

4.3.6 File transfer tab – Disturbance course log

This parameter definition dialog corresponds to the parameter definition dialog of 
the Signal sequence log, see File transfer tab – Signal sequence log 1 and N on page 
215.
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4.4 Operation log

4.4.1Create operation log

An Operation log is created and edited in the Project tree below an Operator station 
resource or in the Common display pool (P-CD). See Engineering Manual System 
Configuration, Project tree. 

4.4.2 Configure operation log

> Double-click the name of the Operation log in the Project tree

The configuration of an operation log consists of a parameter dialog with 3 tabs.

> Select an Operator station resource or the Common display pool (P-CD) in the 
Project tree

> Edit > Insert next level > Operation log

Or

Right-click > Insert > next level > Operation log

If an Operation log is configured in the Common display pool (P-CD), this 
Operation log will be available in all Operator stations.
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4.4.3General tab – Operation log 

Operation log.png

General data 
Name The name of the signal sequence log. The name has been fixed in 

the Project tree and cannot be changed here.

Short text A Short text can be assigned to the signal sequence log. Up to 12 
characters can be entered.

Long text A Long text can be assigned to the signal sequence log. Up to 30 
characters can be entered. 
Short and long text are output with the documentation of the project. 
In addition these texts can be configured for the header and footer of 
the printed log, see Header and footer lines in logs on page 238.

Start/Stop
Automatic Logging is automatically started by starting Freelance Operations.

Event driven 
Logging is started and stopped by an event.

Tag name of event function block 
Name of event to start logging, see Engineering Manual, 
Functions and Function Blocks, Monitoring function blocks. 
Press the function key F2 to open a selection list.

Manual The operator on the operator station can start and stop logging.
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Text... Configuration operation log text, see Text layout on parameter 
definition dialog – Operation log on page 228.

Filing
in .. files Specifies the number of log files which are created on the operator 

station PC. The value must be between 1 and 400.

named The name of the log file, which is filed on operator station PC hard 
disk. The preset name can be accepted, or a new name can be 
provided.

Cycles With the start of logging, the data is written cyclically to the file 
according to the entered cycle time. The value must be between 1 
and 32767. 

Cycle time This field specifies the interval between two recordings. Entries are 
made in the IEC 1131-3 format. The value must be between 1 and 
2147483 s.  
Example: T#2147483s or T#24d20h31m23s.

The recording time in a file is calculated from the number of cycles * cycle time.

Required disk space for this log 
The size which log files can attain is displayed in this field. This 
amount of storage should be available on the operator stations PC.

The log file size should not exceed 1 Gbyte in order to limit the Freelance 
Operations load time.
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4.4.4 Text layout on parameter definition dialog – Operation log

> Press Text...

Text.png

Parameter definition dialog Text comprises a text field and an operator line. In the 
text field, any text can be mixed with the formatted output of variables in the 
operation log. For more information about display formats, refer to Select and 
create custom formats on page 136.

Up to 200 variables are permitted per operation log. The number of lines and 
columns are defined by the page layout in the parameter definition dialog 2. 

Using the conventional windows mouse and key commands, text can be marked, 
cut, copied and inserted within the text field.

Check One can test whether errors have been made during text entry or 
dynamization.

Each dynamic entry must consist of a variable and a display format.
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Variable During Variable a variable is selected, and its current value should 
be recorded in the log. Dynamic entries are shown in square 
brackets.

To retrospectively assign a different value to a format, position the cursor 
between the square brackets and press Variable.

Place mouse cursor in text field > Variable > select the required variable > OK

Format A variable is assigned to a display format, for example, the number 
of digits after decimal will be defined.

To assign later an other format to a variable, take position between the square 
brackets and press Format.

Position mouse cursor in text field > Format > select the required format > OK

Print preview The forthcoming Print preview of the Operation log is displayed. 
Only the format specification and text are still visible in the print 
preview. The square brackets and the variable names are not 
displayed.

Variable names cannot be changed in the print preview display.

To switch back to the edit mode, press Edit.

Print as table    The operation log is printed in tabular form. This means that 
the part with the dynamic area is repeated, indeed it is repeated as 
many times as the page layout allows.
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4.4.5 Printing tab - Operation log

Print tab.png

Print to
Channel 1/2 Two printer channels are available for log output on the printer. The 

printer channel is selected by activating the corresponding option 
button.

Print 
Manual The printing of logs can be activated manually by the operator at 

the Operator station.

Automatic Printing takes place automatically after completing the log.

Delete log files
Automatic When the automatic delete option is selected and the configured 

number of files is exceeded, the oldest log file is overwritten by the 
current file.

Manual The operator can select and delete individual log files.

Printed files only 
Only printed log files can be deleted manually.

Page layout Defines page layout for the printout. The number of Lines per page 
must be entered and is between 10 and 100 lines. The number of 
characters per line can be defined as 80 or 132 characters, 
according to the paper format.

Header/Footer 
The contents of the log header and footer are freely definable. 
They can include both static text and dynamic process variables. 

If the automatic delete option is not selected then logging is suspended as soon as 
the maximum number of files has been reached.
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There is also a collection of globally preset variables. The default is 
a commonly used form of the layout. See Header and footer lines in 
logs on page 238.

Changes in the header and footer lines generally lead to a change in size of the 
log. When the log is downloaded to the operator station the file size is checked. A 
log whose file sizes have been changed is treated as new log. All existing log files 
are renamed, and therefore no longer displayed in Freelance Operations. The files 
may be viewed using the archive browser.

4.4.6 File transfer tab – Operation log

This parameter definition dialog corresponds to the parameter definition dialog of 
the Signal sequence log. See File transfer tab – Signal sequence log 1 and N on page 
215.

4.5 Reports

4.5.1General description of the Excel report

Reports are used to acquire and store data in user defined Microsoft Excel 
templates. A report consists of several, cyclically created log files. Each log file is 
configured in Freelance Engineering to acquire one or more samples of a set of 
variables. The Freelance report function supports the storage of the acquired values 
in xls format. You can both configure and acquire MS Excel based reports. For each 
new log a new copy of the template is stored in the directory 
<FreelanceData>\reports  
with the configured name enlarged by a sequencing number.
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4.5.2 Create a new report

You can create and edit an Excel report in the project tree below an Operator station 
resource or in the Common display pool (P-CD). See Engineering Manual System 
Configuration, Project tree for a detailed description. 

4.5.3 Excel report configuration

Double-click the name of the Excel report in the Project tree

The configuration of an Excel report consists of a parameter dialog with 3 tabs.

> In the Project tree select an Operator station resource or the Common display 
pool (P-CD) 

> Edit > Insert > next level > Excel report

Or

Right-click > Insert > next level > Excel report

If an Excel report is configured in the Common display pool, this Excel report 
will be available in all Operator stations.
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4.5.4 General data tab - Excel report

Report.png.

General data
Name The Name of an Excel report. The name has been fixed in the 

Project tree and cannot be changed here.

Short text A Short text can be assigned to the Excel reports. Up to 12 
characters can be entered.

Long text A Long text can be assigned to the Excel reports. Up to 30 
characters can be entered.

Start/stop

Automatic Logging is automatically started by starting Freelance Operations.

Manual The operator can start and stop logging on the Operator station. 

Define template 
Defines the template to be used for creation of the Excel reports.

Filing
in .. files Specifies the number of log files which are created on the operator 

station PC. The value must be between 1 and 400.
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named The name of the Excel report file, which is stored on operator 
station PC hard disk. A preset name is assigned to the report. A new 
name can also be specified. 
Example: If the name of the report is “MyReport 1”, then each file 
will be appended with 001, 002, 003 until reaching the number 
specified under in...files.

Start time Date and Time value for the first possible data acquisition of this 
report. No values will be read before this date.

Cycles Number of value sets in one log file, the maximum value is 32767.

Cycle time Period of time between two acquisitions in one log.

Restart after Period of time between two logs, must be greater than (Cycle time * 
Cycles). 
Maximum value is T#24d20h31m23s647ms (maximum for data 
type TIME).

Example configuration

Start time = DT#2013-06-25-08:0:00.000

Cycle time = T#1h0m0s

Cycles = 8

Restart after = T#24h0m0s

The configured Start time (dat and time) is added with the value of Restart after 
until current date and time is nearly reached. If the result of the next addition will be 
bigger than next Start time + Cycle * Cycle time the addition stops. The last value 
is used as the first start time of this log.

The first acquisition of this report is configured at June 25, 2013 at 8:00. Eight set of 
values will be sampled in one log file with a cycle time of one hour. This means the 
variables will be read at 8:00, 9:00, and so on until 15:00. The current log file will 
be closed, the next log file is prepared. Values will be acquired again from 8:00 the 
next day.
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Case 1: The report is started June 25, 2013 6:30, which is earlier than the 
configured acquisition start.

The system will wait until the date and time configured for acquisition start is 
reached. The first set of values is read and stored into the template at 8:00. One 
cycle time later the next set of values will be read. The acquisition follows the 
configuration until 8 value sets are read at 15:00.

Case 2: The report is started June 25, 2013 10:30, which is during a configured 
acquisition cycle.

One set of values is read at once and stored into the template at 10:30. The next set 
of values is read at the next calculated acquisition time at 11:00, which is the fourth 
calculated sample time.

The remaining cycles follow the original configuration until 15:00. In this case the 
first log contains only six value sets. The next log will start the following day and 
will contain 8 sets as configured.

Case 3: The report is started June 25, 2013 18:30, which is after an acquisition 
time period and before the next start time.

The system will wait until the next date and time configured for acquisition start is 
reached. The acquisition starts the next day at 8:00. The acquisition follow original 
configuration of the report.

4.5.5 Printing tab - Excel reports

Report print.png

Print to
Printer 1/2 Two printer channels are available for report output on to printers. 

Select the printer by activating the corresponding radio button in 
front of it.
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Print
Manual The printing of reports can be activated manually by the operator at 

the Operator station.

Automatic Printing takes place automatically after completion of logging of 
values in the report

Delete Log files
Automatic When the automatic delete option is selected and the configured 

number of files is exceeded, the oldest report file is overwritten by 
the current file, just before the Restart after time is about to start.

Manual By checking this option the operator can select individual report 
files and delete them from Freelance Operations.

4.5.6 File transfer tab – Excel reports

This tab is identical to that described under File transfer tab – Signal sequence log 1 
and N on page 215. 

4.5.7 Defining Excel report template

Select General tab > Define template 

Clicking on the Define template button launches the Excel application. The 
functions that are used for data acquisition can be defined. A cell may contain a 
function or normal Excel content. Only one function is allowed per cell. 

Functions are defined using the syntax <GetValue(variable, next position)>

variable Name of a variable in the variable list

next position NEXT_RIGHT, NEXT_LEFT, NEXT_DOWN or NEXT_UP. The 
first read value is stored in the cell with this configuration. For the 
following acquisition the position for the new values is calculated 
following the next position parameter.

If the automatic delete option is not selected then Excel report logging is stopped 
as soon as the maximum number of files has been reached, and it gives a system 
message indicating that the amount of files is exceeded.
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Example: <GetValue(amount,NEXT_RIGHT)>

The following is a screen shot of a report that uses a function for data acquisition.

Excel_repot_us.png

After creation, the template should be saved before closing the Excel application. 
For detailed description on viewing reports refer to the Operator Manual Freelance 
Operations .
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4.6 Header and footer lines in logs
In Project tree > select log > Header or Footer

Log header.png

Hint concerning variable... and format... The selection of variables is identical 
to the procedure for the dynamization of log text, i.e., a variable and its output 
format are specified [Format|VarName]. When a log file is started under 
Freelance Operations, the configured variables are read once, converted to the 
specified format and entered in header or footer line.

Variable... Selecting a process variable (from list)

Format... Selecting a display format (from list).

To assign later an other format to a variable, take position between the square 
brackets and push Format.

Field... Selecting a project-specific field (from list)

Print preview The print preview of the operation log is displayed. Only the format 
specification and text are still visible in the print preview. The 
square brackets and the variable names are not displayed.

Variable names cannot be changed in the print preview display.

The following elements can be incorporated in text for headers and footers:

• Static text that appears unchanged in the header and footer line on each page

• Field references, referring to the Freelance Engineering documentation 
function
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• Variables.

Field references

Project-specific fields (expanded from the project description “into” static text 
during the plausibility check):

$PrjComm Project comment
$PrjDate Date of the project, the format “dd.mm.yy” (length: 8 characters) 

must be specified
$PrjMan Manager of current project
$PrjName Name of project (length: 8 characters)
$PrjNr Project number
$PrjOrd Project order
$PrjOrdNr Order number of project
$ProtType Log type
$ProtST Short text of log
$ProtLT Long text of log
$ProtName Name of log

Dynamic fields (expanded into static text at run time of the log file):
$ProtStart Start time of log file
$ProtStop Stop time of log file

Dynamic fields (expanded into static text when log file is printed out):
$PgNr Page number (maximum length: 3 characters)
$PrintDate Time of printing, consisting of the date and time
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